summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2011-08-01 15:57:50 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2011-08-01 15:57:50 +0000
commit64aa6849935b410fa18480d6af975de9f2803ce1 (patch)
tree89ea0ff76da8f948cfceecfc76c4e56acff0e6cf /sci-visualization/circos
parentAppend no-avx to fix segmentation fault. (diff)
downloadgentoo-2-64aa6849935b410fa18480d6af975de9f2803ce1.tar.gz
gentoo-2-64aa6849935b410fa18480d6af975de9f2803ce1.tar.bz2
gentoo-2-64aa6849935b410fa18480d6af975de9f2803ce1.zip
Version bump
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/circos')
-rw-r--r--sci-visualization/circos/ChangeLog9
-rw-r--r--sci-visualization/circos/circos-0.55.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/sci-visualization/circos/ChangeLog b/sci-visualization/circos/ChangeLog
index 5f4148416125..b904cd1373ef 100644
--- a/sci-visualization/circos/ChangeLog
+++ b/sci-visualization/circos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/circos
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/circos/ChangeLog,v 1.1 2010/05/01 20:33:15 weaver Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/circos/ChangeLog,v 1.2 2011/08/01 15:57:50 weaver Exp $
+
+*circos-0.55 (01 Aug 2011)
+
+ 01 Aug 2011; Andrey Kislyuk <weaver@gentoo.org> +circos-0.55.ebuild:
+ Version bump
*circos-0.52 (01 May 2010)
diff --git a/sci-visualization/circos/circos-0.55.ebuild b/sci-visualization/circos/circos-0.55.ebuild
new file mode 100644
index 000000000000..74b585ecfcf8
--- /dev/null
+++ b/sci-visualization/circos/circos-0.55.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/circos/circos-0.55.ebuild,v 1.1 2011/08/01 15:57:50 weaver Exp $
+
+EAPI=4
+
+DESCRIPTION="Circular layout visualization of genomic and other data"
+HOMEPAGE="http://mkweb.bcgsc.ca/circos/"
+SRC_URI="http://mkweb.bcgsc.ca/circos/distribution/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-perl/config-general
+ dev-perl/GD
+ dev-perl/Math-Bezier
+ dev-perl/Math-Round
+ dev-perl/Math-VecStat
+ dev-perl/Params-Validate
+ dev-perl/Readonly
+ dev-perl/regexp-common
+ >=dev-perl/Set-IntSpan-1.11
+ dev-perl/Graphics-ColorObject
+ dev-perl/List-MoreUtils"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto /opt/${PN}
+ find * -maxdepth 0 -type d | xargs doins -r
+ exeinto /opt/${PN}/bin
+ doexe bin/circos bin/gddiag
+ dosym /opt/${PN}/bin/circos /usr/bin/circos
+ find * -maxdepth 0 -type f | xargs dodoc
+}