summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-10-09 13:01:30 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-10-09 13:01:30 +0000
commitfb8cc1fe145135ba9ebecdea8d7b3b0c3d261d42 (patch)
treec7645abc6ffd012436b0a3177e6213cba19fc253 /sci-physics
parentVersion bump (diff)
downloadgentoo-2-fb8cc1fe145135ba9ebecdea8d7b3b0c3d261d42.tar.gz
gentoo-2-fb8cc1fe145135ba9ebecdea8d7b3b0c3d261d42.tar.bz2
gentoo-2-fb8cc1fe145135ba9ebecdea8d7b3b0c3d261d42.zip
initial commit (thx to Torsten Stuehn)
(Portage version: 2.2.0_alpha136/cvs/Linux i686)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso++/ChangeLog9
-rw-r--r--sci-physics/espresso++/Manifest3
-rw-r--r--sci-physics/espresso++/espresso++-1.3.1.ebuild43
-rw-r--r--sci-physics/espresso++/metadata.xml12
4 files changed, 67 insertions, 0 deletions
diff --git a/sci-physics/espresso++/ChangeLog b/sci-physics/espresso++/ChangeLog
new file mode 100644
index 000000000000..a3a555cd6bfb
--- /dev/null
+++ b/sci-physics/espresso++/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-physics/espresso++
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/ChangeLog,v 1.1 2012/10/09 13:01:30 ottxor Exp $
+
+*espresso++-1.3.1 (09 Oct 2012)
+
+ 09 Oct 2012; Christoph Junghans <ottxor@gentoo.org> +espresso++-1.3.1.ebuild,
+ +metadata.xml:
+ initial commit (thx to Torsten Stuehn)
diff --git a/sci-physics/espresso++/Manifest b/sci-physics/espresso++/Manifest
new file mode 100644
index 000000000000..92937b5a849c
--- /dev/null
+++ b/sci-physics/espresso++/Manifest
@@ -0,0 +1,3 @@
+DIST espressopp_1_3_1.tgz 12439821 SHA256 5f609e745548ba71b3d48d1e5152d57232ddf5cae01c835e6ac057f0883096d8 SHA512 7ddb83d2436d58f03fa1a49828f207ea6adfdba1c7680fc8e4aa29d33235a89c4c9d23114a3dbcc7e8529504731adb921f654ba31a0abb857e7ed1956bb93e4d WHIRLPOOL c3c9f42c85428900335c9b9dc2a8995693cdca5eecd11410debfd6a364fb85ddc1c58d50be53d36389deb82ecf2ed6a3a594ec453ea80f75e153c3d26615066e
+EBUILD espresso++-1.3.1.ebuild 984 SHA256 2a3fea48708dd8ed97d3f1594e9033c303957e4cd4e424915bac8328751be303 SHA512 b0e8650f86a3e6072c64ed81f523fe5b4a502868bf9acbb03f716622f87f2c6d131a2829fbe7450c59378cacee81ce884a7742a1b9c8104129b4edb922474e65 WHIRLPOOL 71f3b405a35401741c3ce939db433a90dc80fb0909d23d3f5ad291f131a391d1f4aaa721885fe6a66f4b28b6f751635b85fa161ea9da8c97b3f38d2938fc0119
+MISC metadata.xml 381 SHA256 65daec50442b73bf9af711c7efe1543872c0c26b363aa251f855e4b54930d1e2 SHA512 5e8b4c9acdef2c3fd70c85d0e1c7978851c00f6a1a5a4b328e94d73490f50893271b8443f11eeb10b202e3d95d163e8b74e0db53af73f523e6550e9250250692 WHIRLPOOL f8a5d40c87d4411396e2cae4358d231e19d0ca89a5406d0be7946309b9f6ebf3dd83f00d14d983cfa14dd839dcf3f9c3ffa69126e4cf5deffe071bac0c36e12c
diff --git a/sci-physics/espresso++/espresso++-1.3.1.ebuild b/sci-physics/espresso++/espresso++-1.3.1.ebuild
new file mode 100644
index 000000000000..13a91534a706
--- /dev/null
+++ b/sci-physics/espresso++/espresso++-1.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/espresso++-1.3.1.ebuild,v 1.1 2012/10/09 13:01:30 ottxor Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit cmake-utils python
+
+DESCRIPTION="extensible, flexible, fast and parallel simulation software for soft matter research"
+HOMEPAGE="https://www.espresso-pp.de"
+
+if [[ ${PV} = 9999 ]]; then
+ EHG_REPO_URI="https://hg.berlios.de/repos/espressopp"
+ EHG_REVISION="default"
+ inherit mercurial
+else
+ SRC_URI="https://www.espresso-pp.de/Download/${PN%++}pp_${PV//./_}.tgz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+IUSE="-system-boost"
+
+RDEPEND="
+ system-boost? ( dev-libs/boost[python,mpi] )
+ virtual/mpi
+ "
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN%++}pp"
+
+DOCS=( AUTHORS NEWS README )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use system-boost EXTERNAL_BOOST)
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-physics/espresso++/metadata.xml b/sci-physics/espresso++/metadata.xml
new file mode 100644
index 000000000000..14341e73edbe
--- /dev/null
+++ b/sci-physics/espresso++/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-physics</herd>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <use>
+ <flag name='system-boost'>Use system boost (<pkg>dev-libs/boost</pkg>) instead of bundled one</flag>
+ </use>
+</pkgmetadata>