summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-01-10 00:08:23 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-01-10 00:08:23 +0000
commite98f902c979bda3c3e103a56b140311352ea4312 (patch)
treea6c6337bbbffcdd254cd1add571a3913719ec3b5 /sci-physics
parentAdded pch local use flag for sci-physics/root (diff)
downloadgentoo-2-e98f902c979bda3c3e103a56b140311352ea4312.tar.gz
gentoo-2-e98f902c979bda3c3e103a56b140311352ea4312.tar.bz2
gentoo-2-e98f902c979bda3c3e103a56b140311352ea4312.zip
Added various patches: one to respect flags in xrootd (needed for afs), one to properly handle -truetype without libXft (bug #204725) and last one for postgresql (bug #203015). Added pch use flag for faster compilation with g++
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/ChangeLog11
-rw-r--r--sci-physics/root/files/root-5.16.00-flags.patch13
-rw-r--r--sci-physics/root/files/root-5.16.00-postgres.patch24
-rw-r--r--sci-physics/root/files/root-5.16.00-xft.patch24
-rw-r--r--sci-physics/root/root-5.16.00-r1.ebuild41
5 files changed, 95 insertions, 18 deletions
diff --git a/sci-physics/root/ChangeLog b/sci-physics/root/ChangeLog
index 2d9336de01cb..a7fc1bb59bd4 100644
--- a/sci-physics/root/ChangeLog
+++ b/sci-physics/root/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/root
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.18 2007/12/16 17:04:42 markusle Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.19 2008/01/10 00:08:22 bicatali Exp $
+
+ 10 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/root-5.16.00-flags.patch, +files/root-5.16.00-postgres.patch,
+ +files/root-5.16.00-xft.patch, root-5.16.00-r1.ebuild:
+ Added various patches: one to respect flags in xrootd (needed for afs), one
+ to properly handle -truetype without libXft (bug #204725) and last one for
+ postgresql (bug #203015). Added pch use flag for faster compilation with g++
16 Dec 2007; Markus Dittrich <markusle@gentoo.org>
+files/root-5.16.00-afs.patch, root-5.16.00-r1.ebuild:
diff --git a/sci-physics/root/files/root-5.16.00-flags.patch b/sci-physics/root/files/root-5.16.00-flags.patch
new file mode 100644
index 000000000000..05bf8e7531f8
--- /dev/null
+++ b/sci-physics/root/files/root-5.16.00-flags.patch
@@ -0,0 +1,13 @@
+--- xrootd/config/GNUmake.env.in.orig 2007-12-13 09:23:25.041447494 +0000
++++ xrootd/config/GNUmake.env.in 2007-12-13 09:24:10.056012728 +0000
+@@ -22,8 +22,8 @@
+ LIBDIR = ../../lib$(ARCHDIR)
+ OBJDIR = ../../obj$(ARCHDIR)
+
+-CFLAGS = $(CF64) $(CFOP) -DXrdDEBUG=$(XrdDEBUG)
+-CFLAGS32 = $(CF32) $(CFOP) -DXrdDEBUG=$(XrdDEBUG)
++CFLAGS = $(CF64) $(OPTFLAGS) $(CFOP) -DXrdDEBUG=$(XrdDEBUG)
++CFLAGS32 = $(CF32) $(OPTFLAGS) $(CFOP) -DXrdDEBUG=$(XrdDEBUG)
+
+ # Extra flags
+ CFTRACE = @tracedbg@
diff --git a/sci-physics/root/files/root-5.16.00-postgres.patch b/sci-physics/root/files/root-5.16.00-postgres.patch
new file mode 100644
index 000000000000..9e48819fe743
--- /dev/null
+++ b/sci-physics/root/files/root-5.16.00-postgres.patch
@@ -0,0 +1,24 @@
+--- ./pgsql/src/TPgSQLServer.cxx~ 2007-06-08 18:45:02.000000000 +0900
++++ ./pgsql/src/TPgSQLServer.cxx 2007-12-22 22:41:25.000000000 +0900
+@@ -344,16 +344,16 @@
+ SetError(-1, "cannot allocate PGSQL_STMT" , "Statement");
+ return 0;
+ }
+- stmt->conn=fPgSQL;
+- stmt->res=PQprepare(fPgSQL,"", sql,0,(const Oid*)0);
++ stmt->fConn=fPgSQL;
++ stmt->fRes=PQprepare(fPgSQL,"", sql,0,(const Oid*)0);
+
+- ExecStatusType stat = PQresultStatus(stmt->res);
++ ExecStatusType stat = PQresultStatus(stmt->fRes);
+ if (pgsql_success(stat)) {
+ fErrorOut=stat;
+ return new TPgSQLStatement(stmt, fErrorOut);
+ } else {
+- SetError(stat, PQresultErrorMessage(stmt->res), "Statement");
+- stmt->conn = 0;
++ SetError(stat, PQresultErrorMessage(stmt->fRes), "Statement");
++ stmt->fConn = 0;
+ delete stmt;
+ return 0;
+ }
diff --git a/sci-physics/root/files/root-5.16.00-xft.patch b/sci-physics/root/files/root-5.16.00-xft.patch
new file mode 100644
index 000000000000..cc0055f5f81a
--- /dev/null
+++ b/sci-physics/root/files/root-5.16.00-xft.patch
@@ -0,0 +1,24 @@
+--- config/Makefile.in.orig 2007-12-12 22:41:28.000000000 +0000
++++ config/Makefile.in 2007-12-12 22:45:27.000000000 +0000
+@@ -36,6 +36,7 @@
+ X11LIBDIR := @x11libdir@
+ XPMLIBDIR := @xpmlibdir@
+ XPMLIB := @xpmlib@
++XFTLIB := @enable_xft@
+
+ EXCEPTIONS := @exceptions@
+ EXPLICITLINK := @explicitlink@
+--- x11ttf/Module.mk.orig 2008-01-09 01:13:23.000000000 +0000
++++ x11ttf/Module.mk 2008-01-09 10:20:00.000000000 +0000
+@@ -31,9 +31,9 @@
+ ALLLIBS += $(X11TTFLIB)
+ ALLMAPS += $(X11TTFMAP)
+
+-#ifeq ($(XFTLIB),yes)
++ifeq ($(XFTLIB),yes)
+ XLIBS += $(X11LIBDIR) -lXft
+-#endif
++endif
+
+ # include all dependency files
+ INCLUDEFILES += $(X11TTFDEP)
diff --git a/sci-physics/root/root-5.16.00-r1.ebuild b/sci-physics/root/root-5.16.00-r1.ebuild
index 5868e77b9614..eeeda55ef9b4 100644
--- a/sci-physics/root/root-5.16.00-r1.ebuild
+++ b/sci-physics/root/root-5.16.00-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.16.00-r1.ebuild,v 1.2 2007/12/16 17:04:42 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.16.00-r1.ebuild,v 1.3 2008/01/10 00:08:22 bicatali Exp $
inherit versionator flag-o-matic eutils toolchain-funcs qt3 fortran
@@ -16,10 +16,10 @@ SLOT="0"
LICENSE="LGPL-2"
KEYWORDS="~amd64 ~sparc ~x86"
-IUSE="afs cern doc fftw kerberos ldap mysql odbc postgres
+IUSE="afs cern doc fftw kerberos ldap mysql odbc pch postgres
python ruby qt3 ssl truetype xml"
-DEPEND="sys-apps/shadow
+RDEPEND="sys-apps/shadow
x11-libs/libXpm
>=sci-libs/gsl-1.8
dev-libs/libpcre
@@ -41,6 +41,9 @@ DEPEND="sys-apps/shadow
odbc? ( dev-db/unixODBC )
truetype? ( x11-libs/libXft )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
S="${WORKDIR}/${PN}"
pkg_setup() {
@@ -48,11 +51,11 @@ pkg_setup() {
elog "You may want to build ROOT with these non Gentoo extra packages:"
elog "AliEn, castor, Chirp, clarens, Globus, Monalisa, Oracle, peac, "
elog "PYTHIA, PYTHIA6, SapDB, SRP, Venus"
- elog "You can use the EXTRA_CONF variable for this."
+ elog "You can use the EXTRA_ECONF variable for this."
elog "Example, for PYTHIA, you would do: "
- elog "EXTRA_CONF=\"--enable-pythia --with-pythia-libdir=/usr/$(get_libdir)\" emerge root"
+ elog "EXTRA_ECONF=\"--enable-pythia --with-pythia-libdir=/usr/$(get_libdir)\" emerge root"
elog
- epause 10
+ epause 7
if use cern; then
FORTRAN="gfortran g77 ifc"
fortran_pkg_setup
@@ -66,30 +69,36 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-fortran.patch
epatch "${DISTDIR}"/${P}-gcc-4.2.patch.bz2
epatch "${FILESDIR}"/${P}-afs.patch
- if [[ ${ARCH} == sparc ]]; then
- cd "${S}/xrootd/src"
- tar xzf xrootd-20060928-1600.src.tgz
- epatch "${FILESDIR}"/sparc-${P}.patch
- tar czf xrootd-20060928-1600.src.tgz xrootd
- fi
+ epatch "${FILESDIR}"/${P}-xft.patch
+ epatch "${FILESDIR}"/${P}-postgres.patch
+ cd "${S}"/xrootd/src
+ tar xzf xrootd-20060928-1600.src.tgz
+ epatch "${FILESDIR}"/sparc-${P}.patch
+ epatch "${FILESDIR}"/${P}-flags.patch
+ tar czf xrootd-20060928-1600.src.tgz xrootd
}
src_compile() {
local target
+ local myconf="--disable-pch"
+ use pch && myconf="--enable-pch"
if [[ "$(tc-getCXX)" == icc* ]]; then
if use amd64; then
target=linuxx8664icc
elif use x86; then
target=linuxicc
fi
+ myconf="--disable-pch"
fi
use afs && append-flags -DAFS_OLD_COM_ERR
+
local myfortran
use cern && myfortran="F77=${FORTRANC}"
# watch: the configure script is not the standard autotools
- # disable-pch: precompiled headers buggy with icc
+ # precompiled headers buggy with icc
+
./configure ${target} \
--prefix=/usr \
@@ -117,7 +126,6 @@ src_compile() {
--disable-chirp \
--disable-dcache \
--disable-globus \
- --disable-pch \
--disable-rfio \
--disable-rpath \
--disable-sapdb \
@@ -154,7 +162,8 @@ src_compile() {
$(use_enable ssl) \
$(use_enable truetype xft) \
$(use_enable xml) \
- ${EXTRA_CONF} \
+ ${myconf} \
+ ${EXTRA_ECONF} \
|| die "configure failed"
emake \