summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-11-27 21:09:29 +0000
committerChristoph Junghans <ottxor@gentoo.org>2011-11-27 21:09:29 +0000
commitd52e5fab761e44ef3b6458590840daab2c1ccc8e (patch)
tree98e400b98b19346d3260181c53a5c1eb2b4e7839 /sci-physics
parentVersion bump (diff)
downloadgentoo-2-d52e5fab761e44ef3b6458590840daab2c1ccc8e.tar.gz
gentoo-2-d52e5fab761e44ef3b6458590840daab2c1ccc8e.tar.bz2
gentoo-2-d52e5fab761e44ef3b6458590840daab2c1ccc8e.zip
Version bump + qa fixes (bug #392123)
(Portage version: 2.2.0_alpha78/cvs/Linux i686)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso/ChangeLog8
-rw-r--r--sci-physics/espresso/espresso-3.0.2.ebuild (renamed from sci-physics/espresso/espresso-3.0.1.ebuild)26
2 files changed, 20 insertions, 14 deletions
diff --git a/sci-physics/espresso/ChangeLog b/sci-physics/espresso/ChangeLog
index 861c6461a10c..6690906a589a 100644
--- a/sci-physics/espresso/ChangeLog
+++ b/sci-physics/espresso/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/espresso
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/ChangeLog,v 1.3 2011/05/27 17:34:23 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/ChangeLog,v 1.4 2011/11/27 21:09:29 ottxor Exp $
+
+*espresso-3.0.2 (27 Nov 2011)
+
+ 27 Nov 2011; Christoph Junghans <ottxor@gentoo.org> -espresso-3.0.1.ebuild,
+ +espresso-3.0.2.ebuild:
+ Version bump + qa fixes (bug #392123)
*espresso-3.0.1 (27 May 2011)
diff --git a/sci-physics/espresso/espresso-3.0.1.ebuild b/sci-physics/espresso/espresso-3.0.2.ebuild
index deeda72ca6bb..e6a1ad825c2f 100644
--- a/sci-physics/espresso/espresso-3.0.1.ebuild
+++ b/sci-physics/espresso/espresso-3.0.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/espresso-3.0.1.ebuild,v 1.1 2011/05/27 17:34:23 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/espresso-3.0.2.ebuild,v 1.1 2011/11/27 21:09:29 ottxor Exp $
-EAPI="4"
+EAPI=4
inherit autotools-utils savedconfig
@@ -12,29 +12,33 @@ HOMEPAGE="http://www.espressomd.org"
if [ "${PV%9999}" != "${PV}" ]; then
EGIT_REPO_URI="git://git.savannah.nongnu.org/espressomd.git"
EGIT_BRANCH="master"
- inherit git
+ inherit git-2
else
SRC_URI="mirror://nongnu/${PN}md/${P}.tar.gz"
fi
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~x86"
IUSE="X doc examples fftw mpi packages test -tk"
REQUIRED_USE="tk? ( X )"
RESTRICT="tk? ( test )"
-RDEPEND="dev-lang/tcl
- X? ( x11-libs/libX11 )
+RDEPEND="
+ dev-lang/tcl
fftw? ( sci-libs/fftw:3.0 )
mpi? ( virtual/mpi )
- tk? ( >=dev-lang/tk-8.4.18-r1 )"
+ tk? ( >=dev-lang/tk-8.4.18-r1 )
+ X? ( x11-libs/libX11 )"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[-nodot]
+ doc? (
+ app-doc/doxygen[-nodot]
virtual/latex-base )"
+DOCS=( AUTHORS NEWS README ChangeLog )
+
src_prepare() {
autotools-utils_src_prepare
eautoreconf
@@ -53,16 +57,12 @@ src_configure() {
src_compile() {
autotools-utils_src_compile
- if use doc; then
- autotools-utils_src_compile doc || die "emake doc failed"
- fi
+ use doc && autotools-utils_src_compile doc
}
src_install() {
autotools-utils_src_install
- dodoc AUTHORS NEWS README ChangeLog
-
insinto /usr/share/${PN}
doins ${AUTOTOOLS_BUILD_DIR}/myconfig-sample.h