summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-12-29 08:44:38 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-12-29 08:44:38 +0000
commitc11a1f269f5ca84aba8c31597e82e2bd04836305 (patch)
treee5b5f37bd09bbadda16796258b0b046e110380de /sci-physics
parentversion bump (diff)
downloadgentoo-2-c11a1f269f5ca84aba8c31597e82e2bd04836305.tar.gz
gentoo-2-c11a1f269f5ca84aba8c31597e82e2bd04836305.tar.bz2
gentoo-2-c11a1f269f5ca84aba8c31597e82e2bd04836305.zip
Version bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/clhep/ChangeLog7
-rw-r--r--sci-physics/clhep/clhep-2.1.2.0.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/sci-physics/clhep/ChangeLog b/sci-physics/clhep/ChangeLog
index 8b25640ae27a..2e6d02f85d5a 100644
--- a/sci-physics/clhep/ChangeLog
+++ b/sci-physics/clhep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/clhep
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.36 2011/08/06 20:50:27 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.37 2011/12/29 08:44:38 bicatali Exp $
+
+*clhep-2.1.2.0 (29 Dec 2011)
+
+ 29 Dec 2011; Sébastien Fabbro <bicatali@gentoo.org> +clhep-2.1.2.0.ebuild:
+ Version bump
*clhep-2.1.1.0 (06 Aug 2011)
diff --git a/sci-physics/clhep/clhep-2.1.2.0.ebuild b/sci-physics/clhep/clhep-2.1.2.0.ebuild
new file mode 100644
index 000000000000..b03702ea4df0
--- /dev/null
+++ b/sci-physics/clhep/clhep-2.1.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.1.2.0.ebuild,v 1.1 2011/12/29 08:44:38 bicatali Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="High Energy Physics C++ library"
+HOMEPAGE="http://www.cern.ch/clhep"
+SRC_URI="http://proj-clhep.web.cern.ch/proj-clhep/DISTRIBUTION/tarFiles/${P}.tgz"
+LICENSE="public-domain"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+
+IUSE="exceptions static-libs"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PV}/CLHEP"
+
+src_prepare() {
+ local d
+ for d in $(find . -name configure.ac); do
+ # respect user flags and fix some compilers stuff
+ sed -i \
+ -e 's:^g++):*g++):g' \
+ -e 's:^icc):icc|icpc):g' \
+ -e '/AM_CXXFLAGS=/s:-O ::g' \
+ ${d} || die
+ # need to rebuild because original configurations
+ # have buggy detection
+ done
+ for d in $(find . -name Makefile.am | xargs grep -l ": %\.cc"); do
+ sed -i \
+ -e 's|: %\.cc|: %\.cc \$(shareddir)|' \
+ -e 's|all-local: \$(shareddir)|all-local: |' \
+ ${d} || die
+ # fixing parallel build
+ done
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable exceptions) \
+ $(use_enable static-libs static)
+}