summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-06-30 18:50:48 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-06-30 18:50:48 +0000
commitbb9a2476432399c2ea3d4377562f51f341eb04e6 (patch)
treef73f7e3e1223cabcda4f5d566514b9674923f900 /sci-physics
parentVersion bump (diff)
downloadgentoo-2-bb9a2476432399c2ea3d4377562f51f341eb04e6.tar.gz
gentoo-2-bb9a2476432399c2ea3d4377562f51f341eb04e6.tar.bz2
gentoo-2-bb9a2476432399c2ea3d4377562f51f341eb04e6.zip
Version bump
(Portage version: 2.2.10.1-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/clhep/ChangeLog7
-rw-r--r--sci-physics/clhep/clhep-2.2.0.1.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/sci-physics/clhep/ChangeLog b/sci-physics/clhep/ChangeLog
index 07e8c591f8fe..40e70bef48bc 100644
--- a/sci-physics/clhep/ChangeLog
+++ b/sci-physics/clhep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/clhep
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.46 2014/05/28 16:35:42 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.47 2014/06/30 18:50:48 bicatali Exp $
+
+*clhep-2.2.0.1 (30 Jun 2014)
+
+ 30 Jun 2014; Sébastien Fabbro <bicatali@gentoo.org> +clhep-2.2.0.1.ebuild:
+ Version bump
*clhep-2.1.4.2 (28 May 2014)
diff --git a/sci-physics/clhep/clhep-2.2.0.1.ebuild b/sci-physics/clhep/clhep-2.2.0.1.ebuild
new file mode 100644
index 000000000000..6a2beca972d3
--- /dev/null
+++ b/sci-physics/clhep/clhep-2.2.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.2.0.1.ebuild,v 1.1 2014/06/30 18:50:48 bicatali Exp $
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+DESCRIPTION="High Energy Physics C++ library"
+HOMEPAGE="http://www.cern.ch/clhep"
+SRC_URI="http://proj-clhep.web.cern.ch/proj-clhep/DISTRIBUTION/tarFiles/${P}.tgz"
+LICENSE="GPL-3 LGPL-3"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc static-libs test"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+S="${WORKDIR}/${PV}/CLHEP"
+
+src_prepare() {
+ # respect flags
+ sed -i -e 's:-O::g' cmake/Modules/ClhepVariables.cmake || die
+ # no batch mode to allow parallel building (bug #437482)
+ sed -i \
+ -e 's:-interaction=batchmode::g' \
+ cmake/Modules/ClhepBuildTex.cmake || die
+ # gentoo doc directory
+ sed -i \
+ -e "/DESTINATION/s:doc:share/doc/${PF}:" \
+ cmake/Modules/ClhepBuildTex.cmake */doc/CMakeLists.txt || die
+ # dont build test if not asked
+ if ! use test; then
+ sed -i \
+ -e '/add_subdirectory(test)/d' \
+ */CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable test TESTING)
+ $(cmake-utils_use doc CLHEP_BUILD_DOCS)
+ )
+ DESTDIR="${ED}" cmake-utils_src_configure
+ use doc && MAKEOPTS+=" -j1"
+}
+
+src_install() {
+ cmake-utils_src_install
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a
+}