summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-03-23 03:35:58 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-03-23 03:35:58 +0000
commitb0efb8a7215ad1d914df618a761eefe9e4d7967d (patch)
tree7b05f9c8b890c78e20925c28851f3fb4b51b9784 /sci-physics
parentremove useless 5th arg to make_desktop_entry (diff)
downloadgentoo-2-b0efb8a7215ad1d914df618a761eefe9e4d7967d.tar.gz
gentoo-2-b0efb8a7215ad1d914df618a761eefe9e4d7967d.tar.bz2
gentoo-2-b0efb8a7215ad1d914df618a761eefe9e4d7967d.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/pythia/ChangeLog8
-rw-r--r--sci-physics/pythia/pythia-8.1.35.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/sci-physics/pythia/ChangeLog b/sci-physics/pythia/ChangeLog
index 0207683f8305..66b55723ee91 100644
--- a/sci-physics/pythia/ChangeLog
+++ b/sci-physics/pythia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/pythia
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.17 2010/01/08 04:41:08 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.18 2010/03/23 03:35:58 bicatali Exp $
+
+*pythia-8.1.35 (23 Mar 2010)
+
+ 23 Mar 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +pythia-8.1.35.ebuild:
+ Version bump
08 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org> pythia-8.1.30.ebuild:
Reduce the number of tests, closing bug #297512
diff --git a/sci-physics/pythia/pythia-8.1.35.ebuild b/sci-physics/pythia/pythia-8.1.35.ebuild
new file mode 100644
index 000000000000..48144597341a
--- /dev/null
+++ b/sci-physics/pythia/pythia-8.1.35.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-8.1.35.ebuild,v 1.1 2010/03/23 03:35:58 bicatali Exp $
+
+EAPI=2
+
+inherit eutils versionator
+
+MV=$(get_major_version)
+MY_P=${PN}$(replace_all_version_separators "" ${PV})
+
+DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
+HOMEPAGE="http://home.thep.lu.se/~torbjorn/Pythia.html"
+SRC_URI="http://home.thep.lu.se/~torbjorn/${PN}${MV}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="8"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="doc examples +hepmc"
+
+DEPEND="hepmc? ( sci-physics/hepmc )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ use hepmc && export HEPMCVERSION=2 HEPMCLOCATION=/usr
+ # homemade configure script creates a useless config.mk
+ rm -f config.mk
+ cat > config.mk <<-EOF
+ SHAREDLIBS = yes
+ LDFLAGSSHARED = -shared ${LDFLAGS}
+ LDFLAGLIBNAME = -Wl,-soname
+ SHAREDSUFFIX = so
+ EOF
+}
+
+src_test() {
+ cd "${S}"/examples
+ # use emake for parallel instead of long runmains
+ emake \
+ $(ls main0{1..9}*.cc | sed -e 's/.cc//') \
+ || die "emake tests failed"
+ for i in main0{1..9}*.exe; do
+ ./${i} > ${i}.out || die "test ${i} failed"
+ done
+ if use hepmc; then
+ emake main31 main32 || die "emake tests for hepmc failed"
+ ./main31.exe > main31.exe.out || die
+ ./main32.exe main32.cmnd hepmcout32.dat > main32.exe.out || die
+ fi
+ emake clean && rm -f main*out
+}
+
+src_install() {
+ dolib.so lib/*so || die "shared lib install failed"
+ dolib.a lib/archive/* || die "static lib install failed"
+
+ insinto /usr/include/${PN}
+ doins include/* || die "headers install failed"
+
+ # xmldoc needed by root
+ insinto /usr/share/${PN}
+ doins -r xmldoc || die "xmldoc install failed"
+ echo PYTHIA8DATA=/usr/share/${PN}/xmldoc >> 99pythia8
+ doenvd 99pythia8
+
+ insinto /usr/share/doc/${PF}
+ dodoc GUIDELINES AUTHORS README
+ if use doc; then
+ doins worksheet.pdf || die "doc install failed"
+ mv htmldoc html
+ doins -r html || die "html doc install failed"
+ fi
+ if use examples; then
+ doins -r examples || die "examples install failed"
+ fi
+}