summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-08-11 21:33:08 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-08-11 21:33:08 +0000
commit922cf1bb290231a0e8b958f079d0ff4a607fe8a6 (patch)
tree1104365aa56a716d24e6b20cfa8398df2e192dec /sci-physics
parentAdd missing DEPEND, bug #515146. (diff)
downloadgentoo-2-922cf1bb290231a0e8b958f079d0ff4a607fe8a6.tar.gz
gentoo-2-922cf1bb290231a0e8b958f079d0ff4a607fe8a6.tar.bz2
gentoo-2-922cf1bb290231a0e8b958f079d0ff4a607fe8a6.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso/ChangeLog10
-rw-r--r--sci-physics/espresso/espresso-3.2.0.ebuild4
-rw-r--r--sci-physics/espresso/espresso-3.3.0.ebuild135
-rw-r--r--sci-physics/espresso/metadata.xml1
4 files changed, 146 insertions, 4 deletions
diff --git a/sci-physics/espresso/ChangeLog b/sci-physics/espresso/ChangeLog
index ee34fe2b43ff..2ddac3a539a8 100644
--- a/sci-physics/espresso/ChangeLog
+++ b/sci-physics/espresso/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/espresso
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/ChangeLog,v 1.16 2013/12/11 12:44:33 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/ChangeLog,v 1.17 2014/08/11 21:33:08 ottxor Exp $
+
+*espresso-3.3.0 (11 Aug 2014)
+
+ 11 Aug 2014; Christoph Junghans <ottxor@gentoo.org> +espresso-3.3.0.ebuild,
+ espresso-3.2.0.ebuild, metadata.xml:
+ version bump
11 Dec 2013; Justin Lecher <jlec@gentoo.org> espresso-3.2.0.ebuild:
Drop unnecessay dep
diff --git a/sci-physics/espresso/espresso-3.2.0.ebuild b/sci-physics/espresso/espresso-3.2.0.ebuild
index d37267030534..9b8666b3c488 100644
--- a/sci-physics/espresso/espresso-3.2.0.ebuild
+++ b/sci-physics/espresso/espresso-3.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/espresso-3.2.0.ebuild,v 1.3 2013/12/11 12:44:33 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/espresso-3.2.0.ebuild,v 1.4 2014/08/11 21:33:08 ottxor Exp $
EAPI=5
diff --git a/sci-physics/espresso/espresso-3.3.0.ebuild b/sci-physics/espresso/espresso-3.3.0.ebuild
new file mode 100644
index 000000000000..78cdf623c181
--- /dev/null
+++ b/sci-physics/espresso/espresso-3.3.0.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/espresso-3.3.0.ebuild,v 1.1 2014/08/11 21:33:08 ottxor Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils python-single-r1 savedconfig
+
+DESCRIPTION="Extensible Simulation Package for Research on Soft matter"
+HOMEPAGE="http://www.espressomd.org"
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="git://git.savannah.nongnu.org/espressomd.git"
+ EGIT_BRANCH="master"
+ AUTOTOOLS_AUTORECONF=1
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="mirror://nongnu/${PN}md/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="X cuda doc examples +fftw mpi packages python test -tk"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ tk? ( X )"
+
+RESTRICT="tk? ( test )"
+
+RDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+ dev-lang/tcl
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
+ fftw? ( sci-libs/fftw:3.0 )
+ mpi? ( virtual/mpi )
+ packages? ( dev-tcltk/tcllib )
+ tk? ( >=dev-lang/tk-8.4.18-r1 )
+ X? ( x11-libs/libX11 )"
+
+DEPEND="${RDEPEND}
+ doc? (
+ || ( <app-doc/doxygen-1.7.6.1[-nodot] >=app-doc/doxygen-1.7.6.1[dot] )
+ dev-texlive/texlive-latexextra
+ virtual/latex-base )"
+
+DOCS=( AUTHORS NEWS README ChangeLog )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ use cuda && cuda_src_prepare
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ myeconfargs=(
+ $(use_with fftw) \
+ $(use_with cuda) \
+ $(use_with python python-interface) \
+ $(use_with mpi) \
+ $(use_with tk) \
+ $(use_with X x)
+ )
+ CXX=$(usex mpi "mpic++" "$(tc-getCXX)") autotools-utils_src_configure
+ restore_config myconfig.hpp
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile doxygen
+ [[ ${PV} = 9999 ]] && use doc && autotools-utils_src_compile ug dg tutorials
+}
+
+src_install() {
+ local i
+
+ autotools-utils_src_install
+
+ insinto /usr/share/${PN}
+ doins ${AUTOTOOLS_BUILD_DIR}/myconfig-sample.hpp
+
+ save_config ${AUTOTOOLS_BUILD_DIR}/src/core/myconfig-final.hpp
+
+ if use doc; then
+ if [[ ${PV} = 9999 ]] ; then
+ newdoc "${AUTOTOOLS_BUILD_DIR}"/doc/dg/dg.pdf developer_guide.pdf
+ newdoc "${AUTOTOOLS_BUILD_DIR}"/doc/ug/ug.pdf user_guide.pdf
+ for i in "${AUTOTOOLS_BUILD_DIR}"/doc/tutorials/*/[0-9]*.pdf; do
+ newdoc "${i}" "tutorial_${i##*/}"
+ done
+ else
+ newdoc "${S}"/doc/ug/ug.pdf user_guide.pdf
+ for i in "${S}"/doc/tutorials/*/[0-9]*.pdf; do
+ newdoc "${i}" "tutorial_${i##*/}"
+ done
+ fi
+ dohtml -r "${AUTOTOOLS_BUILD_DIR}"/doc/doxygen/html/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins -r samples/*
+ fi
+
+ if use packages; then
+ insinto /usr/share/${PN}/packages
+ doins -r packages/*
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "Please read and cite:"
+ elog "ESPResSo, Comput. Phys. Commun. 174(9) ,704, 2006."
+ elog "http://dx.doi.org/10.1016/j.cpc.2005.10.005"
+ echo
+ elog "If you need more features, change"
+ elog "/etc/portage/savedconfig/${CATEGORY}/${PF}"
+ elog "and reemerge with USE=savedconfig"
+ echo
+ elog "For a full feature list see:"
+ elog "/usr/share/${PN}/myconfig-sample.h"
+ echo
+}
diff --git a/sci-physics/espresso/metadata.xml b/sci-physics/espresso/metadata.xml
index ca1d5d80b67c..1ef3470bdd04 100644
--- a/sci-physics/espresso/metadata.xml
+++ b/sci-physics/espresso/metadata.xml
@@ -7,6 +7,7 @@
<name>Christoph Junghans</name>
</maintainer>
<use>
+ <flag name="cuda">Enable cuda support</flag>
<flag name="examples">Installs the examples</flag>
<flag name="packages">Installs extra subpackages</flag>
</use>