summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-07-07 23:47:57 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-07-07 23:47:57 +0000
commit86d37cce48178aa2583324b9e1f8886718cebc21 (patch)
treea200b93b3e50e8799b110c266158788c21c07553 /sci-physics
parentpkg-config files now only link to the mkl directory. Fixed some syntax and li... (diff)
downloadgentoo-2-86d37cce48178aa2583324b9e1f8886718cebc21.tar.gz
gentoo-2-86d37cce48178aa2583324b9e1f8886718cebc21.tar.bz2
gentoo-2-86d37cce48178aa2583324b9e1f8886718cebc21.zip
Added link for mandatory fortran library.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/camfr/ChangeLog8
-rw-r--r--sci-physics/camfr/camfr-20070717-r1.ebuild76
2 files changed, 83 insertions, 1 deletions
diff --git a/sci-physics/camfr/ChangeLog b/sci-physics/camfr/ChangeLog
index 01be7911b624..37068edbd6fc 100644
--- a/sci-physics/camfr/ChangeLog
+++ b/sci-physics/camfr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/camfr
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/ChangeLog,v 1.10 2008/07/06 09:56:28 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/ChangeLog,v 1.11 2008/07/07 23:47:57 bicatali Exp $
+
+*camfr-20070717-r1 (07 Jul 2008)
+
+ 07 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +camfr-20070717-r1.ebuild:
+ Added link for mandatory fortran library.
06 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org>
camfr-20070717.ebuild:
diff --git a/sci-physics/camfr/camfr-20070717-r1.ebuild b/sci-physics/camfr/camfr-20070717-r1.ebuild
new file mode 100644
index 000000000000..6aba83ae00c8
--- /dev/null
+++ b/sci-physics/camfr/camfr-20070717-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/camfr-20070717-r1.ebuild,v 1.1 2008/07/07 23:47:57 bicatali Exp $
+
+inherit eutils distutils fortran
+
+DESCRIPTION="Full vectorial Maxwell solver based on eigenmode expansion"
+HOMEPAGE="http://camfr.sourceforge.net/"
+SRC_URI="mirror://sourceforge/camfr/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sci-libs/scipy
+ dev-python/matplotlib
+ dev-libs/boost
+ dev-libs/blitz
+ dev-python/imaging
+ virtual/lapack"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/scons-0.98"
+
+S="${WORKDIR}/${P/-/_}"
+
+pkg_setup() {
+ if ! built_with_use dev-lang/python tk || \
+ ! built_with_use dev-python/imaging tk ; then
+ eerror "Python and/or imaging don't have Tk support enabled."
+ eerror "Set the tk USE flag and reinstall python and imaging before continuing."
+ die
+ fi
+ FORTRAN="gfortran g77"
+ fortran_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ cp machine_cfg.py{.gentoo,} || die
+ sed -i -e '/^library_dirs/d' -e '/^libs/d' machine_cfg.py || die
+ local lapack_libs=
+ for x in $(pkg-config --libs-only-l lapack); do
+ lapack_libs="${lapack_libs}, \"${x#-l}\""
+ done
+ local lapack_libdirs=
+ for x in $(pkg-config --libs-only-L lapack); do
+ lapack_libdirs="${lapack_libdirs}, \"${x#-L}\""
+ done
+ local libfort
+ case ${FORTRANC} in
+ gfortran) libfort=gfortran ;;
+ g77) libfort=g2c ;;
+ esac
+ cat <<-EOF >> machine_cfg.py
+ library_dirs = [${lapack_libdirs#,}]
+ libs = ["boost_python", "${libfort}", "blitz"${lapack_libs}]
+ EOF
+}
+
+src_test() {
+ # trick to avoid X in testing (bug #229753)
+ echo "backend : Agg" > matplotlibrc
+ PYTHONPATH=".:visualisation" ${python} testsuite/camfr_test.py \
+ || die "tests failed"
+ rm -f matplotlibrc
+}
+
+src_install() {
+ distutils_src_install
+ dodoc docs/camfr.pdf || die "doc install failed"
+}