summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-11-28 22:25:42 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-11-28 22:25:42 +0000
commit4f7b1b68e30b843066f96b16d9f3f7847c657a9b (patch)
tree151099e72e4338f4e08cc2038b076e9cddf96a9b /sci-physics
parentRevbump and remove old. Update and rename init script. (diff)
downloadgentoo-2-4f7b1b68e30b843066f96b16d9f3f7847c657a9b.tar.gz
gentoo-2-4f7b1b68e30b843066f96b16d9f3f7847c657a9b.tar.bz2
gentoo-2-4f7b1b68e30b843066f96b16d9f3f7847c657a9b.zip
Version bump
(Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/bullet/ChangeLog8
-rw-r--r--sci-physics/bullet/bullet-2.78.ebuild3
-rw-r--r--sci-physics/bullet/bullet-2.79.ebuild44
3 files changed, 53 insertions, 2 deletions
diff --git a/sci-physics/bullet/ChangeLog b/sci-physics/bullet/ChangeLog
index 4dc1466d5800..c024bc849daf 100644
--- a/sci-physics/bullet/ChangeLog
+++ b/sci-physics/bullet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/bullet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.23 2011/04/17 11:53:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.24 2011/11/28 22:25:42 bicatali Exp $
+
+*bullet-2.79 (28 Nov 2011)
+
+ 28 Nov 2011; Sébastien Fabbro <bicatali@gentoo.org> bullet-2.78.ebuild,
+ +bullet-2.79.ebuild:
+ Version bump
*bullet-2.78 (17 Apr 2011)
diff --git a/sci-physics/bullet/bullet-2.78.ebuild b/sci-physics/bullet/bullet-2.78.ebuild
index c7f369f51558..cd71358e69cd 100644
--- a/sci-physics/bullet/bullet-2.78.ebuild
+++ b/sci-physics/bullet/bullet-2.78.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.78.ebuild,v 1.1 2011/04/17 11:53:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.78.ebuild,v 1.2 2011/11/28 22:25:42 bicatali Exp $
EAPI=2
@@ -29,6 +29,7 @@ src_configure() {
-DBUILD_SHARED_LIBS=ON
-DBUILD_CPU_DEMOS=OFF
-DBUILD_DEMOS=OFF
+ -DUSE_GRAPHICAL_BENCHMARK=OFF
-DINSTALL_LIBS=ON
-DINSTALL_EXTRA_LIBS=ON
$(cmake-utils_use_build extras EXTRAS)
diff --git a/sci-physics/bullet/bullet-2.79.ebuild b/sci-physics/bullet/bullet-2.79.ebuild
new file mode 100644
index 000000000000..9b343ea77478
--- /dev/null
+++ b/sci-physics/bullet/bullet-2.79.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.79.ebuild,v 1.1 2011/11/28 22:25:42 bicatali Exp $
+
+EAPI=4
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Continuous Collision Detection and Physics Library"
+HOMEPAGE="http://www.bulletphysics.com/"
+SRC_URI="http://bullet.googlecode.com/files/${P}-rev2440.tgz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="doc double-precision examples extras"
+
+RDEPEND="virtual/opengl"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.78-soversion.patch )
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_CPU_DEMOS=OFF
+ -DBUILD_DEMOS=OFF
+ -DUSE_GRAPHICAL_BENCHMARK=OFF
+ -DINSTALL_LIBS=ON
+ -DINSTALL_EXTRA_LIBS=ON
+ $(cmake-utils_use_build extras EXTRAS)
+ $(cmake-utils_use_use double-precision DOUBLE_PRECISION)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ default
+ use doc && dodoc *.pdf
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r Extras Demos
+ fi
+}