summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-14 22:50:51 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-14 22:50:51 +0000
commit32948ddbe4786fcb8ac6ebd39d99388678808681 (patch)
tree594c1c61dd87910eb1e01bf7d8639f4d977b9a09 /sci-physics
parentStable for x86, wrt bug #430494 (diff)
downloadgentoo-2-32948ddbe4786fcb8ac6ebd39d99388678808681.tar.gz
gentoo-2-32948ddbe4786fcb8ac6ebd39d99388678808681.tar.bz2
gentoo-2-32948ddbe4786fcb8ac6ebd39d99388678808681.zip
Version bump, removed LDFLAGS from the pkg-config flag, added a mpb flag to compile against sci-physics/mpb, avoiding automagic
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/meep/ChangeLog13
-rw-r--r--sci-physics/meep/files/meep-1.2-no-auto-mpb.patch16
-rw-r--r--sci-physics/meep/files/meep-1.2-pc-no-ldflags.patch12
-rw-r--r--sci-physics/meep/meep-1.2.ebuild60
-rw-r--r--sci-physics/meep/metadata.xml3
5 files changed, 101 insertions, 3 deletions
diff --git a/sci-physics/meep/ChangeLog b/sci-physics/meep/ChangeLog
index bec86fd608af..3f8da1741d6d 100644
--- a/sci-physics/meep/ChangeLog
+++ b/sci-physics/meep/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-physics/meep
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/meep/ChangeLog,v 1.16 2010/06/23 20:18:30 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/meep/ChangeLog,v 1.17 2012/08/14 22:50:51 bicatali Exp $
+
+*meep-1.2 (14 Aug 2012)
+
+ 14 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/meep-1.2-no-auto-mpb.patch, +files/meep-1.2-pc-no-ldflags.patch,
+ +meep-1.2.ebuild, metadata.xml:
+ Version bump, removed LDFLAGS from the pkg-config flag, added a mpb flag to
+ compile against sci-physics/mpb, avoiding automagic
23 Jun 2010; Sébastien Fabbro <bicatali@gentoo.org> meep-1.1.1.ebuild:
Removed bindist flag, should be compatible GPL-3 anyway
@@ -69,4 +77,3 @@
06 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org>
+files/meep-0.10.1-configure.ac.patch, +metadata.xml, +meep-0.10.1.ebuild:
Initial import. Ebuild first submitted by Ben Schwartz, see bug #170989
-
diff --git a/sci-physics/meep/files/meep-1.2-no-auto-mpb.patch b/sci-physics/meep/files/meep-1.2-no-auto-mpb.patch
new file mode 100644
index 000000000000..8c287f208d65
--- /dev/null
+++ b/sci-physics/meep/files/meep-1.2-no-auto-mpb.patch
@@ -0,0 +1,16 @@
+diff -Nur meep-1.2.orig/configure.ac meep-1.2/configure.ac
+--- meep-1.2.orig/configure.ac 2012-08-14 21:52:13.000000000 +0100
++++ meep-1.2/configure.ac 2012-08-14 22:00:55.000000000 +0100
+@@ -161,8 +161,10 @@
+
+ ###########################################################################
+ # MPB library
+-
+-AC_CHECK_HEADER(mpb.h, [have_mpb=maybe], [have_mpb=no])
++AC_ARG_WITH(mpb, [AC_HELP_STRING([--without-mpb],[do not build with mpb])], ok=$withval, ok=yes)
++if test "$ok" = "yes"; then
++ AC_CHECK_HEADER(mpb.h, [have_mpb=maybe], [have_mpb=no])
++fi
+
+ if test $have_mpb = maybe; then
+ if test "x$acx_lapack_ok" = x -a "$have_harminv" = xno; then
diff --git a/sci-physics/meep/files/meep-1.2-pc-no-ldflags.patch b/sci-physics/meep/files/meep-1.2-pc-no-ldflags.patch
new file mode 100644
index 000000000000..d7b2f72eaffc
--- /dev/null
+++ b/sci-physics/meep/files/meep-1.2-pc-no-ldflags.patch
@@ -0,0 +1,12 @@
+diff -Nur meep-1.2.orig/configure.ac meep-1.2/configure.ac
+--- meep-1.2.orig/configure.ac 2012-08-14 21:52:13.000000000 +0100
++++ meep-1.2/configure.ac 2012-08-14 21:54:49.000000000 +0100
+@@ -224,7 +224,7 @@
+ ##############################################################################
+ # Libraries and flags (other than -lmeep) required to link Meep:
+
+-MEEPLIBS="$LDFLAGS $LIBS"
++MEEPLIBS="$LIBS"
+ AC_SUBST(MEEPLIBS)
+
+ ##############################################################################
diff --git a/sci-physics/meep/meep-1.2.ebuild b/sci-physics/meep/meep-1.2.ebuild
new file mode 100644
index 000000000000..8055f56bf2c1
--- /dev/null
+++ b/sci-physics/meep/meep-1.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/meep/meep-1.2.ebuild,v 1.1 2012/08/14 22:50:50 bicatali Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="Simulation software to model electromagnetic systems"
+HOMEPAGE="http://ab-initio.mit.edu/meep/"
+SRC_URI="http://ab-initio.mit.edu/meep/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples hdf5 guile mpb mpi"
+
+RDEPEND="
+ sci-libs/fftw
+ sci-libs/gsl
+ sci-physics/harminv
+ guile? ( >=sci-libs/libctl-3.2 )
+ hdf5? ( sci-libs/hdf5 )
+ mpb? ( sci-physics/mpb )
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pc-no-ldflags.patch
+ "${FILESDIR}"/${P}-no-auto-mpb.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with mpb)
+ $(use_with mpi)
+ $(use_with hdf5)
+ $(use_with guile libctl)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ # pml test buggy with optimization on
+ # http://thread.gmane.org/gmane.comp.science.electromagnetism.meep.general/4579
+ pushd ${AUTOTOOLS_BUILD_DIR} > /dev/null
+ emake -C tests pml CXXFLAGS="-O0"
+ emake check
+ popd > /dev/null
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*.ctl
+ fi
+}
diff --git a/sci-physics/meep/metadata.xml b/sci-physics/meep/metadata.xml
index b1867dddf8f3..17865fb063ef 100644
--- a/sci-physics/meep/metadata.xml
+++ b/sci-physics/meep/metadata.xml
@@ -8,4 +8,7 @@
developed at MIT to model electromagnetic systems, along with the MPB
eigenmode package.
</longdescription>
+<use>
+ <flag name='mpb'>Enable build against <pkg>sci-physics/mpb</pkg></flag>
+</use>
</pkgmetadata>