summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-08-22 14:26:15 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-08-22 14:26:15 +0000
commit0bb6e836734c145f5b236f38c6f16b3204590d9f (patch)
treeeac84c1c09a74e26d2b17016299410936d47db49 /sci-physics
parentkeyword ~sparc-fbsd (diff)
downloadgentoo-2-0bb6e836734c145f5b236f38c6f16b3204590d9f.tar.gz
gentoo-2-0bb6e836734c145f5b236f38c6f16b3204590d9f.tar.bz2
gentoo-2-0bb6e836734c145f5b236f38c6f16b3204590d9f.zip
Version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.23-gentoo-r9 x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/clhep/ChangeLog8
-rw-r--r--sci-physics/clhep/clhep-2.0.4.0.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/sci-physics/clhep/ChangeLog b/sci-physics/clhep/ChangeLog
index c835e34b7623..10dc4a19b619 100644
--- a/sci-physics/clhep/ChangeLog
+++ b/sci-physics/clhep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/clhep
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.4 2008/08/06 16:14:28 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.5 2008/08/22 14:26:15 bicatali Exp $
+
+*clhep-2.0.4.0 (22 Aug 2008)
+
+ 22 Aug 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +clhep-2.0.4.0.ebuild:
+ Version bump
06 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/sci-physics/clhep/clhep-2.0.4.0.ebuild b/sci-physics/clhep/clhep-2.0.4.0.ebuild
new file mode 100644
index 000000000000..97b7b283bcad
--- /dev/null
+++ b/sci-physics/clhep/clhep-2.0.4.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.0.4.0.ebuild,v 1.1 2008/08/22 14:26:15 bicatali Exp $
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="High Energy Physics C++ library"
+HOMEPAGE="http://www.cern.ch/clhep"
+SRC_URI="http://wwwasd.web.cern.ch/wwwasd/lhc++/clhep/DISTRIBUTION/distributions/${P}.tgz"
+
+LICENSE="public-domain"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+
+IUSE="exceptions"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PV}/CLHEP"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ for d in $(find . -name configure.in); do
+ pushd ${d/configure.in/}
+ # respect user flags and fix some compilers stuff
+ sed -i \
+ -e 's:^g++):*g++):g' \
+ -e 's:^icc):icc|icpc):g' \
+ -e '/AM_CXXFLAGS=/s:-O ::g' \
+ configure.in || die
+ # need to rebuild because original configurations
+ # have buggy detection
+ eautoconf
+ popd
+ done
+}
+
+src_compile() {
+ # use ld LDFLAGS for intel compiler
+ [[ $(tc-getCXX) = i*c ]] && \
+ export LDFLAGS="$(raw-ldflags)"
+ econf $(use_enable exceptions) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README ChangeLog || die
+}