summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-12-09 17:35:13 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-12-09 17:35:13 +0000
commit562de1d05ffca7be0034756fe91849980bf45862 (patch)
tree7bff414c6f691053ab8f1a4e2ad19872e343cf16 /sci-physics/root/root-5.16.00.ebuild
parentStable on amd64/x86 (bug #201747) (diff)
downloadgentoo-2-562de1d05ffca7be0034756fe91849980bf45862.tar.gz
gentoo-2-562de1d05ffca7be0034756fe91849980bf45862.tar.bz2
gentoo-2-562de1d05ffca7be0034756fe91849980bf45862.zip
Forced opengl as a dep, since it needs it anyway, added a possible fix for afs support, a die function for a g++ >= 4.2 and now use virtual/mysql instead of dev-db/mysql
(Portage version: 2.1.4_rc8)
Diffstat (limited to 'sci-physics/root/root-5.16.00.ebuild')
-rw-r--r--sci-physics/root/root-5.16.00.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/sci-physics/root/root-5.16.00.ebuild b/sci-physics/root/root-5.16.00.ebuild
index b7f356c0d16f..940f9a56ac3a 100644
--- a/sci-physics/root/root-5.16.00.ebuild
+++ b/sci-physics/root/root-5.16.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.16.00.ebuild,v 1.9 2007/11/23 16:01:06 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.16.00.ebuild,v 1.10 2007/12/09 17:35:12 bicatali Exp $
inherit versionator flag-o-matic eutils toolchain-funcs qt3 fortran
@@ -14,16 +14,18 @@ HOMEPAGE="http://root.cern.ch/"
SLOT="0"
LICENSE="LGPL-2"
KEYWORDS="amd64 sparc x86"
-IUSE="afs cern doc fftw kerberos ldap mysql odbc opengl postgres
+
+IUSE="afs cern doc fftw kerberos ldap mysql odbc postgres
python ruby qt3 ssl truetype xml"
DEPEND="sys-apps/shadow
x11-libs/libXpm
>=sci-libs/gsl-1.8
dev-libs/libpcre
+ virtual/opengl
+ virtual/glu
|| ( media-libs/libafterimage x11-wm/afterstep )
- opengl? ( virtual/opengl virtual/glu )
- mysql? ( dev-db/mysql )
+ mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql )
afs? ( net-fs/openafs )
kerberos? ( virtual/krb5 )
@@ -54,6 +56,12 @@ pkg_setup() {
FORTRAN="gfortran g77 ifc"
fortran_pkg_setup
fi
+ if [[ "$(tc-getCXX)" == *g++* ]] && \
+ version_is_at_least 4.2 $(gcc-version); then
+ eerror "${P} will not compile with g++ >= 4.2"
+ eerror "Either downgrade gcc, use another C++ compiler or use root >= 5.18."
+ die "wrong g++ version"
+ fi
}
src_unpack() {
@@ -79,7 +87,7 @@ src_compile() {
target=linuxicc
fi
fi
-
+ use afs && append-flags -DAFS_OLD_COM_ERR
local myfortran
use cern && myfortran="F77=${FORTRANC}"
@@ -126,6 +134,7 @@ src_compile() {
--enable-mathcore \
--enable-mathmore \
--enable-minuit2 \
+ --enable-opengl \
--enable-reflex \
--enable-roofit \
--enable-shared \
@@ -140,7 +149,6 @@ src_compile() {
$(use_enable ldap) \
$(use_enable mysql) \
$(use_enable odbc) \
- $(use_enable opengl) \
$(use_enable postgres pgsql) \
$(use_enable python) \
$(use_enable qt3 qt) \