summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-07-08 16:28:18 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-07-08 16:28:18 +0000
commitfe7918176a740f3bd34b3c85892e7f0fc4105928 (patch)
treecd3ee35451a7d927993464aabf86b326bff50e07 /sci-physics/root/files
parentadd missing test use flag to IUSE (diff)
downloadgentoo-2-fe7918176a740f3bd34b3c85892e7f0fc4105928.tar.gz
gentoo-2-fe7918176a740f3bd34b3c85892e7f0fc4105928.tar.bz2
gentoo-2-fe7918176a740f3bd34b3c85892e7f0fc4105928.zip
Version bump, removed some older versions. Still buggy for pre-compiled headers (use flag pch), and could not test properly with oracle flag. Masked for a testing period, see bug #230654
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-physics/root/files')
-rw-r--r--sci-physics/root/files/root-5.16.00-afs.patch33
-rw-r--r--sci-physics/root/files/root-5.16.00-flags.patch13
-rw-r--r--sci-physics/root/files/root-5.16.00-postgres.patch24
-rw-r--r--sci-physics/root/files/root-5.20.00-configure.patch37
-rw-r--r--sci-physics/root/files/root-5.20.00-pic.patch129
-rw-r--r--sci-physics/root/files/root-xrootd-flags.patch12
6 files changed, 166 insertions, 82 deletions
diff --git a/sci-physics/root/files/root-5.16.00-afs.patch b/sci-physics/root/files/root-5.16.00-afs.patch
deleted file mode 100644
index cf709362aca8..000000000000
--- a/sci-physics/root/files/root-5.16.00-afs.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Naur root/configure root.new/configure
---- root/configure 2007-06-07 02:48:25.000000000 -0500
-+++ root.new/configure 2007-12-16 07:18:51.000000000 -0500
-@@ -307,7 +307,7 @@
- # the .lib export library to link.
- libs=""
- for i in $lib ; do
-- for ext in .a .lib "" ; do # lib without extension for MacOS X
-+ for ext in foobar "" ; do # lib without extension for MacOS X
- libs="$libs $i$ext"
- done
- done
-@@ -403,7 +403,7 @@
- flib=""
- maclib=""
- for i in $lib ; do
-- for ext in .a .lib "" ; do # lib without extension for MacOS X
-+ for ext in foobar "" ; do # lib without extension for MacOS X
- if test "x$found_lib" = "x$i$ext" ; then
- flib=$i$ext
- if test "x$ext" = "x" ; then
-diff -Naur root/xrootd/Module.mk root.new/xrootd/Module.mk
---- root/xrootd/Module.mk 2007-03-24 09:06:26.000000000 -0500
-+++ root.new/xrootd/Module.mk 2007-12-16 07:25:47.000000000 -0500
-@@ -77,6 +77,8 @@
- gunzip -c $(XROOTDVERS).src.tgz | tar xf -; \
- etag=`basename $(XROOTDETAG)` ; \
- touch $$etag ; \
-+ sed -e "s:.a .lib:.foobar:" -i xrootd/configure.classic ; \
-+ sed -e "s:-lXrdSys:-lXrdSys -lresolv:" -i xrootd/src/XrdSecpwd/GNUmakefile ; \
- fi)
- ifeq ($(PLATFORM),win32)
- @(if [ -d $(XROOTDDIRD)/pthreads-win32 ]; then \
diff --git a/sci-physics/root/files/root-5.16.00-flags.patch b/sci-physics/root/files/root-5.16.00-flags.patch
deleted file mode 100644
index 05bf8e7531f8..000000000000
--- a/sci-physics/root/files/root-5.16.00-flags.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- xrootd/config/GNUmake.env.in.orig 2007-12-13 09:23:25.041447494 +0000
-+++ xrootd/config/GNUmake.env.in 2007-12-13 09:24:10.056012728 +0000
-@@ -22,8 +22,8 @@
- LIBDIR = ../../lib$(ARCHDIR)
- OBJDIR = ../../obj$(ARCHDIR)
-
--CFLAGS = $(CF64) $(CFOP) -DXrdDEBUG=$(XrdDEBUG)
--CFLAGS32 = $(CF32) $(CFOP) -DXrdDEBUG=$(XrdDEBUG)
-+CFLAGS = $(CF64) $(OPTFLAGS) $(CFOP) -DXrdDEBUG=$(XrdDEBUG)
-+CFLAGS32 = $(CF32) $(OPTFLAGS) $(CFOP) -DXrdDEBUG=$(XrdDEBUG)
-
- # Extra flags
- CFTRACE = @tracedbg@
diff --git a/sci-physics/root/files/root-5.16.00-postgres.patch b/sci-physics/root/files/root-5.16.00-postgres.patch
deleted file mode 100644
index 9e48819fe743..000000000000
--- a/sci-physics/root/files/root-5.16.00-postgres.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- ./pgsql/src/TPgSQLServer.cxx~ 2007-06-08 18:45:02.000000000 +0900
-+++ ./pgsql/src/TPgSQLServer.cxx 2007-12-22 22:41:25.000000000 +0900
-@@ -344,16 +344,16 @@
- SetError(-1, "cannot allocate PGSQL_STMT" , "Statement");
- return 0;
- }
-- stmt->conn=fPgSQL;
-- stmt->res=PQprepare(fPgSQL,"", sql,0,(const Oid*)0);
-+ stmt->fConn=fPgSQL;
-+ stmt->fRes=PQprepare(fPgSQL,"", sql,0,(const Oid*)0);
-
-- ExecStatusType stat = PQresultStatus(stmt->res);
-+ ExecStatusType stat = PQresultStatus(stmt->fRes);
- if (pgsql_success(stat)) {
- fErrorOut=stat;
- return new TPgSQLStatement(stmt, fErrorOut);
- } else {
-- SetError(stat, PQresultErrorMessage(stmt->res), "Statement");
-- stmt->conn = 0;
-+ SetError(stat, PQresultErrorMessage(stmt->fRes), "Statement");
-+ stmt->fConn = 0;
- delete stmt;
- return 0;
- }
diff --git a/sci-physics/root/files/root-5.20.00-configure.patch b/sci-physics/root/files/root-5.20.00-configure.patch
new file mode 100644
index 000000000000..a60986a2657f
--- /dev/null
+++ b/sci-physics/root/files/root-5.20.00-configure.patch
@@ -0,0 +1,37 @@
+--- configure.orig 2008-07-07 09:43:12.732330045 +0100
++++ configure 2008-07-07 15:45:27.122015928 +0100
+@@ -1648,7 +1648,7 @@
+ if pkg-config --exists ftgl ; then
+ result "ok"
+ ftglincdir=`pkg-config --cflags-only-I ftgl | sed 's/-I//g'`
+- ftgllibs=`pkg-config --libs-only-l ftgl | sed s'/-lftgl/-lftgl_pic/'`
++ ftgllibs=`pkg-config --libs-only-l ftgl`
+ ftgllibdir=`pkg-config --libs-only-L ftgl | sed 's/-L//g'`
+ enable_builtin_ftgl=no
+ else
+@@ -2753,12 +2753,12 @@
+ found_dirz=""
+ # libz must be before libpng, if libz is not found don't
+ # add libpng which needs libz
+- # note that failure to find system libungif is not fatal since
+- # libAfterImage contains embedded libungif source if needed
++ # note that failure to find system libgif is not fatal since
++ # libAfterImage contains embedded libgif source if needed
+ if test ! "x$enable_astiff" = "xno" ; then
+- aslibs="libjpeg libtiff libungif libz libpng"
++ aslibs="libjpeg libtiff libgif libz libpng"
+ else
+- aslibs="libjpeg libungif libz libpng"
++ aslibs="libjpeg libgif libz libpng"
+ fi
+ for k in $aslibs ; do
+ check_library $k "$enable_shared" "" \
+@@ -2771,7 +2771,7 @@
+ if test "x$k" = "xlibpng" && test "x$found_libz" = "x" ; then
+ break;
+ fi
+- if test "x$k" = "xlibungif" && test "x$found_lib" = "x" ; then
++ if test "x$k" = "xlibgif" && test "x$found_lib" = "x" ; then
+ asgifincdir=""
+ fi
+ if test ! "x$found_lib" = "x" ; then
diff --git a/sci-physics/root/files/root-5.20.00-pic.patch b/sci-physics/root/files/root-5.20.00-pic.patch
new file mode 100644
index 000000000000..1ecf8f353414
--- /dev/null
+++ b/sci-physics/root/files/root-5.20.00-pic.patch
@@ -0,0 +1,129 @@
+--- ./net/xrootd/src/xrootd/configure.classic.orig 2008-06-25 07:24:15.000000000 +0100
++++ ./net/xrootd/src/xrootd/configure.classic 2008-07-04 20:06:20.537658375 +0100
+@@ -342,7 +342,8 @@
+
+ # Assert that we got enough arguments
+ if test $# -ne 3 ; then
+- echo "check_symbol: Not 3 arguments"
++ echo "check_symbol: not 3 arguments"
++ found_symbol=0
+ return 1
+ fi
+
+@@ -351,34 +352,105 @@
+ symbollib=$1 ; shift
+ symboldir=$1
+
++ if test "x$symbollib" = "x" ; then
++ found_symbol=0
++ return 1
++ fi
++
++ symbollib=`echo $symbollib | sed -e 's/^-l/lib/'`
++
++ if test ! "x$symboldir" = "x" ; then
++ symboldir=`echo $symboldir | sed -e 's/^-L//'`
++ fi
++
+ # Check if we got a specific argument as to where the library
+ # is to be found
+ symbolfile=$symbollib
+- if test ! "x$symboldir" = "x" ; then
+- symbolfile=$symboldir/$symbollib
+- if test ! -r $symbolfile ; then
+- for i in .a .so .lib ; do
+- if test -r $symbolfile$i ; then
+- symbolfile=$symbolfile$i
+- break
++ exts=".so .lib"
++ if test ! "x$shared" = "xno" ; then
++ exts="$exts .a"
++ else
++ exts=".a $exts"
++ fi
++
++ usrlib="/usr/lib"
++ # look first in the lib32 directories
++ if test "x$checklib32" = "xyes" ; then
++ usrlib="/usr/lib32 $usrlib"
++ fi
++ # look first in the lib64 directories
++ if test "x$checklib64" = "xyes" ; then
++ usrlib="/usr/lib64 $usrlib"
++ fi
++ # look only in the lib64 directories
++ if test "x$checkonlylib64" = "xyes" ; then
++ usrlib="/usr/lib64"
++ fi
++ # look only in the hpux64 directories
++ if test "x$checkhpux64" = "xyes" ; then
++ usrlib="/usr/lib/hpux64"
++ fi
++
++ for d in "$symboldir" $usrlib ; do
++ echo " Checking in $d"
++ if test ! -r $d/$symbollib ; then
++ echo " $d/$symbollib not readable"
++ for i in $exts ; do
++ echo " Checking extension $i with $d/$symbollib"
++ if test -r $d/$symbollib$i ; then
++ echo " $d/$symbollib$i readable"
++ symbolfile=$d/$symbollib$i
++ break 2
+ fi
+ done
++ else
++ echo "$d/$symbollib readable"
++ symbolfile=$d/$symbollib
++ break
+ fi
+- fi
++ done
+
+ if test "x$symbolfile" = "x" || test ! -r $symbolfile ; then
+ found_symbol=0
++ echo " Symbol not found"
+ return 1
+ fi
+
+- symbol_in_lib=`nm $symbolfile | grep $symbol > /dev/null 2>&1`
++ checking_msg "$symbol in $symbolfile"
++ nm $symbolfile 2>&1 | grep $symbol > /dev/null 2>&1
+ if test $? -eq 0 ; then
+ found_symbol=1
++ echo " Symbol found"
+ else
+- found_symbol=0
++ nm $symbolfile 2>&1 | grep "no symbols" > /dev/null 2>&1
++ if test $? -eq 0 ; then
++ echo " $symbolfile is stripped, trying a link"
++ # stripped library - only safe test is to link against the
++ # library! However, we do not know what compiler to use
++ # so we can not do the test. Assume the symbol is in
++ cat <<EOF > conftest.mk
++conftest:conftest.c $symbolfile
++ \$(CC) \$(CFLAGS) \$(LDFLAGS) $symbolfile \$< -o \$@
++
++conftest.c:
++ echo "extern int $symbol (); " > \$@
++ echo "int main() { $symbol (); return 0; }" >> \$@
++EOF
++ make -f conftest.mk >> config.log 2>&1
++ if test $? -eq 0 ; then
++ found_symbol=1
++ echo " Link OK"
++ else
++ found_symbol=0
++ echo " Failed code was"
++ cat conftest.mk >> config.log
++ fi
++ rm -rf conftest.c conftest.mk conftest
++ else
++ found_symbol=0
++ fi
+ fi
+ }
+-
+ #_____________________________________________________________________
+ guess_architecture () {
+ # Try to guess the architecture of the host system
diff --git a/sci-physics/root/files/root-xrootd-flags.patch b/sci-physics/root/files/root-xrootd-flags.patch
deleted file mode 100644
index ed4ef22dfa37..000000000000
--- a/sci-physics/root/files/root-xrootd-flags.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- xrootd/Module.mk.orig 2008-01-17 17:16:53.152329508 +0000
-+++ xrootd/Module.mk 2008-01-17 17:18:27.318594421 +0000
-@@ -77,6 +77,9 @@
- gunzip -c $(XROOTDVERS).src.tgz | tar xf -; \
- etag=`basename $(XROOTDETAG)` ; \
- touch $$etag ; \
-+ sed -i \
-+ -e 's:$$(CFOP):$$(CFOP) $$(OPTFLAGS):g' \
-+ xrootd/config/GNUmake.env.in ; \
- fi)
- ifeq ($(PLATFORM),win32)
- @(if [ -d $(XROOTDDIRD)/pthreads-win32 ]; then \