summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-12-16 17:04:42 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-12-16 17:04:42 +0000
commit7ac239dd9c02db11f91e60abb33b2da7bd7b51da (patch)
treedb363c142008fee1f7a93403f54c30ac606547a8 /sci-physics/root/files
parentStable on ppc64; bug #202168 (diff)
downloadgentoo-2-7ac239dd9c02db11f91e60abb33b2da7bd7b51da.tar.gz
gentoo-2-7ac239dd9c02db11f91e60abb33b2da7bd7b51da.tar.bz2
gentoo-2-7ac239dd9c02db11f91e60abb33b2da7bd7b51da.zip
Added patch to fix linking problem with afs libs. Re-added afs USE flag.
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'sci-physics/root/files')
-rw-r--r--sci-physics/root/files/root-5.16.00-afs.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-physics/root/files/root-5.16.00-afs.patch b/sci-physics/root/files/root-5.16.00-afs.patch
new file mode 100644
index 000000000000..cf709362aca8
--- /dev/null
+++ b/sci-physics/root/files/root-5.16.00-afs.patch
@@ -0,0 +1,33 @@
+diff -Naur root/configure root.new/configure
+--- root/configure 2007-06-07 02:48:25.000000000 -0500
++++ root.new/configure 2007-12-16 07:18:51.000000000 -0500
+@@ -307,7 +307,7 @@
+ # the .lib export library to link.
+ libs=""
+ for i in $lib ; do
+- for ext in .a .lib "" ; do # lib without extension for MacOS X
++ for ext in foobar "" ; do # lib without extension for MacOS X
+ libs="$libs $i$ext"
+ done
+ done
+@@ -403,7 +403,7 @@
+ flib=""
+ maclib=""
+ for i in $lib ; do
+- for ext in .a .lib "" ; do # lib without extension for MacOS X
++ for ext in foobar "" ; do # lib without extension for MacOS X
+ if test "x$found_lib" = "x$i$ext" ; then
+ flib=$i$ext
+ if test "x$ext" = "x" ; then
+diff -Naur root/xrootd/Module.mk root.new/xrootd/Module.mk
+--- root/xrootd/Module.mk 2007-03-24 09:06:26.000000000 -0500
++++ root.new/xrootd/Module.mk 2007-12-16 07:25:47.000000000 -0500
+@@ -77,6 +77,8 @@
+ gunzip -c $(XROOTDVERS).src.tgz | tar xf -; \
+ etag=`basename $(XROOTDETAG)` ; \
+ touch $$etag ; \
++ sed -e "s:.a .lib:.foobar:" -i xrootd/configure.classic ; \
++ sed -e "s:-lXrdSys:-lXrdSys -lresolv:" -i xrootd/src/XrdSecpwd/GNUmakefile ; \
+ fi)
+ ifeq ($(PLATFORM),win32)
+ @(if [ -d $(XROOTDDIRD)/pthreads-win32 ]; then \