summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-10-29 19:52:25 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-10-29 19:52:25 +0000
commitecf9ee453e41d718982b8f30a20a1d06fac105a0 (patch)
treec188050c9a5f1366bbf4a8dbdc14a75bf40244c7 /sci-physics/pythia
parentfix pst2pdf link, bug #489808 by Ulrich Müller (diff)
downloadgentoo-2-ecf9ee453e41d718982b8f30a20a1d06fac105a0.tar.gz
gentoo-2-ecf9ee453e41d718982b8f30a20a1d06fac105a0.tar.bz2
gentoo-2-ecf9ee453e41d718982b8f30a20a1d06fac105a0.zip
Version bump - ebuild submitted by Andrew Savchenko, bug #487210
(Portage version: 2.2.7-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-physics/pythia')
-rw-r--r--sci-physics/pythia/ChangeLog7
-rw-r--r--sci-physics/pythia/pythia-6.4.28.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/sci-physics/pythia/ChangeLog b/sci-physics/pythia/ChangeLog
index 837c3a9c95ba..9141772de3ab 100644
--- a/sci-physics/pythia/ChangeLog
+++ b/sci-physics/pythia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/pythia
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.51 2013/06/07 15:35:42 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/ChangeLog,v 1.52 2013/10/29 19:52:25 bicatali Exp $
+
+*pythia-6.4.28 (29 Oct 2013)
+
+ 29 Oct 2013; Sébastien Fabbro <bicatali@gentoo.org> +pythia-6.4.28.ebuild:
+ Version bump - ebuild submitted by Andrew Savchenko, bug #487210
*pythia-8.1.76 (07 Jun 2013)
diff --git a/sci-physics/pythia/pythia-6.4.28.ebuild b/sci-physics/pythia/pythia-6.4.28.ebuild
new file mode 100644
index 000000000000..fdf9cebbfd3f
--- /dev/null
+++ b/sci-physics/pythia/pythia-6.4.28.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/pythia/pythia-6.4.28.ebuild,v 1.1 2013/10/29 19:52:25 bicatali Exp $
+
+EAPI=5
+
+inherit autotools fortran-2 versionator
+
+MV=$(get_major_version)
+MY_PN=${PN}${MV}
+DOC_PV=0613
+EX_PV=6.4.18
+
+DESCRIPTION="Lund Monte Carlo high-energy physics event generator"
+HOMEPAGE="http://pythia6.hepforge.org/"
+
+# pythia6 from root is needed for some files to interface pythia6 with root.
+# To produce a split version, replace the 6.4.x by the current version:
+# svn export http://svn.hepforge.org/pythia6/tags/v_6_4_x/ pythia-6.4.x
+# tar cJf pythia-6.4.x.tar.xz
+SRC_URI="
+ http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.xz
+ ftp://root.cern.ch/root/pythia6.tar.gz
+ doc? ( http://home.thep.lu.se/~torbjorn/pythia/lutp${DOC_PV}man2.pdf )
+ examples? ( mirror://gentoo/${PN}-${EX_PV}-examples.tar.bz2 )"
+
+SLOT="6"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs"
+
+src_prepare() {
+ cp ../pythia6/tpythia6_called_from_cc.F .
+ cp ../pythia6/pythia6_common_address.c .
+ cat > configure.ac <<-EOF
+ AC_INIT(${PN},${PV})
+ AM_INIT_AUTOMAKE
+ AC_PROG_F77
+ LT_INIT
+ AC_CHECK_LIB(m,sqrt)
+ AC_CONFIG_FILES(Makefile)
+ AC_OUTPUT
+ EOF
+ echo >> Makefile.am "lib_LTLIBRARIES = libpythia6.la"
+ echo >> Makefile.am "libpythia6_la_SOURCES = \ "
+ # replace wildcard from makefile to ls in shell
+ local f
+ for f in py*.f struct*.f up*.f fh*.f; do
+ echo >> Makefile.am " ${f} \\"
+ done
+ echo >> Makefile.am " ssmssm.f sugra.f visaje.f pdfset.f \\"
+ echo >> Makefile.am " tpythia6_called_from_cc.F pythia6_common_address.c"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc update_notes.txt
+ use doc && dodoc "${DISTDIR}"/lutp${DOC_PV}man2.pdf
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r "${WORKDIR}"/examples
+ fi
+}