summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-07-10 18:29:08 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-07-10 18:29:08 +0000
commitb7a263c99e06424f17a133b4150b4bee63cca68d (patch)
tree46e303cc2292be23ba38f89c1fd7b063620289d7 /sci-physics/paw/paw-2.14.04-r1.ebuild
parentstable amd64, bug 229835 (diff)
downloadgentoo-2-b7a263c99e06424f17a133b4150b4bee63cca68d.tar.gz
gentoo-2-b7a263c99e06424f17a133b4150b4bee63cca68d.tar.bz2
gentoo-2-b7a263c99e06424f17a133b4150b4bee63cca68d.zip
Added libXaw as dependency, removed src_test (bug #231208)
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-physics/paw/paw-2.14.04-r1.ebuild')
-rw-r--r--sci-physics/paw/paw-2.14.04-r1.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/sci-physics/paw/paw-2.14.04-r1.ebuild b/sci-physics/paw/paw-2.14.04-r1.ebuild
deleted file mode 100644
index 541101ee1940..000000000000
--- a/sci-physics/paw/paw-2.14.04-r1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/paw/paw-2.14.04-r1.ebuild,v 1.3 2008/06/29 07:55:15 tove Exp $
-
-inherit eutils multilib fortran
-
-DEB_PN=paw
-DEB_PV=${PV}.dfsg.2
-DEB_PR=3
-DEB_P=${DEB_PN}_${DEB_PV}
-
-DESCRIPTION="CERN's Physics Analysis Workstation data analysis program"
-HOMEPAGE="http://wwwasd.web.cern.ch/wwwasd/paw/index.html"
-LICENSE="GPL-2 LGPL-2 BSD"
-SRC_URI="mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
- mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.diff.gz"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE=""
-
-RDEPEND="x11-libs/openmotif
- virtual/lapack
- dev-lang/cfortran
- sci-physics/cernlib
- x11-libs/xbae"
-
-DEPEND="${RDEPEND}
- virtual/latex-base
- x11-misc/imake
- x11-misc/makedepend"
-
-S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
-
-KEYWORDS="~amd64 ~x86"
-
-FORTRAN="gfortran g77 ifc"
-
-src_unpack() {
- unpack ${A}
- epatch "${DEB_P}-${DEB_PR}".diff
-
- cd "${S}"
- cp debian/add-ons/Makefile .
- export DEB_BUILD_OPTIONS="${FORTRANC} nostrip nocheck"
-
- # fix some path stuff and collision for comis.h,
- # already installed by cernlib and replace hardcoded fortran compiler
- sed -i \
- -e 's:/usr/local:/usr:g' \
- -e '/comis.h/d' \
- -e "s/gfortran/${FORTRANC}/g" \
- Makefile || die "sed'ing the Makefile failed"
-
- einfo "Applying Debian patches"
- emake -j1 patch || die "make patch failed"
-
- # since we depend on cfortran, do not use the one from cernlib
- rm -f src/include/cfortran/cfortran.h
-}
-
-src_compile() {
- # create local LaTeX cache directory
- mkdir -p .texmf-var
- emake -j1 cernlib-indep cernlib-arch || die "emake failed"
-}
-
-src_test() {
- LD_LIBRARY_PATH="${S}"/shlib \
- emake -j1 cernlib-test || die "emake test failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- cd "${S}"/debian
- dodoc changelog README.* deadpool.txt copyright || die "dodoc failed"
- newdoc add-ons/README README.add-ons || die "newdoc failed"
-}
-
-pkg_postinst() {
- if use amd64; then
- elog "Please see the possible warnings in using ${PN} on 64 bits:"
- elog "${ROOT}/usr/share/doc/${PF}/README.*64*"
- fi
-}