summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-23 16:57:27 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-23 16:57:27 +0000
commitc6cfea2f86469c5637d1948b9ffe122d09afbd0e (patch)
tree0e9e646d16a774bf52e9b3e904f30177658e2938 /sci-physics/mpb
parentversion bump. remove old ebuild b/c of security bugs (see bug #284536). jpgra... (diff)
downloadgentoo-2-c6cfea2f86469c5637d1948b9ffe122d09afbd0e.tar.gz
gentoo-2-c6cfea2f86469c5637d1948b9ffe122d09afbd0e.tar.bz2
gentoo-2-c6cfea2f86469c5637d1948b9ffe122d09afbd0e.zip
sci-physics/mpb: Respect CC, fix buildfailure due to remove configure.sub, #423123
(Portage version: 2.2.0_alpha111/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/mpb')
-rw-r--r--sci-physics/mpb/ChangeLog6
-rw-r--r--sci-physics/mpb/metadata.xml5
-rw-r--r--sci-physics/mpb/mpb-1.4.2-r2.ebuild20
3 files changed, 18 insertions, 13 deletions
diff --git a/sci-physics/mpb/ChangeLog b/sci-physics/mpb/ChangeLog
index 0cc8ca0c82f5..56f7d8dfb830 100644
--- a/sci-physics/mpb/ChangeLog
+++ b/sci-physics/mpb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/mpb
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/ChangeLog,v 1.14 2012/05/04 07:55:34 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/ChangeLog,v 1.15 2012/06/23 16:57:27 jlec Exp $
+
+ 23 Jun 2012; Justin Lecher <jlec@gentoo.org> mpb-1.4.2-r2.ebuild,
+ metadata.xml:
+ Respect CC, fix buildfailure due to remove configure.sub, #423123
04 May 2012; Jeff Horelick <jdhore@gentoo.org> mpb-1.4.2-r2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/sci-physics/mpb/metadata.xml b/sci-physics/mpb/metadata.xml
index a7870e267ce6..36994b3229fd 100644
--- a/sci-physics/mpb/metadata.xml
+++ b/sci-physics/mpb/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-physics</herd>
-<longdescription lang="en">
+ <herd>sci-physics</herd>
+ <longdescription lang="en">
The MIT Photonic-Bands (MPB) package is a program for computing
the band structures (dispersion relations) and electromagnetic modes of
periodic dielectric structures, on both serial and parallel computers. It was
@@ -18,4 +18,3 @@
cross-sections.)
</longdescription>
</pkgmetadata>
-
diff --git a/sci-physics/mpb/mpb-1.4.2-r2.ebuild b/sci-physics/mpb/mpb-1.4.2-r2.ebuild
index 06a38861e0d2..419310e881f8 100644
--- a/sci-physics/mpb/mpb-1.4.2-r2.ebuild
+++ b/sci-physics/mpb/mpb-1.4.2-r2.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/mpb-1.4.2-r2.ebuild,v 1.4 2012/05/04 07:55:34 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/mpb-1.4.2-r2.ebuild,v 1.5 2012/06/23 16:57:27 jlec Exp $
-EAPI=2
-inherit eutils autotools flag-o-matic
+EAPI=4
+
+inherit eutils autotools flag-o-matic toolchain-funcs
DESCRIPTION="Photonic band structure program"
SRC_URI="http://ab-initio.mit.edu/mpb/${P}.tar.gz"
@@ -27,11 +28,11 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${P}-autotools.patch
- epatch "${FILESDIR}"/${P}-headers.patch
+ epatch \
+ "${FILESDIR}"/${P}-autotools.patch \
+ "${FILESDIR}"/${P}-headers.patch
cd "${S}"
- rm -f config.*
- AT_NOELIBTOOLIZE=yes eautoreconf
+ eautoreconf
# version with inversion symmetry (mpbi).
cp -r "${S}" "${S}_inv"
# version with hermitian eps (mpbh).
@@ -42,6 +43,7 @@ src_prepare() {
cp -r "${S}" "${S}_inv_mpi"
cp -r "${S}" "${S}_herm_mpi"
fi
+ tc-export CC
}
src_configure() {
@@ -82,8 +84,8 @@ src_compile() {
local dirs="${S} ${S}_inv ${S}_herm"
for d in ${dirs}; do
cd "${d}"
- emake -C mpb-ctl ctl-io.c || die
- emake || die "emake in ${d} failed"
+ emake -C mpb-ctl ctl-io.c
+ emake
done
local dirs="${S} ${S}_inv ${S}_herm"
if use mpi; then