summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-08 04:08:59 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-08 04:08:59 +0000
commit0de8d5dc509d767d7bf82c57358b12e3315ee358 (patch)
treee577339e64aa086584a7e60c925dc1b20485f72b /sci-physics/mpb
parentBump (diff)
downloadgentoo-2-0de8d5dc509d767d7bf82c57358b12e3315ee358.tar.gz
gentoo-2-0de8d5dc509d767d7bf82c57358b12e3315ee358.tar.bz2
gentoo-2-0de8d5dc509d767d7bf82c57358b12e3315ee358.zip
Fixed for guile-1.8. Switched to EAPI4. Cleanup ebuild. Install properly mpbi. Keyword amd64-linux, x86-linux
(Portage version: 2.2.01.20796-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/mpb')
-rw-r--r--sci-physics/mpb/ChangeLog9
-rw-r--r--sci-physics/mpb/files/mpb-1.4.2-gcc4.patch21
-rw-r--r--sci-physics/mpb/files/mpb-1.4.2-guile18.patch12
-rw-r--r--sci-physics/mpb/metadata.xml4
-rw-r--r--sci-physics/mpb/mpb-1.4.2-r2.ebuild73
5 files changed, 58 insertions, 61 deletions
diff --git a/sci-physics/mpb/ChangeLog b/sci-physics/mpb/ChangeLog
index 56f7d8dfb830..d7253da30ee9 100644
--- a/sci-physics/mpb/ChangeLog
+++ b/sci-physics/mpb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/mpb
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/ChangeLog,v 1.15 2012/06/23 16:57:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/ChangeLog,v 1.16 2012/08/08 04:08:59 bicatali Exp $
+
+ 08 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/mpb-1.4.2-guile18.patch, -files/mpb-1.4.2-gcc4.patch, metadata.xml,
+ mpb-1.4.2-r2.ebuild:
+ Fixed for guile-1.8. Switched to EAPI4. Cleanup ebuild. Install properly mpbi.
+ Keyword amd64-linux, x86-linux
23 Jun 2012; Justin Lecher <jlec@gentoo.org> mpb-1.4.2-r2.ebuild,
metadata.xml:
@@ -57,4 +63,3 @@
04 Jan 2006; Peter Bienstman <pbienst@gentoo.org> +mpb-1.4.2.ebuild:
New ebuild (closes #36581).
-
diff --git a/sci-physics/mpb/files/mpb-1.4.2-gcc4.patch b/sci-physics/mpb/files/mpb-1.4.2-gcc4.patch
deleted file mode 100644
index 62536ac202db..000000000000
--- a/sci-physics/mpb/files/mpb-1.4.2-gcc4.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur mpb-1.4.2/configure mpb-1.4.2-new/configure
---- mpb-1.4.2/configure 2003-03-03 21:39:25.000000000 -0500
-+++ mpb-1.4.2-new/configure 2006-11-07 08:19:13.000000000 -0500
-@@ -1343,7 +1343,7 @@
- ac_link='$F77 -o conftest$ac_exeext $FFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_f77_compiler_gnu
- if test -n "$ac_tool_prefix"; then
-- for ac_prog in g77 f77 xlf frt pgf77 fl32 af77 fort77 f90 xlf90 pgf90 epcf90 f95 fort xlf95 lf95 g95
-+ for ac_prog in g77 f77 xlf frt pgf77 fl32 af77 fort77 f90 xlf90 pgf90 epcf90 f95 fort xlf95 lf95 g95 gfortran
- do
- # Extract the first word of "$ac_tool_prefix$ac_prog", so it can be a program name with args.
- set dummy $ac_tool_prefix$ac_prog; ac_word=$2
-@@ -1385,7 +1385,7 @@
- fi
- if test -z "$F77"; then
- ac_ct_F77=$F77
-- for ac_prog in g77 f77 xlf frt pgf77 fl32 af77 fort77 f90 xlf90 pgf90 epcf90 f95 fort xlf95 lf95 g95
-+ for ac_prog in g77 f77 xlf frt pgf77 fl32 af77 fort77 f90 xlf90 pgf90 epcf90 f95 fort xlf95 lf95 g95 gfortran
- do
- # Extract the first word of "$ac_prog", so it can be a program name with args.
- set dummy $ac_prog; ac_word=$2
diff --git a/sci-physics/mpb/files/mpb-1.4.2-guile18.patch b/sci-physics/mpb/files/mpb-1.4.2-guile18.patch
new file mode 100644
index 000000000000..9cb73a099b8b
--- /dev/null
+++ b/sci-physics/mpb/files/mpb-1.4.2-guile18.patch
@@ -0,0 +1,12 @@
+diff -Nur mpb-1.4.2.orig/mpb-ctl/field-smob.c mpb-1.4.2/mpb-ctl/field-smob.c
+--- mpb-1.4.2.orig/mpb-ctl/field-smob.c 2012-08-07 20:56:24.538452994 -0700
++++ mpb-1.4.2/mpb-ctl/field-smob.c 2012-08-07 20:56:43.713557380 -0700
+@@ -157,7 +157,7 @@
+ boolean cur_fieldp(SCM obj)
+ {
+ if (SCM_NIMP(obj) && SCM_SYMBOLP(obj)) {
+- char *s = gh_symbol2newstr(obj, NULL);
++ char *s = gh_symbol2newstr(obj);
+ int ret = !strcmp(s, "cur-field");
+ free(s);
+ return ret;
diff --git a/sci-physics/mpb/metadata.xml b/sci-physics/mpb/metadata.xml
index 36994b3229fd..4c409fb5d874 100644
--- a/sci-physics/mpb/metadata.xml
+++ b/sci-physics/mpb/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-physics</herd>
- <longdescription lang="en">
+<herd>sci-physics</herd>
+<longdescription lang="en">
The MIT Photonic-Bands (MPB) package is a program for computing
the band structures (dispersion relations) and electromagnetic modes of
periodic dielectric structures, on both serial and parallel computers. It was
diff --git a/sci-physics/mpb/mpb-1.4.2-r2.ebuild b/sci-physics/mpb/mpb-1.4.2-r2.ebuild
index 419310e881f8..0d43b115ac13 100644
--- a/sci-physics/mpb/mpb-1.4.2-r2.ebuild
+++ b/sci-physics/mpb/mpb-1.4.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/mpb-1.4.2-r2.ebuild,v 1.5 2012/06/23 16:57:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/mpb/mpb-1.4.2-r2.ebuild,v 1.6 2012/08/08 04:08:59 bicatali Exp $
EAPI=4
@@ -11,7 +11,7 @@ SRC_URI="http://ab-initio.mit.edu/mpb/${P}.tar.gz"
HOMEPAGE="http://ab-initio.mit.edu/mpb/"
LICENSE="GPL-2"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE="doc examples hdf5 mpi"
SLOT="0"
@@ -30,18 +30,19 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch \
"${FILESDIR}"/${P}-autotools.patch \
+ "${FILESDIR}"/${P}-guile18.patch \
"${FILESDIR}"/${P}-headers.patch
cd "${S}"
eautoreconf
# version with inversion symmetry (mpbi).
- cp -r "${S}" "${S}_inv"
+ cp -r "${S}" "${S}_inv" || die
# version with hermitian eps (mpbh).
- cp -r "${S}" "${S}_herm"
+ cp -r "${S}" "${S}_herm" || die
# mpi versions (mpb-mpi).
if use mpi; then
- cp -r "${S}" "${S}_mpi"
- cp -r "${S}" "${S}_inv_mpi"
- cp -r "${S}" "${S}_herm_mpi"
+ cp -r "${S}" "${S}_mpi" || die
+ cp -r "${S}" "${S}_inv_mpi" || die
+ cp -r "${S}" "${S}_herm_mpi" || die
fi
tc-export CC
}
@@ -49,31 +50,34 @@ src_prepare() {
src_configure() {
# enable legacy API for hdf-1.8
use hdf5 && append-cflags -DH5_USE_16_API
+ #
+ local myconf=(
+ --with-libctl="${EPREFIX}/usr/share/libctl"
+ --with-blas="$(pkg-config --libs blas)"
+ --with-lapack="$(pkg-config --libs lapack)"
+ $(use_with hdf5)
+ )
- local myconf="$(use_with hdf5)"
- export BLAS_LIBS="$(pkg-config --libs blas)"
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
-
- econf ${myconf}
+ econf "${myconf[@]}"
cd "${S}_inv"
- econf ${myconf} \
+ econf "${myconf[@]}" \
--with-inv-symmetry
cd "${S}_herm"
- econf ${myconf} \
+ econf "${myconf[@]}" \
--with-hermitian-eps
if use mpi; then
cd "${S}_mpi"
- econf ${myconf} \
+ econf "${myconf[@]}" \
--with-mpi
cd "${S}_inv_mpi"
- econf ${myconf} \
+ econf "${myconf[@]}" \
--with-inv-symmetry \
--with-mpi
cd "${S}_herm_mpi"
- econf ${myconf} \
+ econf "${myconf[@]}" \
--with-hermitian-eps \
--with-mpi \
CC=mpicc
@@ -81,44 +85,41 @@ src_configure() {
}
src_compile() {
- local dirs="${S} ${S}_inv ${S}_herm"
- for d in ${dirs}; do
- cd "${d}"
+ local d
+ for d in . _inv _herm; do
+ cd "${S}${d}"
emake -C mpb-ctl ctl-io.c
emake
done
- local dirs="${S} ${S}_inv ${S}_herm"
if use mpi; then
- for d in ${dirs}; do
- cd "${d}_mpi"
- emake -C mpb-ctl ctl-io.c CC=mpicc || die
- emake CC=mpicc LD=mpicc || die "emake in ${d}_mpi failed"
+ for d in . _inv _herm; do
+ cd "${S}${d}_mpi"
+ emake -C mpb-ctl ctl-io.c CC=mpicc
+ emake CC=mpicc LD=mpicc
done
fi
}
src_install() {
- einstall || die "einstall failed"
+ einstall
dodoc README NEWS AUTHORS COPYRIGHT ChangeLog TODO
-
- if use doc; then
- dohtml doc/* || die
- fi
+ use doc && dohtml doc/*
if use examples; then
insinto /usr/share/doc/${PF}
- doins -r mpb-ctl/examples || die
+ doins -r mpb-ctl/examples
fi
- newbin "${d}"/mpb-ctl/.mpb mpbi || die
- newbin "${S}_herm"/mpb-ctl/.mpb mpbh || die
+ newbin "${S}_inv"/mpb-ctl/.mpb mpbi
+ newbin "${S}_herm"/mpb-ctl/.mpb mpbh
+
einfo "Several versions of mpb have been installed:"
einfo "mpb : regular version"
einfo "mpbi: configured for inversion symmetry"
einfo "mpbh: configured for hermitian epsilon"
if use mpi; then
- newbin "${S}_mpi"/mpb-ctl/.mpb mpb-mpi || die
- newbin "${S}_inv_mpi"/mpb-ctl/.mpb mpbh-mpi || die
- newbin "${S}_herm_mpi"/mpb-ctl/.mpb mpbi-mpi || die
+ newbin "${S}_mpi"/mpb-ctl/.mpb mpb-mpi
+ newbin "${S}_inv_mpi"/mpb-ctl/.mpb mpbh-mpi
+ newbin "${S}_herm_mpi"/mpb-ctl/.mpb mpbi-mpi
einfo "mpb-mpi : regular version with mpi"
einfo "mpbi-mpi: configured for inversion symmetry with mpi"
einfo "mpbh-mpi: configured for hermitian epsilon with mpi"