summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-10 13:16:06 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-10 13:16:06 +0000
commit5fd94ee83674fa1f7cfc009372b7fb9c447734df (patch)
treefe5076ce60d1141df4a4eb21b27751de8ef97af4 /sci-physics/meep
parentIO-Zlib was not replaced by IO-Compress (diff)
downloadgentoo-2-5fd94ee83674fa1f7cfc009372b7fb9c447734df.tar.gz
gentoo-2-5fd94ee83674fa1f7cfc009372b7fb9c447734df.tar.bz2
gentoo-2-5fd94ee83674fa1f7cfc009372b7fb9c447734df.zip
Fix building with GCC 4.4+ wrt #278427.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/meep')
-rw-r--r--sci-physics/meep/ChangeLog6
-rw-r--r--sci-physics/meep/files/meep-1.0.3-gcc44.patch11
-rw-r--r--sci-physics/meep/meep-1.0.3.ebuild7
3 files changed, 22 insertions, 2 deletions
diff --git a/sci-physics/meep/ChangeLog b/sci-physics/meep/ChangeLog
index 14883912eee7..270ee2f0a689 100644
--- a/sci-physics/meep/ChangeLog
+++ b/sci-physics/meep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/meep
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/meep/ChangeLog,v 1.10 2009/07/14 18:33:46 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/meep/ChangeLog,v 1.11 2009/08/10 13:16:06 ssuominen Exp $
+
+ 10 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> meep-1.0.3.ebuild,
+ +files/meep-1.0.3-gcc44.patch:
+ Fix building with GCC 4.4+ wrt #278427.
*meep-1.0.3 (14 Jul 2009)
diff --git a/sci-physics/meep/files/meep-1.0.3-gcc44.patch b/sci-physics/meep/files/meep-1.0.3-gcc44.patch
new file mode 100644
index 000000000000..31f4fc9b79c4
--- /dev/null
+++ b/sci-physics/meep/files/meep-1.0.3-gcc44.patch
@@ -0,0 +1,11 @@
+diff -ur meep-1.0.3.orig/src/h5file.cpp meep-1.0.3/src/h5file.cpp
+--- meep-1.0.3.orig/src/h5file.cpp 2009-05-23 05:43:24.000000000 +0300
++++ meep-1.0.3/src/h5file.cpp 2009-08-10 16:13:03.000000000 +0300
+@@ -15,6 +15,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#include <cstdio>
+ #include <cstdlib>
+ #include <string.h>
+
diff --git a/sci-physics/meep/meep-1.0.3.ebuild b/sci-physics/meep/meep-1.0.3.ebuild
index e23ed2e501c4..4c476572c265 100644
--- a/sci-physics/meep/meep-1.0.3.ebuild
+++ b/sci-physics/meep/meep-1.0.3.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/meep/meep-1.0.3.ebuild,v 1.1 2009/07/14 18:33:46 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/meep/meep-1.0.3.ebuild,v 1.2 2009/08/10 13:16:06 ssuominen Exp $
EAPI=2
+inherit eutils
DESCRIPTION="Simulation software to model electromagnetic systems"
HOMEPAGE="http://ab-initio.mit.edu/meep/"
@@ -22,6 +23,10 @@ DEPEND="sci-libs/fftw
mpi? ( virtual/mpi )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+}
+
src_configure() {
econf \
--enable-shared \