summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-03-23 03:24:53 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-03-23 03:24:53 +0000
commit50c3cb884f9db452aeff53d7a8650fbbf2dd2850 (patch)
tree5c30a02c3e351db835ca93c63e37595cb813d163 /sci-physics/heppdt
parentVersion bump (diff)
downloadgentoo-2-50c3cb884f9db452aeff53d7a8650fbbf2dd2850.tar.gz
gentoo-2-50c3cb884f9db452aeff53d7a8650fbbf2dd2850.tar.bz2
gentoo-2-50c3cb884f9db452aeff53d7a8650fbbf2dd2850.zip
Initial import
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/heppdt')
-rw-r--r--sci-physics/heppdt/ChangeLog10
-rw-r--r--sci-physics/heppdt/heppdt-3.04.01.ebuild42
-rw-r--r--sci-physics/heppdt/metadata.xml14
3 files changed, 66 insertions, 0 deletions
diff --git a/sci-physics/heppdt/ChangeLog b/sci-physics/heppdt/ChangeLog
new file mode 100644
index 000000000000..66943f5eac3f
--- /dev/null
+++ b/sci-physics/heppdt/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-physics/heppdt
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/heppdt/ChangeLog,v 1.1 2010/03/23 03:24:53 bicatali Exp $
+
+*heppdt-3.04.01 (23 Mar 2010)
+
+ 23 Mar 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +heppdt-3.04.01.ebuild, +metadata.xml:
+ Initial import
+
diff --git a/sci-physics/heppdt/heppdt-3.04.01.ebuild b/sci-physics/heppdt/heppdt-3.04.01.ebuild
new file mode 100644
index 000000000000..197a3b54ddfd
--- /dev/null
+++ b/sci-physics/heppdt/heppdt-3.04.01.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/heppdt/heppdt-3.04.01.ebuild,v 1.1 2010/03/23 03:24:53 bicatali Exp $
+
+EAPI=2
+inherit autotools
+
+MYP=HepPDT-${PV}
+
+DESCRIPTION="Data about each particle from the Review of Particle Properties"
+HOMEPAGE="http://lcgapp.cern.ch/project/simu/HepPDT/"
+SRC_URI="${HOMEPAGE}/download/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ # respect user flags
+ sed -i \
+ -e '/AC_SUBST(AM_CXXFLAGS)/d' \
+ configure.ac || die
+ # directories
+ sed -i \
+ -e 's:$(prefix)/data:$(datadir)/${PN}:g' \
+ data/Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README ChangeLog
+ use doc && mv "${D}"usr/doc/* "${D}"usr/share/doc/${PF}/
+ use examples && mv "${D}"usr/examples "${D}"usr/share/doc/${PF}/
+ rm -rf "${D}"usr/{doc,examples}
+}
diff --git a/sci-physics/heppdt/metadata.xml b/sci-physics/heppdt/metadata.xml
new file mode 100644
index 000000000000..89a8cc95903e
--- /dev/null
+++ b/sci-physics/heppdt/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+ HepPDT contains the fixed data about each particle type. In other
+ words, it contains the data that can be found in the Review of
+ Particle Properties.
+ This data is conceptually split into particle information (e.g. mass)
+ and decay information. HepPDT provides a simple set of particle data
+ classes. Particle ID translation methods are in a separate HepPID
+ library, which is distributed as part of HepPDT.
+</longdescription>
+</pkgmetadata>