summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-06-08 05:15:07 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-06-08 05:15:07 +0000
commite7af839d2cd6b06d254a7c035ed56c9eed8ec7c4 (patch)
tree1465c53989a842f6ba6568cabaf9ef9c9152bd3d /sci-physics/hepmc
parentManually preserve +x bits on postsync.d files #301721 by Klaus Birkelund Jensen. (diff)
downloadgentoo-2-e7af839d2cd6b06d254a7c035ed56c9eed8ec7c4.tar.gz
gentoo-2-e7af839d2cd6b06d254a7c035ed56c9eed8ec7c4.tar.bz2
gentoo-2-e7af839d2cd6b06d254a7c035ed56c9eed8ec7c4.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/hepmc')
-rw-r--r--sci-physics/hepmc/ChangeLog8
-rw-r--r--sci-physics/hepmc/hepmc-2.06.00.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/sci-physics/hepmc/ChangeLog b/sci-physics/hepmc/ChangeLog
index ee3bdbab7a30..d80d0b71b302 100644
--- a/sci-physics/hepmc/ChangeLog
+++ b/sci-physics/hepmc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/hepmc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/ChangeLog,v 1.15 2010/05/25 21:18:31 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/ChangeLog,v 1.16 2010/06/08 05:15:07 bicatali Exp $
+
+*hepmc-2.06.00 (08 Jun 2010)
+
+ 08 Jun 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +hepmc-2.06.00.ebuild:
+ Version bump
25 May 2010; Pacho Ramos <pacho@gentoo.org> hepmc-2.05.01.ebuild:
stable amd64, bug 318461
diff --git a/sci-physics/hepmc/hepmc-2.06.00.ebuild b/sci-physics/hepmc/hepmc-2.06.00.ebuild
new file mode 100644
index 000000000000..7699445f7e73
--- /dev/null
+++ b/sci-physics/hepmc/hepmc-2.06.00.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/hepmc-2.06.00.ebuild,v 1.1 2010/06/08 05:15:07 bicatali Exp $
+
+EAPI=2
+
+MYP=HepMC-${PV}
+
+DESCRIPTION="Event Record for Monte Carlo Generators"
+HOMEPAGE="https://savannah.cern.ch/projects/hepmc/"
+SRC_URI="http://lcgapp.cern.ch/project/simu/HepMC/download/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="doc examples gev cm"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ # use MeV over GeV and mm over cm
+ local length_conf="MM"
+ use cm && length_conf="CM"
+ local momentum_conf="MEV"
+ use gev && momentum_conf="GEV"
+ econf \
+ --with-length=${length_conf} \
+ --with-momentum=${momentum_conf}
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ cd doc
+ doxygen doxygen.conf || die "doc building failed"
+ fi
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ INSTALLDIR=/usr/share/doc/${PF}/examples \
+ doc_installdir=/usr/share/doc/${PF} \
+ install || die "emake install failed"
+
+ dodoc README AUTHORS ChangeLog
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins -r doc/html doc/*.pdf || die
+ else
+ rm -f "${D}"/usr/share/doc/${PF}/*pdf
+ fi
+ use examples || rm -rf "${D}"/usr/share/doc/${PF}/examples
+}