summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-05-03 16:21:07 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-05-03 16:21:07 +0000
commit62e0e57d4b23250cb71ace90b21f18b01e0e89b0 (patch)
tree919e212041d27f87f6a12f8e6f15968b918c5f56 /sci-physics/hepmc
parentbetter align keywords with libsoup, tested by myself (diff)
downloadgentoo-2-62e0e57d4b23250cb71ace90b21f18b01e0e89b0.tar.gz
gentoo-2-62e0e57d4b23250cb71ace90b21f18b01e0e89b0.tar.bz2
gentoo-2-62e0e57d4b23250cb71ace90b21f18b01e0e89b0.zip
Version bump
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/hepmc')
-rw-r--r--sci-physics/hepmc/ChangeLog7
-rw-r--r--sci-physics/hepmc/hepmc-2.06.05.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/sci-physics/hepmc/ChangeLog b/sci-physics/hepmc/ChangeLog
index baf35b597980..3944357a6f8d 100644
--- a/sci-physics/hepmc/ChangeLog
+++ b/sci-physics/hepmc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/hepmc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/ChangeLog,v 1.26 2011/04/14 08:12:45 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/ChangeLog,v 1.27 2011/05/03 16:21:07 bicatali Exp $
+
+*hepmc-2.06.05 (03 May 2011)
+
+ 03 May 2011; Sébastien Fabbro <bicatali@gentoo.org> +hepmc-2.06.05.ebuild:
+ Version bump
14 Apr 2011; Justin Lecher <jlec@gentoo.org> hepmc-2.06.03.ebuild,
hepmc-2.06.04.ebuild, +files/hepmc-2.06.04-gcc46.patch:
diff --git a/sci-physics/hepmc/hepmc-2.06.05.ebuild b/sci-physics/hepmc/hepmc-2.06.05.ebuild
new file mode 100644
index 000000000000..f4ab9a678012
--- /dev/null
+++ b/sci-physics/hepmc/hepmc-2.06.05.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/hepmc-2.06.05.ebuild,v 1.1 2011/05/03 16:21:07 bicatali Exp $
+
+EAPI=4
+
+inherit eutils
+
+MYP=HepMC-${PV}
+
+DESCRIPTION="Event Record for Monte Carlo Generators"
+HOMEPAGE="https://savannah.cern.ch/projects/hepmc/"
+SRC_URI="http://lcgapp.cern.ch/project/simu/HepMC/download/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc examples gev cm static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ # use MeV over GeV and mm over cm
+ local length_conf="MM"
+ use cm && length_conf="CM"
+ local momentum_conf="MEV"
+ use gev && momentum_conf="GEV"
+ econf \
+ --with-length=${length_conf} \
+ --with-momentum=${momentum_conf} \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ cd doc
+ doxygen doxygen.conf || die "doc building failed"
+ fi
+}
+
+src_install() {
+ emake \
+ DESTDIR="${ED}" \
+ INSTALLDIR="${EPREFIX}/usr/share/doc/${PF}/examples" \
+ doc_installdir="${EPREFIX}/usr/share/doc/${PF}" \
+ install
+
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins -r doc/html doc/*.pdf || die
+ else
+ rm -f "${ED}"/usr/share/doc/${PF}/*pdf
+ fi
+ use examples || rm -rf "${ED}"/usr/share/doc/${PF}/examples
+}