summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-03-13 21:52:56 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-03-13 21:52:56 +0000
commitf951fd9650e77a3f0271106555e727aa712e99c6 (patch)
tree17b4f9a7821e4028fa21302c29c068e8eb6cf2c0 /sci-physics/geant
parentUse "-python${PYTHON_ABI}" instead of "$(PYTHON)" as suffix, for consistency ... (diff)
downloadgentoo-2-f951fd9650e77a3f0271106555e727aa712e99c6.tar.gz
gentoo-2-f951fd9650e77a3f0271106555e727aa712e99c6.tar.bz2
gentoo-2-f951fd9650e77a3f0271106555e727aa712e99c6.zip
Fixed more zlib issues. The geant3 flag is now only for unit conversion (if geant3 is needed, geant:3 has to be installed from user). The data is now fetched (building needs network) to ease maintenance and set up the proper env variables in the geant4*sh scripts. Removed a use dawn duplicate. Thanks Marek Szuba for his suggestions (bug #407517 and bug #359673). Added a message for backward compatibility (bug #360285)
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/geant')
-rw-r--r--sci-physics/geant/ChangeLog15
-rw-r--r--sci-physics/geant/files/geant-4.9.4-zlib.patch14
-rw-r--r--sci-physics/geant/geant-4.9.5-r1.ebuild73
3 files changed, 100 insertions, 2 deletions
diff --git a/sci-physics/geant/ChangeLog b/sci-physics/geant/ChangeLog
index ef0f36c34299..79e2e3c964fe 100644
--- a/sci-physics/geant/ChangeLog
+++ b/sci-physics/geant/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sci-physics/geant
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.55 2011/12/18 07:13:04 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.56 2012/03/13 21:52:56 bicatali Exp $
+
+*geant-4.9.5-r1 (13 Mar 2012)
+
+ 13 Mar 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ files/geant-4.9.4-zlib.patch, +geant-4.9.5-r1.ebuild:
+ Fixed more zlib issues. The geant3 flag is now only for unit conversion (if
+ geant3 is needed, geant:3 has to be installed from user). The data is now
+ fetched (building needs network) to ease maintenance and set up the proper
+ env variables in the geant4*sh scripts. Removed a use dawn duplicate. Thanks
+ Marek Szuba for his suggestions (bug #407517 and bug #359673). Added a
+ message for backward compatibility (bug #360285)
*geant-4.9.5 (18 Dec 2011)
*geant-4.9.4_p03 (18 Dec 2011)
diff --git a/sci-physics/geant/files/geant-4.9.4-zlib.patch b/sci-physics/geant/files/geant-4.9.4-zlib.patch
index ac7b72818be9..1aaa3e5083ed 100644
--- a/sci-physics/geant/files/geant-4.9.4-zlib.patch
+++ b/sci-physics/geant/files/geant-4.9.4-zlib.patch
@@ -18,3 +18,17 @@
LINK_LIBRARIES
)
+--- source/visualization/externals/gl2ps/sources.cmake.orig 2011-12-02 16:07:56.000000000 +0100
++++ source/visualization/externals/gl2ps/sources.cmake 2012-03-09 14:09:26.965148002 +0100
+@@ -49,9 +49,9 @@
+ G4OpenGL2PSAction.cc
+ gl2ps.cc
+ GRANULAR_DEPENDENCIES
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ GLOBAL_DEPENDENCIES
+- G4zlib
++ ${ZLIB_LIBRARIES}
+ LINK_LIBRARIES
+ ${OPENGL_LIBRARIES}
+ )
diff --git a/sci-physics/geant/geant-4.9.5-r1.ebuild b/sci-physics/geant/geant-4.9.5-r1.ebuild
new file mode 100644
index 000000000000..f954aa483d40
--- /dev/null
+++ b/sci-physics/geant/geant-4.9.5-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.5-r1.ebuild,v 1.1 2012/03/13 21:52:56 bicatali Exp $
+
+EAPI=4
+
+inherit cmake-utils eutils fortran-2 versionator
+
+PV1=$(get_version_component_range 1 ${PV})
+PV2=$(get_version_component_range 2 ${PV})
+PV3=$(get_version_component_range 3 ${PV})
+MYP=${PN}$(replace_version_separator 3 .)
+
+DESCRIPTION="Toolkit for simulation of passage of particles through matter"
+HOMEPAGE="http://geant4.cern.ch/"
+SRC_URI="http://geant4.cern.ch/support/source/${MYP}.tar.gz"
+
+LICENSE="geant4"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="+data dawn examples gdml geant3 granular motif opengl openinventor
+ raytracerx qt4 static-libs test vrml zlib"
+
+RDEPEND="virtual/fortran
+ >=sci-physics/clhep-2.1.1
+ dawn? ( media-gfx/dawn )
+ gdml? ( dev-libs/xerces-c )
+ motif? ( x11-libs/openmotif:0 )
+ openinventor? ( media-libs/openinventor )
+ raytracerx? ( x11-libs/libX11 x11-libs/libXmu )
+ qt4? ( x11-libs/qt-gui:4 opengl? ( x11-libs/qt-opengl:4 ) )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.9.4-zlib.patch )
+
+src_configure() {
+ mycmakeargs=(
+ -DGEANT4_USE_SYSTEM_CLHEP=ON
+ $(cmake-utils_use data GEANT4_INSTALL_DATA)
+ $(cmake-utils_use dawn GEANT4_USE_NETWORKDAWN)
+ $(cmake-utils_use gdml GEANT4_USE_GDML)
+ $(cmake-utils_use geant3 GEANT4_USE_G3TOG4)
+ $(cmake-utils_use granular GEANT4_BUILD_GRANULAR_BUILD)
+ $(cmake-utils_use motif GEANT4_USE_XM)
+ $(cmake-utils_use opengl GEANT4_USE_OPENGL_X11)
+ $(cmake-utils_use openinventor GEANT4_USE_INVENTOR)
+ $(cmake-utils_use qt4 GEANT4_USE_QT)
+ $(cmake-utils_use raytracerx GEANT4_USE_RAYTRACER_X11)
+ $(cmake-utils_use test GEANT4_ENABLE_TESTING)
+ $(cmake-utils_use vrml GEANT4_USE_NETWORKVRML)
+ $(cmake-utils_use zlib GEANT4_USE_SYSTEM_ZLIB)
+ $(cmake-utils_use_build static-libs STATIC_LIBS)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ insinto /usr/share/doc/${PF}
+ local mypv="${PV1}.${PV2}.${PV3}"
+ doins ReleaseNotes/ReleaseNotes${mypv}.html
+ [[ -e ReleaseNotes/Patch${mypv}-1.txt ]] && \
+ dodoc ReleaseNotes/Patch${mypv}-*.txt
+ use examples && doins -r examples
+}
+
+pkg_postinst() {
+ elog "The following scripts are provided for backward compatibility:"
+ elog "$(ls -1 ${EROOT}usr/share/Geant4-${PV2}.${PV3}.*/geant4make/*sh)"
+}