summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-06-10 16:51:50 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-06-10 16:51:50 +0000
commit161f72f44886def035a3c7435dc8769195bdd496 (patch)
tree906da48c8c8515d1883e852d8e9778e018a2eed1 /sci-physics/geant
parentVersion bump from science overlay (diff)
downloadgentoo-2-161f72f44886def035a3c7435dc8769195bdd496.tar.gz
gentoo-2-161f72f44886def035a3c7435dc8769195bdd496.tar.bz2
gentoo-2-161f72f44886def035a3c7435dc8769195bdd496.zip
Split installation of all data into a new package sci-physics/geant-data, also fixing bug #472550
(Portage version: 2.2.01.21938-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-physics/geant')
-rw-r--r--sci-physics/geant/ChangeLog9
-rw-r--r--sci-physics/geant/geant-4.9.6_p02-r1.ebuild (renamed from sci-physics/geant/geant-4.9.6_p01.ebuild)15
2 files changed, 13 insertions, 11 deletions
diff --git a/sci-physics/geant/ChangeLog b/sci-physics/geant/ChangeLog
index d121ead97d20..ee9b4f5244ce 100644
--- a/sci-physics/geant/ChangeLog
+++ b/sci-physics/geant/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/geant
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.73 2013/06/05 16:14:34 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.74 2013/06/10 16:51:50 bicatali Exp $
+
+*geant-4.9.6_p02-r1 (10 Jun 2013)
+
+ 10 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org>
+ +geant-4.9.6_p02-r1.ebuild, -geant-4.9.6_p01.ebuild:
+ Split installation of all data into a new package sci-physics/geant-data, also
+ fixing bug #472550
*geant-4.9.6_p02 (05 Jun 2013)
diff --git a/sci-physics/geant/geant-4.9.6_p01.ebuild b/sci-physics/geant/geant-4.9.6_p02-r1.ebuild
index 33b46bfcb804..df0179a6a414 100644
--- a/sci-physics/geant/geant-4.9.6_p01.ebuild
+++ b/sci-physics/geant/geant-4.9.6_p02-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.6_p01.ebuild,v 1.2 2013/03/02 23:26:38 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.6_p02-r1.ebuild,v 1.1 2013/06/10 16:51:50 bicatali Exp $
EAPI=5
@@ -33,6 +33,7 @@ RDEPEND="
raytracerx? ( x11-libs/libX11 x11-libs/libXmu )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}"
+PDEPEND="data? ( ~sci-physics/geant-data-${PV} )"
S="${WORKDIR}/${MYP}"
@@ -42,8 +43,8 @@ src_configure() {
local mycmakeargs=(
-DGEANT4_USE_SYSTEM_CLHEP=ON
-DCMAKE_INSTALL_LIBDIR="${EROOT}usr/$(get_libdir)"
+ -DGEANT4_INSTALL_DATA=OFF
$(use openinventor && echo "-DINVENTOR_SOXT_LIBRARY=${EROOT}usr/$(get_libdir)/libInventorXt.so")
- $(cmake-utils_use data GEANT4_INSTALL_DATA)
$(cmake-utils_use dawn GEANT4_USE_NETWORKDAWN)
$(cmake-utils_use gdml GEANT4_USE_GDML)
$(cmake-utils_use geant3 GEANT4_USE_G3TOG4)
@@ -62,8 +63,7 @@ src_configure() {
src_install() {
# adjust clhep linking flags for system clhep
# binmake.gmk is only useful for legacy build systems
- sed -i "s,-lG4clhep,-lCLHEP," config/binmake.gmk || die "sed failed"
-
+ sed -i -e 's/-lG4clhep/-lCLHEP/' config/binmake.gmk || die
cmake-utils_src_install
insinto /usr/share/doc/${PF}
local mypv="${PV1}.${PV2}.${PV3}"
@@ -71,14 +71,9 @@ src_install() {
[[ -e ReleaseNotes/Patch${mypv}-1.txt ]] && \
dodoc ReleaseNotes/Patch${mypv}-*.txt
use examples && doins -r examples
- if use data ; then
- sed -n "s,export \(G4.\+DATA=\"\).*\(/share/Geant.\+/data/.\+\) > /dev/null ; pwd\`,\1${EPREFIX}/usr\2,p" \
- "${CMAKE_BUILD_DIR}/InstallTreeFiles/geant4.sh" > 99geant
- doenvd 99geant
- fi
}
pkg_postinst() {
elog "The following scripts are provided for backward compatibility:"
- elog "$(ls -1 ${EROOT}usr/share/Geant4-${PV2}.${PV3}.*/geant4make/*sh)"
+ elog "$(ls -1 ${EROOT%/}/usr/share/Geant4-${PV2}.${PV3}.*/geant4make/*sh)"
}