summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-01-22 02:28:43 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-01-22 02:28:43 +0000
commit58997ded796c47522159ae0027cc7dde412a8866 (patch)
tree29051dc2ebbb3f0f19ec2cbcefffb4c5eef27eb9 /sci-physics/geant/files
parentRemoved cspase (diff)
downloadgentoo-2-58997ded796c47522159ae0027cc7dde412a8866.tar.gz
gentoo-2-58997ded796c47522159ae0027cc7dde412a8866.tar.bz2
gentoo-2-58997ded796c47522159ae0027cc7dde412a8866.zip
Version bump, switched to cmake. Fixed Qt drivers bug #263450, bug #347279. Removed G4WORKDIR bug #345855.
(Portage version: 2.1.9.34/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/geant/files')
-rw-r--r--sci-physics/geant/files/geant-4.9.3-zlib.patch21
-rw-r--r--sci-physics/geant/files/geant-4.9.4-datadir.patch43
-rw-r--r--sci-physics/geant/files/geant-4.9.4-libdir.patch35
-rw-r--r--sci-physics/geant/files/geant-4.9.4-no-benchmarks.patch10
-rw-r--r--sci-physics/geant/files/geant-4.9.4-no-examples.patch15
-rw-r--r--sci-physics/geant/files/geant-4.9.4-zlib.patch11
6 files changed, 131 insertions, 4 deletions
diff --git a/sci-physics/geant/files/geant-4.9.3-zlib.patch b/sci-physics/geant/files/geant-4.9.3-zlib.patch
index 516a4840ae73..f047abdb31cd 100644
--- a/sci-physics/geant/files/geant-4.9.3-zlib.patch
+++ b/sci-physics/geant/files/geant-4.9.3-zlib.patch
@@ -1,7 +1,5 @@
-diff --git a/config/binmake.gmk b/config/binmake.gmk
-index 75bbaf2..c31ed3d 100644
---- a/config/binmake.gmk
-+++ b/config/binmake.gmk
+--- config/binmake.gmk.orig
++++ config/binmake.gmk
@@ -234,7 +234,7 @@ ifdef GLOBALLIBS
-lG4intercoms \
-lG4global
@@ -12,3 +10,18 @@ index 75bbaf2..c31ed3d 100644
endif
+--- config/architecture.gmk.orig 2011-01-16 00:22:05.976079082 +0000
++++ config/architecture.gmk 2011-01-16 00:23:18.346082379 +0000
+@@ -214,8 +214,10 @@
+ else
+ LDFLAGS += -L$(CLHEP_LIB_DIR)
+ LOADLIBS := -l$(CLHEP_LIB) -lm
+- ifndef G4LIB_USE_ZLIB
+- LOADLIBS += -lz
++ ifdef G4LIB_USE_ZLIB
++ ifndef G4LIB_BUILD_ZLIB
++ LOADLIBS += -lz
++ endif
+ endif
+ endif
+
diff --git a/sci-physics/geant/files/geant-4.9.4-datadir.patch b/sci-physics/geant/files/geant-4.9.4-datadir.patch
new file mode 100644
index 000000000000..c691d90e8ce4
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-datadir.patch
@@ -0,0 +1,43 @@
+--- cmake/Modules/Geant4ToolchainBackwardCompatibility.cmake.orig 2011-01-22 00:49:11.096082056 +0000
++++ cmake/Modules/Geant4ToolchainBackwardCompatibility.cmake 2011-01-22 00:53:04.746078920 +0000
+@@ -74,9 +74,9 @@
+ # Construct backward compatible variables
+ #
+ set(G4SYSTEM "${GEANT4_SYSTEM}-${GEANT4_COMPILER}")
+-set(G4INSTALL ${GEANT4_DATADIR}/geant4-${geant4_VERSION})
++set(G4INSTALL ${GEANT4_DATADIR}/geant4)
+ set(G4INCLUDE ${GEANT4_INCLUDEDIR}/geant4)
+-set(G4LIB ${GEANT4_LIBDIR}/geant4-${geant4_VERSION})
++set(G4LIB ${GEANT4_LIBDIR}/geant4)
+
+ message(STATUS "Geant4 backwards compatible variable G4SYSTEM : ${G4SYSTEM}")
+ message(STATUS "Geant4 backwards compatible variable G4INSTALL: ${G4INSTALL}")
+@@ -125,7 +125,7 @@
+ # Install targets
+ # toolchain
+ install(DIRECTORY config
+- DESTINATION ${GEANT4_DATAROOTDIR}/geant4-${geant4_VERSION}
++ DESTINATION ${GEANT4_DATAROOTDIR}/geant4
+ FILES_MATCHING PATTERN "*.gmk"
+ PATTERN "CVS" EXCLUDE
+ PATTERN "scripts/" EXCLUDE)
+@@ -134,16 +134,16 @@
+ install(FILES
+ ${CMAKE_BINARY_DIR}/outputs/runtime/geant4-${geant4_VERSION}.sh
+ ${CMAKE_BINARY_DIR}/outputs/runtime/geant4-${geant4_VERSION}.csh
+- DESTINATION ${GEANT4_DATAROOTDIR}/geant4-${geant4_VERSION}/config
++ DESTINATION ${GEANT4_DATAROOTDIR}/geant4/config
+ PERMISSIONS
+ OWNER_READ OWNER_WRITE OWNER_EXECUTE
+ GROUP_READ GROUP_EXECUTE
+ WORLD_READ WORLD_EXECUTE)
+
+ # compatibility softlink to library directory
+- install(CODE "execute_process(COMMAND \${CMAKE_COMMAND} -E make_directory \$ENV{DESTDIR}${GEANT4_LIBDIR}/geant4-${geant4_VERSION})")
++ install(CODE "execute_process(COMMAND \${CMAKE_COMMAND} -E make_directory \$ENV{DESTDIR}${GEANT4_LIBDIR}/geant4)")
+
+- install(CODE "execute_process(COMMAND \${CMAKE_COMMAND} -E create_symlink .. ${GEANT4_SYSTEM}-${GEANT4_COMPILER} WORKING_DIRECTORY \$ENV{DESTDIR}${GEANT4_LIBDIR}/geant4-${geant4_VERSION})")
++ install(CODE "execute_process(COMMAND \${CMAKE_COMMAND} -E create_symlink .. ${GEANT4_SYSTEM}-${GEANT4_COMPILER} WORKING_DIRECTORY \$ENV{DESTDIR}${GEANT4_LIBDIR}/geant4)")
+
+ endif()
+
diff --git a/sci-physics/geant/files/geant-4.9.4-libdir.patch b/sci-physics/geant/files/geant-4.9.4-libdir.patch
new file mode 100644
index 000000000000..8934f73acfe9
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-libdir.patch
@@ -0,0 +1,35 @@
+--- CMakeLists.txt.orig 2011-01-17 06:25:14.536078940 +0000
++++ CMakeLists.txt 2011-01-21 23:50:53.406082074 +0000
+@@ -195,7 +195,7 @@
+ set(GEANT4_PREFIX ${CMAKE_INSTALL_PREFIX})
+ set(GEANT4_EXEC_PREFIX ${GEANT4_PREFIX})
+ set(GEANT4_BINDIR ${GEANT4_EXEC_PREFIX}/bin)
+-set(GEANT4_LIBDIR ${GEANT4_PREFIX}/lib)
++set(GEANT4_LIBDIR ${GEANT4_PREFIX}/lib${LIB_SUFFIX})
+ set(GEANT4_DATAROOTDIR ${GEANT4_PREFIX}/share)
+ set(GEANT4_DATADIR ${GEANT4_DATAROOTDIR})
+ set(GEANT4_INCLUDEDIR ${GEANT4_PREFIX}/include)
+--- cmake/Modules/Geant4MacroLibraryTargets.cmake.orig 2011-01-21 23:36:09.356079013 +0000
++++ cmake/Modules/Geant4MacroLibraryTargets.cmake 2011-01-21 23:49:49.826082339 +0000
+@@ -35,8 +35,8 @@
+ # NEEDS WORK TO REMOVE HARDCODED LIB/BIN DIR
+ install(TARGETS ${G4LIBTARGET_NAME}
+ RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib)
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX})
+ endif()
+
+ #
+@@ -59,8 +59,8 @@
+
+ install(TARGETS ${G4LIBTARGET_NAME}-static
+ RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib)
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX})
+ endif()
+ ENDMACRO()
+
diff --git a/sci-physics/geant/files/geant-4.9.4-no-benchmarks.patch b/sci-physics/geant/files/geant-4.9.4-no-benchmarks.patch
new file mode 100644
index 000000000000..8c9d47707ac4
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-no-benchmarks.patch
@@ -0,0 +1,10 @@
+--- source/geometry/CMakeLists.txt.orig 2011-01-17 05:09:38.046080303 +0000
++++ source/geometry/CMakeLists.txt 2011-01-17 05:09:59.636215548 +0000
+@@ -12,7 +12,6 @@
+ #
+ #------------------------------------------------------------------------------
+
+-add_subdirectory(benchmarks)
+ add_subdirectory(biasing)
+ add_subdirectory(divisions)
+ add_subdirectory(magneticfield)
diff --git a/sci-physics/geant/files/geant-4.9.4-no-examples.patch b/sci-physics/geant/files/geant-4.9.4-no-examples.patch
new file mode 100644
index 000000000000..6db7b3f9017d
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-no-examples.patch
@@ -0,0 +1,15 @@
+--- CMakeLists.txt.orig 2011-01-22 01:47:07.000000000 +0000
++++ CMakeLists.txt 2011-01-22 02:00:58.676084146 +0000
+@@ -209,9 +209,9 @@
+ # Install any extra files needed such as documentation and legacy Makefiles
+ #
+ # User example code
+-install(DIRECTORY examples
+- DESTINATION ${GEANT4_DATAROOTDIR}/geant4-${geant4_VERSION}
+- PATTERN "CVS" EXCLUDE)
++#install(DIRECTORY examples
++# DESTINATION ${GEANT4_DATAROOTDIR}/geant4-${geant4_VERSION}
++# PATTERN "CVS" EXCLUDE)
+
+
+ #
diff --git a/sci-physics/geant/files/geant-4.9.4-zlib.patch b/sci-physics/geant/files/geant-4.9.4-zlib.patch
new file mode 100644
index 000000000000..faa850e214ae
--- /dev/null
+++ b/sci-physics/geant/files/geant-4.9.4-zlib.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2011-01-17 06:25:14.536078940 +0000
++++ CMakeLists.txt 2011-01-17 06:25:26.166078780 +0000
+@@ -154,7 +154,7 @@
+ #------------------------------------------------------------------------------
+ # Optional use of system zlib library
+ #
+-#option(GEANT4_USE_SYSTEM_ZLIB "Use the system's zlib library" OFF)
++option(GEANT4_USE_SYSTEM_ZLIB "Use the system's zlib library" OFF)
+ if(GEANT4_USE_SYSTEM_ZLIB)
+ # This needs more work - use ITK's way of doing it as an example.
+ find_package(ZLIB)