summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-20 00:39:52 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-20 00:39:52 +0000
commit70e3d02bf6a339563421efb151d746f3230fdcea (patch)
tree0becbd17482b0007eed15205ca4965566b3c746c /sci-physics/fastjet
parentVersion bump (diff)
downloadgentoo-2-70e3d02bf6a339563421efb151d746f3230fdcea.tar.gz
gentoo-2-70e3d02bf6a339563421efb151d746f3230fdcea.tar.bz2
gentoo-2-70e3d02bf6a339563421efb151d746f3230fdcea.zip
Version bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/fastjet')
-rw-r--r--sci-physics/fastjet/ChangeLog7
-rw-r--r--sci-physics/fastjet/fastjet-3.0.2.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/sci-physics/fastjet/ChangeLog b/sci-physics/fastjet/ChangeLog
index f09514ec70c8..fc62f87214c7 100644
--- a/sci-physics/fastjet/ChangeLog
+++ b/sci-physics/fastjet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/fastjet
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/ChangeLog,v 1.1 2012/01/08 01:32:14 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/ChangeLog,v 1.2 2012/01/20 00:39:52 bicatali Exp $
+
+*fastjet-3.0.2 (20 Jan 2012)
+
+ 20 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +fastjet-3.0.2.ebuild:
+ Version bump
*fastjet-3.0.1 (08 Jan 2012)
diff --git a/sci-physics/fastjet/fastjet-3.0.2.ebuild b/sci-physics/fastjet/fastjet-3.0.2.ebuild
new file mode 100644
index 000000000000..e5111520ed29
--- /dev/null
+++ b/sci-physics/fastjet/fastjet-3.0.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/fastjet-3.0.2.ebuild,v 1.1 2012/01/20 00:39:52 bicatali Exp $
+
+EAPI=4
+inherit autotools-utils fortran-2 flag-o-matic
+
+DESCRIPTION="Fast implementation of several recombination jet algorithms"
+HOMEPAGE="http://www.fastjet.fr/"
+SRC_URI="${HOMEPAGE}/repo/${P}.tar.gz"
+
+LICENSE="GPL-2 QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cgal doc examples +plugins static-libs"
+
+RDEPEND="cgal? ( sci-mathematics/cgal )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ plugins? ( virtual/fortran )"
+
+src_configure() {
+ use cgal && has_version sci-mathematics/cgal[gmp] && append-ldflags -lgmp
+ myeconfargs+=(
+ $(use_enable cgal)
+ $(use_enable plugins allplugins)
+ $(use_enable plugins allcxxplugins)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && doxygen Doxyfile
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml html/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ find example \
+ -name Makefile -or Makefile.in -or Makefile.am -delete
+ doins -r example/*
+ fi
+}