summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 15:38:07 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 15:38:07 +0000
commit551c31cfaecb354767e50c38ee532a24e8d30974 (patch)
tree53e3360f3e92f69ab70951aee1448e5a76674e27 /sci-physics/abinit
parentRemoval of fortran.eclass, #348851 (diff)
downloadgentoo-2-551c31cfaecb354767e50c38ee532a24e8d30974.tar.gz
gentoo-2-551c31cfaecb354767e50c38ee532a24e8d30974.tar.bz2
gentoo-2-551c31cfaecb354767e50c38ee532a24e8d30974.zip
Removal of fortran.eclass, #348851
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/abinit')
-rw-r--r--sci-physics/abinit/ChangeLog6
-rw-r--r--sci-physics/abinit/abinit-5.3.4.ebuild12
-rw-r--r--sci-physics/abinit/abinit-5.4.4-r1.ebuild12
-rw-r--r--sci-physics/abinit/abinit-5.4.4.ebuild12
4 files changed, 20 insertions, 22 deletions
diff --git a/sci-physics/abinit/ChangeLog b/sci-physics/abinit/ChangeLog
index 96f1df39215a..65ae1e0ce4af 100644
--- a/sci-physics/abinit/ChangeLog
+++ b/sci-physics/abinit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/abinit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/abinit/ChangeLog,v 1.12 2010/07/16 22:27:55 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/abinit/ChangeLog,v 1.13 2010/12/16 15:38:07 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> abinit-5.3.4.ebuild,
+ abinit-5.4.4.ebuild, abinit-5.4.4-r1.ebuild:
+ Removal of fortran.eclass, #348851
16 Jul 2010; Sébastien Fabbro <bicatali@gentoo.org> abinit-6.0.4.ebuild:
Removed fortran eclass use. Now really use autotools, propagate mpi
diff --git a/sci-physics/abinit/abinit-5.3.4.ebuild b/sci-physics/abinit/abinit-5.3.4.ebuild
index 813e3e606e51..0717eb4143df 100644
--- a/sci-physics/abinit/abinit-5.3.4.ebuild
+++ b/sci-physics/abinit/abinit-5.3.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/abinit/abinit-5.3.4.ebuild,v 1.1 2007/05/09 06:47:17 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/abinit/abinit-5.3.4.ebuild,v 1.2 2010/12/16 15:38:07 jlec Exp $
-inherit fortran toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Find total energy, charge density and electronic structure using density functional theory"
HOMEPAGE="http://www.abinit.org/"
@@ -21,14 +21,12 @@ RDEPEND="virtual/blas
DEPEND="${RDEPEND}"
# F90 code, g77 won't work
-FORTRAN="gfortran ifc"
pkg_setup() {
- fortran_pkg_setup
# Doesn't compile with gcc-4.0, only >=4.1
local diemsg="Requires gcc-4.1 or newer"
- if [[ "${FORTRANC}" = "gfortran" ]]; then
+ if [[ "$(tc-getFC)" = "gfortran" ]]; then
if [[ $(gcc-major-version) -eq 4 ]] \
&& [[ $(gcc-minor-version) -lt 1 ]]; then
die "${diemsg}"
@@ -61,7 +59,7 @@ src_compile() {
--with-c-optflags="${CFLAGS}" \
--with-fortran-optflags="${FFLAGS}" \
--with-fortran-ldflags='-lpthread' \
- FC="${FORTRANC}" \
+ FC="$(tc-getFC)" \
CC="$(tc-getCC)" \
|| die "configure failed"
# $(use_enable netcdf) \
diff --git a/sci-physics/abinit/abinit-5.4.4-r1.ebuild b/sci-physics/abinit/abinit-5.4.4-r1.ebuild
index 83cb1ab0dc90..0ebdad1c0da6 100644
--- a/sci-physics/abinit/abinit-5.4.4-r1.ebuild
+++ b/sci-physics/abinit/abinit-5.4.4-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/abinit/abinit-5.4.4-r1.ebuild,v 1.1 2009/12/18 01:26:24 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/abinit/abinit-5.4.4-r1.ebuild,v 1.2 2010/12/16 15:38:07 jlec Exp $
-inherit fortran toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Find total energy, charge density and electronic structure using density functional theory"
HOMEPAGE="http://www.abinit.org/"
@@ -18,14 +18,12 @@ RDEPEND="virtual/blas
DEPEND="${RDEPEND}"
# F90 code, g77 won't work
-FORTRAN="gfortran ifc"
pkg_setup() {
- fortran_pkg_setup
# Doesn't compile with gcc-4.0, only >=4.1
local diemsg="Requires gcc-4.1 or newer"
- if [[ "${FORTRANC}" = "gfortran" ]]; then
+ if [[ "$(tc-getFC)" = "gfortran" ]]; then
if [[ $(gcc-major-version) -eq 4 ]] \
&& [[ $(gcc-minor-version) -lt 1 ]]; then
die "${diemsg}"
@@ -66,7 +64,7 @@ src_compile() {
--with-cc-optflags="${CFLAGS}" \
--with-fc-optflags="${FFLAGS}" \
--with-fc-ldflags='-lpthread' \
- FC="${FORTRANC}" \
+ FC="$(tc-getFC)" \
CC="$(tc-getCC)" \
LD="$(tc-getLD)" \
|| die "configure failed"
diff --git a/sci-physics/abinit/abinit-5.4.4.ebuild b/sci-physics/abinit/abinit-5.4.4.ebuild
index f1755440c23c..7846849b0787 100644
--- a/sci-physics/abinit/abinit-5.4.4.ebuild
+++ b/sci-physics/abinit/abinit-5.4.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/abinit/abinit-5.4.4.ebuild,v 1.1 2008/07/05 01:10:36 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/abinit/abinit-5.4.4.ebuild,v 1.2 2010/12/16 15:38:07 jlec Exp $
-inherit fortran toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Find total energy, charge density and electronic structure using density functional theory"
HOMEPAGE="http://www.abinit.org/"
@@ -18,14 +18,12 @@ RDEPEND="virtual/blas
DEPEND="${RDEPEND}"
# F90 code, g77 won't work
-FORTRAN="gfortran ifc"
pkg_setup() {
- fortran_pkg_setup
# Doesn't compile with gcc-4.0, only >=4.1
local diemsg="Requires gcc-4.1 or newer"
- if [[ "${FORTRANC}" = "gfortran" ]]; then
+ if [[ "$(tc-getFC)" = "gfortran" ]]; then
if [[ $(gcc-major-version) -eq 4 ]] \
&& [[ $(gcc-minor-version) -lt 1 ]]; then
die "${diemsg}"
@@ -69,7 +67,7 @@ src_compile() {
--with-c-optflags="${CFLAGS}" \
--with-fortran-optflags="${FFLAGS}" \
--with-fortran-ldflags='-lpthread' \
- FC="${FORTRANC}" \
+ FC="$(tc-getFC)" \
CC="$(tc-getCC)" \
LD="$(tc-getLD)" \
|| die "configure failed"