summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-09-29 17:45:00 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-09-29 17:45:00 +0000
commitd6d1e6c0717e38d903646aff846c825021229ada (patch)
tree315491433931c08e4fbc2a0442e5d09bf8dcd872 /sci-misc
parentFilter -fvisibility-inlines-hidden as a workaround for bug 282838. (diff)
downloadgentoo-2-d6d1e6c0717e38d903646aff846c825021229ada.tar.gz
gentoo-2-d6d1e6c0717e38d903646aff846c825021229ada.tar.bz2
gentoo-2-d6d1e6c0717e38d903646aff846c825021229ada.zip
Add new as-needed patch per bug #286771. Also fix elog informations per bug #286905.
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/ChangeLog8
-rw-r--r--sci-misc/boinc/boinc-6.6.40-r1.ebuild23
-rw-r--r--sci-misc/boinc/boinc-6.6.40.ebuild146
-rw-r--r--sci-misc/boinc/files/6.6.40-as-needed.patch21
4 files changed, 41 insertions, 157 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index c739c9072a16..5f2590b1b305 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.72 2009/09/28 19:28:40 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.73 2009/09/29 17:45:00 scarabeus Exp $
+
+ 29 Sep 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/6.6.40-as-needed.patch, -boinc-6.6.40.ebuild,
+ boinc-6.6.40-r1.ebuild:
+ Add new as-needed patch per bug #286771. Also fix elog informations per
+ bug #286905.
*boinc-6.6.40-r1 (28 Sep 2009)
diff --git a/sci-misc/boinc/boinc-6.6.40-r1.ebuild b/sci-misc/boinc/boinc-6.6.40-r1.ebuild
index 76cfdfb5d33d..ce5b98d7a24a 100644
--- a/sci-misc/boinc/boinc-6.6.40-r1.ebuild
+++ b/sci-misc/boinc/boinc-6.6.40-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-6.6.40-r1.ebuild,v 1.1 2009/09/28 19:28:40 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-6.6.40-r1.ebuild,v 1.2 2009/09/29 17:45:00 scarabeus Exp $
EAPI="2"
@@ -88,6 +88,7 @@ src_configure() {
--disable-dependency-tracking \
--enable-unicode \
--with-ssl \
+ --enable-optimize \
$(use_with X x) \
${wxconf} \
${conf}
@@ -124,8 +125,8 @@ pkg_setup() {
pkg_postinst() {
echo
- elog "You are using the source compiled version."
- elog "The manager can be found at /usr/bin/${PN}_gui"
+ elog "You are using the source compiled version of ${PN}."
+ use X && elog "The graphical manager can be found at /usr/bin/${PN}mgr"
elog
elog "You need to attach to a project to do anything useful with ${PN}."
elog "You can do this by running /etc/init.d/${PN} attach"
@@ -133,13 +134,15 @@ pkg_postinst() {
elog "http://boinc.berkeley.edu/wiki/Anonymous_platform"
elog
# Add warning about the new password for the client, bug 121896.
- elog "If you need to use the graphical client the password is in:"
- elog "/var/lib/${PN}/gui_rpc_auth.cfg"
- elog "Where /var/lib/ is default RUNTIMEDIR, that can be changed in:"
- elog "/etc/conf.d/${PN}"
- elog "You should change this to something more memorable (can be even blank)."
- elog
- elog "Remember to launch init script before using manager. Or changing the password."
+ if use X; then
+ elog "If you need to use the graphical manager the password is in:"
+ elog "/var/lib/${PN}/gui_rpc_auth.cfg"
+ elog "Where /var/lib/ is default RUNTIMEDIR, that can be changed in:"
+ elog "/etc/conf.d/${PN}"
+ elog "You should change this password to something more memorable (can be even blank)."
+ elog "Remember to launch init script before using manager. Or changing the password."
+ elog
+ fi
if use cuda; then
elog "To be able to use CUDA you should add boinc user to video group."
elog "To do so run as root:"
diff --git a/sci-misc/boinc/boinc-6.6.40.ebuild b/sci-misc/boinc/boinc-6.6.40.ebuild
deleted file mode 100644
index 919d15642102..000000000000
--- a/sci-misc/boinc/boinc-6.6.40.ebuild
+++ /dev/null
@@ -1,146 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-6.6.40.ebuild,v 1.3 2009/09/28 10:26:55 scarabeus Exp $
-
-EAPI="2"
-
-inherit flag-o-matic depend.apache eutils wxwidgets autotools
-
-DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
-HOMEPAGE="http://boinc.ssl.berkeley.edu/"
-SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="X +client cuda server"
-
-RDEPEND="
- !sci-misc/boinc-bin
- !app-admin/quickswitch
- >=app-misc/ca-certificates-20080809
- dev-libs/openssl
- net-misc/curl
- sys-apps/util-linux
- sys-libs/zlib
- cuda? (
- >=dev-util/nvidia-cuda-toolkit-2.1
- >=x11-drivers/nvidia-drivers-180.22
- )
- server? (
- >=virtual/mysql-5.0
- dev-python/mysql-python
- )
-"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- server? ( virtual/imap-c-client )
- X? (
- media-libs/freeglut
- media-libs/jpeg
- x11-libs/wxGTK:2.8[X,opengl]
- )
-"
-
-src_prepare() {
- # use system ssl certificates
- mkdir "${S}"/curl
- cp /etc/ssl/certs/ca-certificates.crt "${S}"/curl/ca-bundle.crt
-
- epatch \
- "${FILESDIR}"/6.4.5-glibc210.patch \
- "${FILESDIR}"/${PV}-*
-
- eautoreconf
-}
-
-src_configure() {
- local wxconf=""
- local conf=""
-
- # define preferable CFLAGS (recommended by upstream)
- append-flags -O3 -funroll-loops -fforce-addr -ffast-math
-
- # look for wxGTK
- if use X; then
- WX_GTK_VER="2.8"
- need-wxwidgets unicode
- wxconf+=" --with-wx-config=${WX_CONFIG}"
- else
- wxconf+=" --without-wxdir"
- fi
-
- # Bug #248769: don't use strlcat and friends from kerberos or similar
- #local func
- #for func in strlcat strlcpy; do
- # eval "export ac_cv_func_${func}=no"
- # append-cppflags -D${func}=boinc_${func}
- #done
- use server || conf+=" --disable-server"
- use X || conf+=" --disable-manager"
- use client || conf+=" --disable-client"
-
- # configure
- econf \
- --disable-dependency-tracking \
- --enable-unicode \
- --with-ssl \
- --enable-optimize \
- $(use_with X x) \
- ${wxconf} \
- ${conf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- dodir /var/lib/${PN}/
- keepdir /var/lib/${PN}/
-
- if use X; then
- newicon "${S}"/packages/generic/sea/${PN}mgr.48x48.png ${PN}.png || die
- make_desktop_entry boincmgr "${PN}" "${PN}" "Math;Science" /var/lib/${PN}
- fi
-
- # cleanup cruft
- rm -rf "${D}"/etc/
-
- newinitd "${FILESDIR}"/${PN}.init ${PN}
- newconfd "${FILESDIR}"/${PN}.conf ${PN}
-}
-
-pkg_setup() {
- enewgroup ${PN}
- # note this works only for first install so we have to
- # elog user about the need of being in video group
- if use cuda; then
- enewuser ${PN} -1 -1 /var/lib/${PN} "${PN},video"
- else
- enewuser ${PN} -1 -1 /var/lib/${PN} "${PN}"
- fi
-}
-
-pkg_postinst() {
- echo
- elog "You are using the source compiled version."
- elog "The manager can be found at /usr/bin/${PN}_gui"
- elog
- elog "You need to attach to a project to do anything useful with ${PN}."
- elog "You can do this by running /etc/init.d/${PN} attach"
- elog "The howto for configuration is located at:"
- elog "http://boinc.berkeley.edu/wiki/Anonymous_platform"
- elog
- # Add warning about the new password for the client, bug 121896.
- elog "If you need to use the graphical client the password is in:"
- elog "/var/lib/${PN}/gui_rpc_auth.cfg"
- elog "Where /var/lib/ is default RUNTIMEDIR, that can be changed in:"
- elog "/etc/conf.d/${PN}"
- elog "You should change this to something more memorable (can be even blank)."
- elog
- elog "Remember to launch init script before using manager. Or changing the password."
- if use cuda; then
- elog "To be able to use CUDA you should add boinc user to video group."
- elog "To do so run as root:"
- elog "gpasswd -a boinc video"
- fi
-}
diff --git a/sci-misc/boinc/files/6.6.40-as-needed.patch b/sci-misc/boinc/files/6.6.40-as-needed.patch
new file mode 100644
index 000000000000..24ccc5a75f4c
--- /dev/null
+++ b/sci-misc/boinc/files/6.6.40-as-needed.patch
@@ -0,0 +1,21 @@
+Make boinc compile with LDFLAGS="-Wl,--as-needed"
+
+2009-09-28 Martin von Gagern
+
+References:
+http://bugs.gentoo.org/286771
+http://www.gentoo.org/proj/en/qa/asneeded.xml
+
+Index: boinc-6.6.40/lib/Makefile.am
+===================================================================
+--- boinc-6.6.40.orig/lib/Makefile.am
++++ boinc-6.6.40/lib/Makefile.am
+@@ -103,7 +103,7 @@ libboinc_la_SOURCES = $(generic_sources)
+ libboinc_la_CFLAGS = $(AM_CFLAGS) $(PICFLAGS) $(PTHREAD_CFLAGS)
+ libboinc_la_CXXFLAGS = $(AM_CXXFLAGS) $(PICFLAGS) $(PTHREAD_CFLAGS)
+ libboinc_la_LDFLAGS = -L$(libdir) -rpath $(libdir) -version-number $(LIBBOINC_VERSION)
+-libboinc_la_LIBADD =
++libboinc_la_LIBADD = $(SSL_LIBS)
+
+ if ENABLE_FCGI
+ lib_LTLIBRARIES += libboinc_fcgi.la