summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2006-11-03 15:28:30 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2006-11-03 15:28:30 +0000
commitd276943f2d50556202856c991bd3db48287faf96 (patch)
tree7e9777d5b35ec8eb4a71dd2384c4bebcc4f6a926 /sci-misc
parentAdded correct automake and pkgconfig dependency. (diff)
downloadgentoo-2-d276943f2d50556202856c991bd3db48287faf96.tar.gz
gentoo-2-d276943f2d50556202856c991bd3db48287faf96.tar.bz2
gentoo-2-d276943f2d50556202856c991bd3db48287faf96.zip
Version bump to add latest stable, bug 151556. Removed old version.
(Portage version: 2.1.2_rc1-r2)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/ChangeLog9
-rw-r--r--sci-misc/boinc/boinc-5.4.11.ebuild96
-rw-r--r--sci-misc/boinc/files/digest-boinc-5.4.113
3 files changed, 107 insertions, 1 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index a3ca04fdef8d..1a087e66ab32 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.26 2006/10/15 22:20:09 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.27 2006/11/03 15:28:30 cryos Exp $
+
+*boinc-5.4.11 (03 Nov 2006)
+
+ 03 Nov 2006; Marcus D. Hanwell <cryos@gentoo.org>
+ -files/boinc-4.72.20050813-gcc4-fix.patch, -boinc-4.72.20050813-r3.ebuild,
+ +boinc-5.4.11.ebuild:
+ Version bump to add latest stable, bug 151556. Removed old version.
15 Oct 2006; Marcus D. Hanwell <cryos@gentoo.org> ChangeLog:
Redigesting, should fix bug 151389.
diff --git a/sci-misc/boinc/boinc-5.4.11.ebuild b/sci-misc/boinc/boinc-5.4.11.ebuild
new file mode 100644
index 000000000000..804e17468e7b
--- /dev/null
+++ b/sci-misc/boinc/boinc-5.4.11.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.4.11.ebuild,v 1.1 2006/11/03 15:28:30 cryos Exp $
+
+inherit eutils
+
+DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
+HOMEPAGE="http://boinc.ssl.berkeley.edu/"
+SRC_URI="mirror://gentoo//${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="server X unicode"
+
+RDEPEND="sys-libs/zlib
+ >=net-misc/curl-7.15.0
+ >=dev-libs/openssl-0.9.7
+ X? ( >=x11-libs/wxGTK-2.6.2 )
+ server? ( net-www/apache
+ >=dev-db/mysql-4.0.24
+ virtual/php
+ >=dev-lang/python-2.2.3
+ >=dev-python/mysql-python-0.9.2 )"
+DEPEND=">=sys-devel/gcc-3.0.4
+ >=sys-devel/autoconf-2.58
+ >=sys-devel/automake-1.8
+ >=dev-util/pkgconfig-0.15
+ >=sys-devel/m4-1.4
+ X? ( || ( ( x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-proto/xproto )
+ virtual/x11 )
+ virtual/glut
+ virtual/glu
+ media-libs/jpeg )
+ server? ( virtual/imap-c-client )
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # point to a proper mouse device
+ sed -e "s:/dev/mouse:/dev/input/mice:g" -i client/hostinfo_unix.C || die
+}
+
+src_compile() {
+ econf \
+ --enable-client \
+ --disable-static-client \
+ --with-wx-config=$(which wx-config-2.6) \
+ $(use_enable unicode) \
+ $(use_enable server) \
+ $(use_with X x) || die "econf failed"
+ # Make it link to the compiled libs, not the installed ones
+ sed -e "s|LDFLAGS = |LDFLAGS = -L../lib |g" -i */Makefile || \
+ die "sed failed"
+ # Force -j1 - bug 136374.
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+
+ newinitd ${FILESDIR}/boinc.init boinc
+ newconfd ${FILESDIR}/boinc.conf boinc
+
+ make_desktop_entry boinc_gui BOINC boinc Science /var/lib/boinc
+}
+
+pkg_preinst() {
+ enewgroup boinc
+ enewuser boinc -1 -1 /var/lib/boinc boinc
+}
+
+pkg_postinst() {
+ echo
+ einfo "You need to attach to a project to do anything useful with boinc."
+ einfo "You can do this by running /etc/init.d/boinc attach"
+ einfo "BOINC The howto for configuration is located at:"
+ einfo "http://boinc.berkeley.edu/anonymous_platform.php"
+ if use server;then
+ echo
+ einfo "You have chosen to enable server mode. this ebuild has installed"
+ einfo "the necessary packages to be a server. You will need to have a"
+ einfo "project. Contact BOINC directly for further information."
+ fi
+ echo
+ # Add warning about the new password for the client, bug 121896.
+ einfo "If you need to use the graphical client the password is in "
+ einfo "/var/lib/boinc/gui_rpc_auth.cfg which is randomly generated "
+ einfo "by BOINC. You can change this to something more memorable."
+ echo
+}
diff --git a/sci-misc/boinc/files/digest-boinc-5.4.11 b/sci-misc/boinc/files/digest-boinc-5.4.11
new file mode 100644
index 000000000000..abc66c4b39f7
--- /dev/null
+++ b/sci-misc/boinc/files/digest-boinc-5.4.11
@@ -0,0 +1,3 @@
+MD5 3da83789b1e5cb3aa0a4fb17a068a34f boinc-5.4.11.tar.bz2 9604328
+RMD160 5dc29d9720ca3bff6015991fbabe97929b4b1fb0 boinc-5.4.11.tar.bz2 9604328
+SHA256 cd67228ca08794714177e101f8a3b611a1f5e7d24506aaf3cf4edfa548c04a85 boinc-5.4.11.tar.bz2 9604328