summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-06 14:56:37 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-06 14:56:37 +0000
commitb638d57668f7e35043c76f590681800c3106adb9 (patch)
tree32c736fd66e6db595519ee676ccd5ff7a411167d /sci-misc
parentStable for HPPA (bug #316539). (diff)
downloadgentoo-2-b638d57668f7e35043c76f590681800c3106adb9.tar.gz
gentoo-2-b638d57668f7e35043c76f590681800c3106adb9.tar.bz2
gentoo-2-b638d57668f7e35043c76f590681800c3106adb9.zip
Set SUPPORT_PYTHON_ABIS (bug #316241).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/pythoncad/ChangeLog6
-rw-r--r--sci-misc/pythoncad/pythoncad-1.37.ebuild21
2 files changed, 19 insertions, 8 deletions
diff --git a/sci-misc/pythoncad/ChangeLog b/sci-misc/pythoncad/ChangeLog
index 054c847fdbb9..6aa89052a974 100644
--- a/sci-misc/pythoncad/ChangeLog
+++ b/sci-misc/pythoncad/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-misc/pythoncad
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/pythoncad/ChangeLog,v 1.4 2010/03/10 23:13:23 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/pythoncad/ChangeLog,v 1.5 2010/07/06 14:56:37 arfrever Exp $
+
+ 06 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pythoncad-1.37.ebuild:
+ Set SUPPORT_PYTHON_ABIS (bug #316241).
*pythoncad-1.37 (10 Mar 2010)
diff --git a/sci-misc/pythoncad/pythoncad-1.37.ebuild b/sci-misc/pythoncad/pythoncad-1.37.ebuild
index 8438fe5beb66..e75e7257a700 100644
--- a/sci-misc/pythoncad/pythoncad-1.37.ebuild
+++ b/sci-misc/pythoncad/pythoncad-1.37.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/pythoncad/pythoncad-1.37.ebuild,v 1.1 2010/03/10 23:13:23 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/pythoncad/pythoncad-1.37.ebuild,v 1.2 2010/07/06 14:56:37 arfrever Exp $
-NEED_PYTHON=2.3
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit eutils distutils versionator
@@ -12,9 +15,9 @@ MY_P=${MY_PN}-${MY_PV}
DESCRIPTION="CAD program written in PyGTK"
HOMEPAGE="http://www.pythoncad.org/"
-LICENSE="GPL-2"
SRC_URI="mirror://sourceforge/pythoncad/${MY_P}.tar.gz"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
@@ -26,9 +29,7 @@ PYTHON_MODNAME=${MY_PN}
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${P}-png.patch"
sed -i \
@@ -39,7 +40,13 @@ src_unpack() {
src_install() {
distutils_src_install
- newbin gtkpycad.py pythoncad
+
+ install_pythoncad() {
+ newbin gtkpycad.py pythoncad-${PYTHON_ABI}
+ }
+ python_execute_function -q install_pythoncad
+ python_generate_wrapper_scripts "${ED}usr/bin/pythoncad"
+
insinto /etc/"${PN}"
doins prefs.py
domenu pythoncad.desktop