summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-04-27 17:01:01 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-04-27 17:01:01 +0000
commitb4a2fef7e0ccab9db425010127e4a5d65b8833b2 (patch)
treee3401239762143f10dc7126ceb2b4e29dcd85410 /sci-misc
parentAdded udunits and ncap2 flags for sci-misc/nco (diff)
downloadgentoo-2-b4a2fef7e0ccab9db425010127e4a5d65b8833b2.tar.gz
gentoo-2-b4a2fef7e0ccab9db425010127e4a5d65b8833b2.tar.bz2
gentoo-2-b4a2fef7e0ccab9db425010127e4a5d65b8833b2.zip
Version bump. Added functionality through new use flags: mpi, udunits and ncap2. Proper documentation and longdescription added to metadata.xml. Closing bug #160843. Thanks snickl.freaks.de for his initial ebuild.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/nco/ChangeLog10
-rw-r--r--sci-misc/nco/files/digest-nco-3.2.03
-rw-r--r--sci-misc/nco/metadata.xml9
-rw-r--r--sci-misc/nco/nco-3.2.0.ebuild61
4 files changed, 82 insertions, 1 deletions
diff --git a/sci-misc/nco/ChangeLog b/sci-misc/nco/ChangeLog
index 0337105f2e41..1d46300f21bc 100644
--- a/sci-misc/nco/ChangeLog
+++ b/sci-misc/nco/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-misc/nco
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/nco/ChangeLog,v 1.5 2007/02/09 05:27:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/nco/ChangeLog,v 1.6 2007/04/27 17:01:01 bicatali Exp $
+
+*nco-3.2.0 (27 Apr 2007)
+
+ 27 Apr 2007; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ +nco-3.2.0.ebuild:
+ Version bump. Added functionality through new use flags: mpi, udunits and
+ ncap2. Proper documentation and longdescription added to metadata.xml.
+ Closing bug #160843. Thanks snickl.freaks.de for his initial ebuild.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/sci-misc/nco/files/digest-nco-3.2.0 b/sci-misc/nco/files/digest-nco-3.2.0
new file mode 100644
index 000000000000..ef6227c859e5
--- /dev/null
+++ b/sci-misc/nco/files/digest-nco-3.2.0
@@ -0,0 +1,3 @@
+MD5 f2b17cc39a21416d44a8891851a53a37 nco-3.2.0.tar.gz 3239108
+RMD160 37bf10ad387036c2d05757dea0163ebdf128a5a6 nco-3.2.0.tar.gz 3239108
+SHA256 7804dfb2e40ea6fa2bdbd81cf69c1eb1e6027f60d7f1c3d62d58eb413c5d3159 nco-3.2.0.tar.gz 3239108
diff --git a/sci-misc/nco/metadata.xml b/sci-misc/nco/metadata.xml
index b229aec85b8f..9ea6e83aa938 100644
--- a/sci-misc/nco/metadata.xml
+++ b/sci-misc/nco/metadata.xml
@@ -2,4 +2,13 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci</herd>
+<longdescription lang="en">
+Command-line operators to analyze netCDF files
+NetCDF Operator is a suite of programs known as operators. The
+operators are stand-alone, command-line programs executable in a POSIX
+shell. Operators take one or more netCDF files as input, perform an
+operation (e.g., averaging or hyperslabbing), and produce a netCDF
+output file. NCO was originally designed to manipulate and analyze
+climate data, though it works on any netCDF format datasets.
+</longdescription>
</pkgmetadata>
diff --git a/sci-misc/nco/nco-3.2.0.ebuild b/sci-misc/nco/nco-3.2.0.ebuild
new file mode 100644
index 000000000000..a131e40a2f58
--- /dev/null
+++ b/sci-misc/nco/nco-3.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/nco/nco-3.2.0.ebuild,v 1.1 2007/04/27 17:01:01 bicatali Exp $
+
+DESCRIPTION="Command line utilities for operating on netCDF files"
+SRC_URI="http://dust.ess.uci.edu/nco/src/${P}.tar.gz"
+HOMEPAGE="http://nco.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+
+IUSE="mpi doc ncap2 udunits"
+
+RDEPEND="sci-libs/netcdf
+ mpi? ( virtual/mpi )
+ udnunits? ( sci-libs/udunits )"
+
+DEPEND="${RDEPEND}
+ ncap2? ( !mpi? ( dev-java/antlr ) )
+ doc? ( virtual/tetex )"
+
+pkg_setup() {
+ if use mpi && use ncap2; then
+ elog
+ elog "mpi and ncap2 are still incompatible flags"
+ elog "nco configure will automatically disables ncap2"
+ elog
+ fi
+}
+
+src_compile() {
+ # force disabling experimental and not implemented features
+ econf \
+ --disable-dap \
+ --disable-netcdf4 \
+ --disable-i18n \
+ --enable-regex \
+ --enable-nco_cplusplus \
+ $(use_enable ncap2 ncoxx) \
+ $(use_enable udunits) \
+ $(use_enable mpi) \
+ || die "econf failed"
+ emake || die "emake failed"
+ cd "${S}"/doc
+ make clean info
+ use doc && make html pdf || die "make doc failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd doc
+ dodoc ANNOUNCE ChangeLog MANIFEST NEWS README TAG TODO VERSION *.txt \
+ || die "dodoc failed"
+ doinfo *.info* || die "doinfo failed"
+ if use doc; then
+ dohtml nco.html/*
+ insinto /usr/share/doc/${PF}
+ doins nco.pdf
+ fi
+}