summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-07-18 12:56:45 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2012-07-18 12:56:45 +0000
commit848c57802b8448c78bbae6b0494125b651b4dfd2 (patch)
tree3f9d31a0899cd466f4baad3fccc75b7e705150d8 /sci-misc
parentDrop misplaced doc dir. #426976 (diff)
downloadgentoo-2-848c57802b8448c78bbae6b0494125b651b4dfd2.tar.gz
gentoo-2-848c57802b8448c78bbae6b0494125b651b4dfd2.tar.bz2
gentoo-2-848c57802b8448c78bbae6b0494125b651b4dfd2.zip
[sci-misc/boinc] Version bump per bug #411463
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/ChangeLog9
-rw-r--r--sci-misc/boinc/boinc-7.0.29.ebuild145
-rw-r--r--sci-misc/boinc/files/7.0.2-fix_subdirs.patch10
3 files changed, 162 insertions, 2 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index b39b585c0fb5..9c52643ccbbc 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.108 2012/06/26 13:13:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.109 2012/07/18 12:56:45 alexxy Exp $
+
+*boinc-7.0.29 (18 Jul 2012)
+
+ 18 Jul 2012; Alexey Shvetsov <alexxy@gentoo.org> +boinc-7.0.29.ebuild,
+ +files/7.0.2-fix_subdirs.patch:
+ [sci-misc/boinc] Version bump per bug #411463
26 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> boinc-6.12.42.ebuild:
inherit user for enewgroup and enewuser
@@ -507,4 +513,3 @@
to Robert Moss <robmoss@gentoo.org> and Tony Murray <tonymurray@fastmail.fm>
for the ebuilds and maintenance performed by Tony, as well as all the other
contributors who helped with this ebuild. This closes bug 54962.
-
diff --git a/sci-misc/boinc/boinc-7.0.29.ebuild b/sci-misc/boinc/boinc-7.0.29.ebuild
new file mode 100644
index 000000000000..7f3c368b15b0
--- /dev/null
+++ b/sci-misc/boinc/boinc-7.0.29.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-7.0.29.ebuild,v 1.1 2012/07/18 12:56:44 alexxy Exp $
+
+EAPI=4
+
+WANT_AUTOMAKE="1.11"
+
+inherit flag-o-matic eutils wxwidgets autotools base user
+
+DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
+HOMEPAGE="http://boinc.ssl.berkeley.edu/"
+SRC_URI="http://dev.gentoo.org/~alexxy/distfiles/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X cuda"
+
+RDEPEND="
+ !sci-misc/boinc-bin
+ !app-admin/quickswitch
+ >=app-misc/ca-certificates-20080809
+ dev-libs/openssl
+ net-misc/curl[ssl,-gnutls(-),-nss(-),curl_ssl_openssl(+)]
+ sys-apps/util-linux
+ sys-libs/zlib
+ cuda? (
+ >=dev-util/nvidia-cuda-toolkit-2.1
+ >=x11-drivers/nvidia-drivers-180.22
+ )
+ X? (
+ dev-db/sqlite:3
+ media-libs/freeglut
+ sys-libs/glibc:2.2
+ virtual/jpeg
+ x11-libs/gtk+:2
+ >=x11-libs/libnotify-0.7
+ x11-libs/wxGTK:2.8[X,opengl]
+ )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ app-text/docbook-xml-dtd:4.4
+ app-text/docbook2X
+"
+
+PATCHES=(
+ "${FILESDIR}/7.0.2-fix_subdirs.patch"
+)
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # prevent bad changes in compile flags, bug 286701
+ sed -i -e "s:BOINC_SET_COMPILE_FLAGS::" configure.ac || die "sed failed"
+
+ base_src_prepare
+
+ eautoreconf
+}
+
+src_configure() {
+ local wxconf=""
+
+ # add gtk includes
+ append-flags "$(pkg-config --cflags gtk+-2.0)"
+
+ # look for wxGTK
+ if use X; then
+ WX_GTK_VER="2.8"
+ need-wxwidgets unicode
+ wxconf+=" --with-wx-config=${WX_CONFIG}"
+ else
+ wxconf+=" --without-wxdir"
+ fi
+
+ econf \
+ --disable-server \
+ --enable-client \
+ --enable-dynamic-client-linkage \
+ --disable-static \
+ --enable-unicode \
+ --with-ssl \
+ $(use_with X x) \
+ $(use_enable X manager) \
+ ${wxconf}
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ dodir /var/lib/${PN}/
+ keepdir /var/lib/${PN}/
+
+ if use X; then
+ newicon "${S}"/packages/generic/sea/${PN}mgr.48x48.png ${PN}.png || die
+ make_desktop_entry boincmgr "${PN}" "${PN}" "Math;Science" "Path=/var/lib/${PN}"
+ fi
+
+ # cleanup cruft
+ rm -rf "${D}"/etc/
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf ${PN}
+}
+
+pkg_preinst() {
+ enewgroup ${PN}
+ # note this works only for first install so we have to
+ # elog user about the need of being in video group
+ if use cuda; then
+ enewuser ${PN} -1 -1 /var/lib/${PN} "${PN},video"
+ else
+ enewuser ${PN} -1 -1 /var/lib/${PN} "${PN}"
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "You are using the source compiled version of ${PN}."
+ use X && elog "The graphical manager can be found at /usr/bin/${PN}mgr"
+ elog
+ elog "You need to attach to a project to do anything useful with ${PN}."
+ elog "You can do this by running /etc/init.d/${PN} attach"
+ elog "The howto for configuration is located at:"
+ elog "http://boinc.berkeley.edu/wiki/Anonymous_platform"
+ elog
+ # Add warning about the new password for the client, bug 121896.
+ if use X; then
+ elog "If you need to use the graphical manager the password is in:"
+ elog "/var/lib/${PN}/gui_rpc_auth.cfg"
+ elog "Where /var/lib/ is default RUNTIMEDIR, that can be changed in:"
+ elog "/etc/conf.d/${PN}"
+ elog "You should change this password to something more memorable (can be even blank)."
+ elog "Remember to launch init script before using manager. Or changing the password."
+ elog
+ fi
+ if use cuda; then
+ elog "To be able to use CUDA you should add boinc user to video group."
+ elog "Run as root:"
+ elog "gpasswd -a boinc video"
+ fi
+}
diff --git a/sci-misc/boinc/files/7.0.2-fix_subdirs.patch b/sci-misc/boinc/files/7.0.2-fix_subdirs.patch
new file mode 100644
index 000000000000..133fb51150c1
--- /dev/null
+++ b/sci-misc/boinc/files/7.0.2-fix_subdirs.patch
@@ -0,0 +1,10 @@
+--- boinc-7.0.2.old/configure.ac 2011-12-25 08:48:12.000000000 +0800
++++ boinc-7.0.2/configure.ac 2011-12-25 08:50:29.000000000 +0800
+@@ -901,7 +901,6 @@
+ apps/Makefile
+ clientgui/Makefile
+ clientgui/res/Makefile
+- clientscr/Makefile
+ client/Makefile
+ client/win/boinc_path_config.py:py/boinc_path_config.py.in
+ client/scripts/Makefile