summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-07-31 07:56:36 +0000
committerJustin Lecher <jlec@gentoo.org>2015-07-31 07:56:36 +0000
commit43df27487ac35733562bb86118d9f143ead46ff0 (patch)
treee69bacafb770d3a6484ae11177d20f9d16ae7652 /sci-misc
parentDocument JAVA_RM_FILES variable. Also, fix documentation and correct typos in... (diff)
downloadgentoo-2-43df27487ac35733562bb86118d9f143ead46ff0.tar.gz
gentoo-2-43df27487ac35733562bb86118d9f143ead46ff0.tar.bz2
gentoo-2-43df27487ac35733562bb86118d9f143ead46ff0.zip
Version Bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/nco/ChangeLog7
-rw-r--r--sci-misc/nco/nco-4.5.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/sci-misc/nco/ChangeLog b/sci-misc/nco/ChangeLog
index 0be47e28b519..e1f89775702c 100644
--- a/sci-misc/nco/ChangeLog
+++ b/sci-misc/nco/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-misc/nco
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/nco/ChangeLog,v 1.25 2015/07/31 07:45:44 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/nco/ChangeLog,v 1.26 2015/07/31 07:56:36 jlec Exp $
+
+*nco-4.5.1 (31 Jul 2015)
+
+ 31 Jul 2015; Justin Lecher <jlec@gentoo.org> +nco-4.5.1.ebuild:
+ Version Bump
31 Jul 2015; Justin Lecher <jlec@gentoo.org> -nco-4.3.1.ebuild, metadata.xml,
nco-4.4.2.ebuild:
diff --git a/sci-misc/nco/nco-4.5.1.ebuild b/sci-misc/nco/nco-4.5.1.ebuild
new file mode 100644
index 000000000000..d3b5771e125e
--- /dev/null
+++ b/sci-misc/nco/nco-4.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/nco/nco-4.5.1.ebuild,v 1.1 2015/07/31 07:56:36 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils eutils flag-o-matic
+
+DESCRIPTION="Command line utilities for operating on netCDF files"
+HOMEPAGE="http://nco.sourceforge.net/"
+SRC_URI="http://nco.sf.net/src/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="dap doc gsl ncap2 openmp static-libs test udunits"
+
+RDEPEND="
+ >=sci-libs/netcdf-4:=[dap=,tools]
+ gsl? ( sci-libs/gsl:= )
+ udunits? ( >=sci-libs/udunits-2 )"
+
+DEPEND="${RDEPEND}
+ ncap2? ( dev-java/antlr:0 )
+ test? ( >=sci-libs/netcdf-4[tools] )"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-udunits
+ $(use_enable dap dap-netcdf)
+ $(use_enable gsl)
+ $(use_enable ncap2)
+ $(use_enable openmp)
+ $(use_enable udunits udunits2)
+ )
+ if has_version '>=sci-libs/netcdf-4[hdf5]'; then
+ myeconfargs+=( --enable-netcdf4 )
+ append-cppflags -DHAVE_NETCDF4_H
+ else
+ myeconfargs+=( --disable-netcdf4 )
+ fi
+ autotools-utils_src_configure
+}
+
+src_install() {
+ use doc && DOCS=( doc/nco.pdf ) && HTML_DOCS=( doc/nco.html )
+ autotools-utils_src_install
+ doinfo doc/*.info*
+}