summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-11-10 21:14:27 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-11-10 21:14:27 +0000
commit3a1bb1e14119cb0f0bc8a7b52b779021e8f15f9a (patch)
tree996f96765ea1c6fe31f0aca5274b2c9d8dd0c4eb /sci-misc
parentRemove USE arts (deprecated). (diff)
downloadgentoo-2-3a1bb1e14119cb0f0bc8a7b52b779021e8f15f9a.tar.gz
gentoo-2-3a1bb1e14119cb0f0bc8a7b52b779021e8f15f9a.tar.bz2
gentoo-2-3a1bb1e14119cb0f0bc8a7b52b779021e8f15f9a.zip
Version bump. Drop old. Per bug #292640.
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/ChangeLog10
-rw-r--r--sci-misc/boinc/boinc-6.10.18.ebuild (renamed from sci-misc/boinc/boinc-6.4.5-r2.ebuild)93
-rw-r--r--sci-misc/boinc/files/6.4.5-RSA_security.patch64
-rw-r--r--sci-misc/boinc/files/6.4.5-gcc44.patch47
-rw-r--r--sci-misc/boinc/files/6.4.5-nostrip.patch30
5 files changed, 48 insertions, 196 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index c731a17fa799..7a33372fad50 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.78 2009/10/20 10:18:09 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.79 2009/11/10 21:14:27 scarabeus Exp $
+
+*boinc-6.10.18 (10 Nov 2009)
+
+ 10 Nov 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ -files/6.4.5-RSA_security.patch, -boinc-6.4.5-r2.ebuild,
+ -files/6.4.5-gcc44.patch, -files/6.4.5-nostrip.patch,
+ +boinc-6.10.18.ebuild:
+ Version bump. Drop old. Per bug #292640.
20 Oct 2009; Tomáš Chvátal <scarabeus@gentoo.org>
boinc-6.6.40-r2.ebuild:
diff --git a/sci-misc/boinc/boinc-6.4.5-r2.ebuild b/sci-misc/boinc/boinc-6.10.18.ebuild
index 275ed685aeb0..286fbe21b492 100644
--- a/sci-misc/boinc/boinc-6.4.5-r2.ebuild
+++ b/sci-misc/boinc/boinc-6.10.18.ebuild
@@ -1,14 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-6.4.5-r2.ebuild,v 1.4 2009/07/29 11:48:31 scarabeus Exp $
-
-#
-# Don't forget to keep things in sync with binary boinc package!
-#
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-6.10.18.ebuild,v 1.1 2009/11/10 21:14:27 scarabeus Exp $
EAPI="2"
-inherit flag-o-matic depend.apache eutils wxwidgets
+inherit flag-o-matic depend.apache eutils wxwidgets autotools
DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
HOMEPAGE="http://boinc.ssl.berkeley.edu/"
@@ -17,7 +13,7 @@ SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="X cuda server"
+IUSE="X +client cuda server"
RDEPEND="
!sci-misc/boinc-bin
@@ -46,26 +42,26 @@ DEPEND="${RDEPEND}
)
"
+# Upstream sucks in autotools
+#MAKEOPTS="-j1"
+
src_prepare() {
# use system ssl certificates
mkdir "${S}"/curl
cp /etc/ssl/certs/ca-certificates.crt "${S}"/curl/ca-bundle.crt
- # copy icons to correct location
- cp "${S}"/sea/*.png "${S}"/clientgui/res/
- # RSA Security bug fix. Per bug #258011
- # GCC 4.4 Compilation issue. Per bug #269618
- # Fix stripping. Per bug #257297
- # Fix glibc 2.10 compilation issues. Per bug #276868
+
+ # prevent bad changes in compile flags, bug 286701
+ sed -i -e "s:BOINC_SET_COMPILE_FLAGS::" configure.ac || die "sed failed"
+
epatch \
- "${FILESDIR}"/${PV}-RSA_security.patch \
- "${FILESDIR}"/${PV}-gcc44.patch \
- "${FILESDIR}"/${PV}-nostrip.patch \
- "${FILESDIR}"/${PV}-glibc210.patch
+ "${FILESDIR}"/6.4.5-glibc210.patch
+
+ eautoreconf
}
src_configure() {
local wxconf=""
- local config=""
+ local conf=""
# define preferable CFLAGS (recommended by upstream)
append-flags -O3 -funroll-loops -fforce-addr -ffast-math
@@ -74,41 +70,29 @@ src_configure() {
if use X; then
WX_GTK_VER="2.8"
need-wxwidgets unicode
- wxconf="${wxconf} --with-wx-config=${WX_CONFIG}"
+ wxconf+=" --with-wx-config=${WX_CONFIG}"
else
- wxconf="${wxconf} --without-wxdir"
+ wxconf+=" --without-wxdir"
fi
- # nonstandard enable
- use server || config="--disable-server"
-
# Bug #248769: don't use strlcat and friends from kerberos or similar
- local func
- for func in strlcat strlcpy; do
- eval "export ac_cv_func_${func}=no"
- append-cppflags -D${func}=boinc_${func}
- done
+ #local func
+ #for func in strlcat strlcpy; do
+ # eval "export ac_cv_func_${func}=no"
+ # append-cppflags -D${func}=boinc_${func}
+ #done
+ use server || conf+=" --disable-server"
+ use X || conf+=" --disable-manager"
+ use client || conf+=" --disable-client"
# configure
econf \
--disable-dependency-tracking \
- --with-gnu-ld \
--enable-unicode \
- --enable-client \
--with-ssl \
+ $(use_with X x) \
${wxconf} \
- ${config} \
- $(use_with X x)
-
- # Fix LDFLAGS. Link to compiled stuff and not to installed one
- sed -i \
- -e "s|LDFLAGS = |LDFLAGS = -L../lib |g" \
- */Makefile || die "sed failed"
-}
-
-src_compile() {
- # disable parallel build.
- emake -j1 || die "emake failed"
+ ${conf}
}
src_install() {
@@ -118,12 +102,11 @@ src_install() {
keepdir /var/lib/${PN}/
if use X; then
- newicon "${S}"/sea/${PN}mgr.48x48.png ${PN}.png
- make_desktop_entry boinc_gui "${PN}" "${PN}" "Math;Science" /var/lib/${PN}
+ newicon "${S}"/packages/generic/sea/${PN}mgr.48x48.png ${PN}.png || die
+ make_desktop_entry boincmgr "${PN}" "${PN}" "Math;Science" /var/lib/${PN}
fi
# cleanup cruft
- rm "${D}"/usr/bin/ca-bundle.crt
rm -rf "${D}"/etc/
newinitd "${FILESDIR}"/${PN}.init ${PN}
@@ -143,8 +126,8 @@ pkg_setup() {
pkg_postinst() {
echo
- elog "You are using the source compiled version."
- elog "The manager can be found at /usr/bin/${PN}_gui"
+ elog "You are using the source compiled version of ${PN}."
+ use X && elog "The graphical manager can be found at /usr/bin/${PN}mgr"
elog
elog "You need to attach to a project to do anything useful with ${PN}."
elog "You can do this by running /etc/init.d/${PN} attach"
@@ -152,13 +135,15 @@ pkg_postinst() {
elog "http://boinc.berkeley.edu/wiki/Anonymous_platform"
elog
# Add warning about the new password for the client, bug 121896.
- elog "If you need to use the graphical client the password is in:"
- elog "/var/lib/${PN}/gui_rpc_auth.cfg"
- elog "Where /var/lib/ is default RUNTIMEDIR, that can be changed in:"
- elog "/etc/conf.d/${PN}"
- elog "You should change this to something more memorable (can be even blank)."
- elog
- elog "Remember to launch init script before using manager. Or changing the password."
+ if use X; then
+ elog "If you need to use the graphical manager the password is in:"
+ elog "/var/lib/${PN}/gui_rpc_auth.cfg"
+ elog "Where /var/lib/ is default RUNTIMEDIR, that can be changed in:"
+ elog "/etc/conf.d/${PN}"
+ elog "You should change this password to something more memorable (can be even blank)."
+ elog "Remember to launch init script before using manager. Or changing the password."
+ elog
+ fi
if use cuda; then
elog "To be able to use CUDA you should add boinc user to video group."
elog "To do so run as root:"
diff --git a/sci-misc/boinc/files/6.4.5-RSA_security.patch b/sci-misc/boinc/files/6.4.5-RSA_security.patch
deleted file mode 100644
index 0098444ed5e7..000000000000
--- a/sci-misc/boinc/files/6.4.5-RSA_security.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-diff -urN boinc-6.4.5.old/lib/crypt.cpp boinc-6.4.5/lib/crypt.cpp
---- boinc-6.4.5.old/lib/crypt.cpp 2008-09-26 20:20:24.000000000 +0200
-+++ boinc-6.4.5/lib/crypt.cpp 2009-02-17 17:33:10.000000000 +0100
-@@ -243,7 +243,7 @@
- // The output block must be decrypted in its entirety.
- //
- int encrypt_private(R_RSA_PRIVATE_KEY& key, DATA_BLOCK& in, DATA_BLOCK& out) {
-- int n, modulus_len;
-+ int n, modulus_len, retval;
-
- modulus_len = (key.bits+7)/8;
- n = in.len;
-@@ -252,17 +252,27 @@
- }
- RSA* rp = RSA_new();
- private_to_openssl(key, rp);
-- RSA_private_encrypt(n, in.data, out.data, rp, RSA_PKCS1_PADDING);
-+ retval = RSA_private_encrypt(n, in.data, out.data, rp, RSA_PKCS1_PADDING);
-+ if (retval < 0) {
-+ RSA_free(rp);
-+ return ERR_CRYPTO;
-+ }
- out.len = RSA_size(rp);
- RSA_free(rp);
- return 0;
- }
-
- int decrypt_public(R_RSA_PUBLIC_KEY& key, DATA_BLOCK& in, DATA_BLOCK& out) {
-+ int retval;
- RSA* rp = RSA_new();
- public_to_openssl(key, rp);
-- RSA_public_decrypt(in.len, in.data, out.data, rp, RSA_PKCS1_PADDING);
-+ retval = RSA_public_decrypt(in.len, in.data, out.data, rp, RSA_PKCS1_PADDING);
-+ if (retval < 0) {
-+ RSA_free(rp);
-+ return ERR_CRYPTO;
-+ }
- out.len = RSA_size(rp);
-+ RSA_free(rp);
- return 0;
- }
-
-diff -urN boinc-6.4.5.old/lib/error_numbers.h boinc-6.4.5/lib/error_numbers.h
---- boinc-6.4.5.old/lib/error_numbers.h 2008-08-06 20:36:30.000000000 +0200
-+++ boinc-6.4.5/lib/error_numbers.h 2009-02-17 17:34:17.000000000 +0100
-@@ -185,6 +185,7 @@
- #define ERR_RMDIR -227
- #define ERR_SYMLINK -229
- #define ERR_DB_CONN_LOST -230
-+#define ERR_CRYPTO -231
-
- // PLEASE: add a text description of your error to
- // the text description function boincerror() in str_util.C.
-diff -urN boinc-6.4.5.old/lib/str_util.cpp boinc-6.4.5/lib/str_util.cpp
---- boinc-6.4.5.old/lib/str_util.cpp 2008-09-26 20:20:24.000000000 +0200
-+++ boinc-6.4.5/lib/str_util.cpp 2009-02-17 17:33:50.000000000 +0100
-@@ -735,6 +735,7 @@
- case ERR_RMDIR: return "rmdir() failed";
- case ERR_SYMLINK: return "symlink() failed";
- case ERR_DB_CONN_LOST: return "DB connection lost during enumeration";
-+ case ERR_CRYPTO: return "encryption error";
- case 404: return "HTTP file not found";
- case 407: return "HTTP proxy authentication failure";
- case 416: return "HTTP range request error";
diff --git a/sci-misc/boinc/files/6.4.5-gcc44.patch b/sci-misc/boinc/files/6.4.5-gcc44.patch
deleted file mode 100644
index de491d926957..000000000000
--- a/sci-misc/boinc/files/6.4.5-gcc44.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-diff -NrU5 boinc-6.4.5.orig/clientgui/common/wxFlatNotebook.cpp boinc-6.4.5/clientgui/common/wxFlatNotebook.cpp
---- boinc-6.4.5.orig/clientgui/common/wxFlatNotebook.cpp 2009-05-12 15:56:03.000000000 -0600
-+++ boinc-6.4.5/clientgui/common/wxFlatNotebook.cpp 2009-05-12 17:19:57.000000000 -0600
-@@ -605,11 +605,11 @@
- //
- // wxPageContainerBase
- //
- ///////////////////////////////////////////////////////////////////////////////////////////
-
--BEGIN_EVENT_TABLE(wxPageContainerBase, wxControl)
-+BEGIN_EVENT_TABLE(wxPageContainerBase, wxPanel)
- EVT_PAINT(wxPageContainerBase::OnPaint)
- EVT_SIZE(wxPageContainerBase::OnSize)
- EVT_LEFT_DOWN(wxPageContainerBase::OnLeftDown)
- EVT_LEFT_UP(wxPageContainerBase::OnLeftUp)
- EVT_RIGHT_DOWN(wxPageContainerBase::OnRightDown)
-diff -NrU5 boinc-6.4.5.orig/sched/sched_driver.cpp boinc-6.4.5/sched/sched_driver.cpp
---- boinc-6.4.5.orig/sched/sched_driver.cpp 2009-05-12 15:56:03.000000000 -0600
-+++ boinc-6.4.5/sched/sched_driver.cpp 2009-05-12 16:01:00.000000000 -0600
-@@ -38,10 +38,11 @@
- #define AUTHENTICATOR "49bcae97f1788385b0f41123acdf5694"
- // authenticator of a user record
- #define HOSTID "7"
- // ID of a host belonging to that user
-
-+#include <cstdio>
- #include <vector>
- #include "util.h"
-
- using std::vector;
-
-diff -NrU5 boinc-6.4.5.orig/sched/sched_util.cpp boinc-6.4.5/sched/sched_util.cpp
---- boinc-6.4.5.orig/sched/sched_util.cpp 2009-05-12 15:56:03.000000000 -0600
-+++ boinc-6.4.5/sched/sched_util.cpp 2009-05-12 17:58:59.000000000 -0600
-@@ -102,11 +102,11 @@
- #ifndef _USING_FCGI_
- int try_fopen(const char* path, FILE*& f, const char* mode) {
- #else
- int try_fopen(const char* path, FCGI_FILE*& f, const char *mode) {
- #endif
-- char* p;
-+ const char* p;
- DIR* d;
- char dirpath[256];
-
- #ifndef _USING_FCGI_
- f = fopen(path, mode);
diff --git a/sci-misc/boinc/files/6.4.5-nostrip.patch b/sci-misc/boinc/files/6.4.5-nostrip.patch
deleted file mode 100644
index cc9da4cef949..000000000000
--- a/sci-misc/boinc/files/6.4.5-nostrip.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -NrU5 boinc-6.4.5.orig/client/Makefile.in boinc-6.4.5/client/Makefile.in
---- boinc-6.4.5.orig/client/Makefile.in 2009-05-14 00:59:41.000000000 -0600
-+++ boinc-6.4.5/client/Makefile.in 2009-05-14 01:01:10.000000000 -0600
-@@ -1330,11 +1330,10 @@
- @CLIENT_BIN_FILENAME@: boinc_client
- rm -f $@
- rm -f $@.unmodified
- cp $? $@.unmodified
- @LN@ $? $@
-- @STRIP@ $@
-
- clean-local:
- rm -f @CLIENT_BIN_FILENAME@
- rm -f @CLIENT_BIN_FILENAME@.unmodified
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
-diff -NrU5 boinc-6.4.5.orig/lib/Makefile.in boinc-6.4.5/lib/Makefile.in
---- boinc-6.4.5.orig/lib/Makefile.in 2009-05-14 00:59:41.000000000 -0600
-+++ boinc-6.4.5/lib/Makefile.in 2009-05-14 01:00:31.000000000 -0600
-@@ -950,11 +950,10 @@
- @CLIENT_CMD_BIN_FILENAME@: boinc_cmd$(EXEEXT)
- rm -f $@
- rm -f $@.unmodified
- cp $? $@.unmodified
- @LN@ $? $@
-- @STRIP@ $@
-
- clean-local:
- rm -f @CLIENT_CMD_BIN_FILENAME@
- rm -f @CLIENT_CMD_BIN_FILENAME@.unmodified
- # Tell versions [3.59,3.63) of GNU make to not export all variables.