summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-27 21:08:20 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-27 21:08:20 +0000
commite53292c439a0797a03e580a9793d873e42bdf6fa (patch)
tree5f34340665a9054b6965278ad4c314a5fd9da8b1 /sci-misc/xfoil/xfoil-6.94-r1.ebuild
parentMoving to sci-misc/xfoil (diff)
downloadgentoo-2-e53292c439a0797a03e580a9793d873e42bdf6fa.tar.gz
gentoo-2-e53292c439a0797a03e580a9793d873e42bdf6fa.tar.bz2
gentoo-2-e53292c439a0797a03e580a9793d873e42bdf6fa.zip
Moved from app-sci/xfoil to sci-misc/xfoil.
Diffstat (limited to 'sci-misc/xfoil/xfoil-6.94-r1.ebuild')
-rw-r--r--sci-misc/xfoil/xfoil-6.94-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sci-misc/xfoil/xfoil-6.94-r1.ebuild b/sci-misc/xfoil/xfoil-6.94-r1.ebuild
new file mode 100644
index 000000000000..9832aa8455fe
--- /dev/null
+++ b/sci-misc/xfoil/xfoil-6.94-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/xfoil/xfoil-6.94-r1.ebuild,v 1.1 2004/12/27 21:08:20 ribosome Exp $
+
+inherit gcc
+
+MY_PN="${PN}"
+MY_PV="${PV/./}"
+MY_P="${MY_PN}${MY_PV}"
+
+DESCRIPTION="design and analysis of subsonic isolated airfoils"
+HOMEPAGE="http://raphael.mit.edu/xfoil/"
+SRC_URI="http://raphael.mit.edu/xfoil/${MY_P}.tar.gz
+ doc? ( http://raphael.mit.edu/xfoil/xfoil_doc.ps
+ http://raphael.mit.edu/xfoil/xfoil_doc.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND="virtual/blas
+ app-sci/blas-config
+ virtual/x11"
+RDEPEND="virtual/x11"
+
+S=${WORKDIR}/XFOIL${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ [ -z "$FC" ] && FC=g77 # because gcc-config doesn't do it yet
+ [ -z "${FFLAGS}" ] && FFLAGS="${CFLAGS}" # because gcc-config doesn't do it yet
+ echo "CC = $(gcc-getCC)" >>plotlib/config.make
+ echo "FC = ${FC}" >>plotlib/config.make
+ echo "CFLAGS += ${CFLAGS}" >>plotlib/config.make
+ echo "FFLAGS += ${FFLAGS}" >>plotlib/config.make
+ sed -i bin/Makefile \
+ -e "s/^\(FC.*\)/FC = ${FC}/g" \
+ -e "s/^\(CC.*\)/CC = $(gcc-getCC)/g" \
+ -e "s/^\(FFLAGS .*\)/FFLAGS = ${FFLAGS}/g" \
+ -e "s/^\(FFLOPT .*\)/FFLOPT = \$(FFLAGS)/g" \
+ -e "s/^\(FFLAGS2 .*\)/FFLAGS2 = \$(FFLAGS)/g"
+}
+
+src_compile() {
+ cd ${S}/plotlib
+ emake || die "failed to build plotlib"
+ cd ${S}/bin
+ for i in xfoil pplot pxplot; do
+ emake ${i} || die "failed to build ${i}"
+ done
+}
+
+src_install() {
+ dobin bin/pplot bin/pxplot bin/xfoil
+ dodoc version_notes.txt xfoil_doc.txt sessions.txt README
+ use doc && dodoc ${DISTDIR}/xfoil_doc.ps ${DISTDIR}/xfoil_doc.pdf
+ docinto runs
+ dodoc runs/*
+}