summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-12-12 18:25:32 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-12-12 18:25:32 +0000
commitbb862947486188358d59b8055867b9c63329a870 (patch)
tree3f250ca5433e03d4d2b3277d7936416b213f5eea /sci-misc/nco
parentversion bump (diff)
downloadgentoo-2-bb862947486188358d59b8055867b9c63329a870.tar.gz
gentoo-2-bb862947486188358d59b8055867b9c63329a870.tar.bz2
gentoo-2-bb862947486188358d59b8055867b9c63329a870.zip
Version bump
(Portage version: 2.2_rc58/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc/nco')
-rw-r--r--sci-misc/nco/ChangeLog10
-rw-r--r--sci-misc/nco/metadata.xml14
-rw-r--r--sci-misc/nco/nco-3.9.9.ebuild72
3 files changed, 87 insertions, 9 deletions
diff --git a/sci-misc/nco/ChangeLog b/sci-misc/nco/ChangeLog
index 9340dbb744ed..4a1a25f94875 100644
--- a/sci-misc/nco/ChangeLog
+++ b/sci-misc/nco/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-misc/nco
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/nco/ChangeLog,v 1.14 2009/03/24 19:16:47 betelgeuse Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/nco/ChangeLog,v 1.15 2009/12/12 18:25:32 bicatali Exp $
+
+*nco-3.9.9 (12 Dec 2009)
+
+ 12 Dec 2009; Sébastien Fabbro <bicatali@gentoo.org> +nco-3.9.9.ebuild,
+ metadata.xml:
+ Version bump
24 Mar 2009; Petteri Räty <betelgeuse@gentoo.org> nco-3.9.4.ebuild:
Slot dep for antlr.
diff --git a/sci-misc/nco/metadata.xml b/sci-misc/nco/metadata.xml
index ac146995f919..5dd3778e42f1 100644
--- a/sci-misc/nco/metadata.xml
+++ b/sci-misc/nco/metadata.xml
@@ -3,13 +3,13 @@
<pkgmetadata>
<herd>sci</herd>
<longdescription lang="en">
-Command-line operators to analyze netCDF files
-NetCDF Operator is a suite of programs known as operators. The
-operators are stand-alone, command-line programs executable in a POSIX
-shell. Operators take one or more netCDF files as input, perform an
-operation (e.g., averaging or hyperslabbing), and produce a netCDF
-output file. NCO was originally designed to manipulate and analyze
-climate data, though it works on any netCDF format datasets.
+ Command-line operators to analyze netCDF files
+ NetCDF Operator is a suite of programs known as operators. The
+ operators are stand-alone, command-line programs executable in a POSIX
+ shell. Operators take one or more netCDF files as input, perform an
+ operation (e.g., averaging or hyperslabbing), and produce a netCDF
+ output file. NCO was originally designed to manipulate and analyze
+ climate data, though it works on any netCDF format datasets.
</longdescription>
<use>
<flag name='ncap2'>Build next generation netcdf arithmetic processor
diff --git a/sci-misc/nco/nco-3.9.9.ebuild b/sci-misc/nco/nco-3.9.9.ebuild
new file mode 100644
index 000000000000..b09c7e9df93b
--- /dev/null
+++ b/sci-misc/nco/nco-3.9.9.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/nco/nco-3.9.9.ebuild,v 1.1 2009/12/12 18:25:32 bicatali Exp $
+
+EAPI=2
+inherit eutils flag-o-matic
+
+DESCRIPTION="Command line utilities for operating on netCDF files"
+SRC_URI="http://dust.ess.uci.edu/nco/src/${P}.tar.gz"
+HOMEPAGE="http://nco.sourceforge.net/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+
+IUSE="doc mpi ncap2 udunits"
+
+RDEPEND="sci-libs/netcdf
+ mpi? ( virtual/mpi )
+ dap? ( sci-libs/netcdf )
+ udunits? ( >=sci-libs/udunits-2 )"
+
+DEPEND="${RDEPEND}
+ ncap2? ( !mpi? ( dev-java/antlr:0 ) )
+ doc? ( virtual/latex-base )"
+
+pkg_setup() {
+ if use mpi && use ncap2; then
+ elog
+ elog "mpi and ncap2 are still incompatible flags"
+ elog "nco configure will automatically disables ncap2"
+ elog
+ fi
+}
+
+src_configure() {
+ local myconf
+ if has_version ">=sci-libs/netcdf-4" && built_with_use sci-libs/netcdf hdf5; then
+ append-cppflags -DHAVE_NETCDF4_H
+ myconf="--enable-netcdf4"
+ else
+ myconf="--disable-netcdf4"
+ fi
+ econf \
+ ${myconf} \
+ --disable-udunits \
+ $(use_enable ncap2) \
+ $(use_enable udunits udunits2) \
+ $(use_enable mpi)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ cd doc
+ emake clean info
+ if use doc; then
+ VARTEXFONTS="${T}/fonts" emake html pdf || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd doc
+ dodoc ANNOUNCE ChangeLog MANIFEST NEWS README TAG TODO VERSION *.txt \
+ || die "dodoc failed"
+ doinfo *.info* || die "doinfo failed"
+ if use doc; then
+ dohtml nco.html/* || die "dohtml failed"
+ insinto /usr/share/doc/${PF}
+ doins nco.pdf || die "pdf install failed"
+ fi
+}