summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-09-26 12:43:55 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-09-26 12:43:55 +0000
commit3e4c3fa14a0cd148a2fbcf32dbc81717e6329d41 (patch)
tree75fcca9ced45f2df830ef6b7a4320bc8ac2c0382 /sci-misc/boinc
parentversion bump (diff)
downloadgentoo-2-3e4c3fa14a0cd148a2fbcf32dbc81717e6329d41.tar.gz
gentoo-2-3e4c3fa14a0cd148a2fbcf32dbc81717e6329d41.tar.bz2
gentoo-2-3e4c3fa14a0cd148a2fbcf32dbc81717e6329d41.zip
Version bump. Per bug #272283. Thanks everyone in the bug for testing/feedback.
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc/boinc')
-rw-r--r--sci-misc/boinc/ChangeLog10
-rw-r--r--sci-misc/boinc/boinc-6.6.40.ebuild145
-rw-r--r--sci-misc/boinc/files/6.6.40-gui01.patch11
-rw-r--r--sci-misc/boinc/files/6.6.40-locale.patch14
-rw-r--r--sci-misc/boinc/metadata.xml7
5 files changed, 185 insertions, 2 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index 346c869a1fc0..307463c2cd08 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.69 2009/09/02 21:22:20 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.70 2009/09/26 12:43:55 scarabeus Exp $
+
+*boinc-6.6.40 (26 Sep 2009)
+
+ 26 Sep 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/6.6.40-gui01.patch, +files/6.6.40-locale.patch,
+ +boinc-6.6.40.ebuild, metadata.xml:
+ Version bump. Per bug #272283. Thanks everyone in the bug for
+ testing/feedback.
02 Sep 2009; Tomáš Chvátal <scarabeus@gentoo.org> files/boinc.init:
Fix attach function. Per bug #266684.
diff --git a/sci-misc/boinc/boinc-6.6.40.ebuild b/sci-misc/boinc/boinc-6.6.40.ebuild
new file mode 100644
index 000000000000..a2a583a68415
--- /dev/null
+++ b/sci-misc/boinc/boinc-6.6.40.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-6.6.40.ebuild,v 1.1 2009/09/26 12:43:55 scarabeus Exp $
+
+EAPI="2"
+
+inherit flag-o-matic depend.apache eutils wxwidgets autotools
+
+DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
+HOMEPAGE="http://boinc.ssl.berkeley.edu/"
+SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X +client cuda server"
+
+RDEPEND="
+ !sci-misc/boinc-bin
+ !app-admin/quickswitch
+ >=app-misc/ca-certificates-20080809
+ dev-libs/openssl
+ net-misc/curl
+ sys-apps/util-linux
+ sys-libs/zlib
+ cuda? (
+ >=dev-util/nvidia-cuda-toolkit-2.1
+ >=x11-drivers/nvidia-drivers-180.22
+ )
+ server? (
+ >=virtual/mysql-5.0
+ dev-python/mysql-python
+ )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ server? ( virtual/imap-c-client )
+ X? (
+ media-libs/freeglut
+ media-libs/jpeg
+ x11-libs/wxGTK:2.8[X,opengl]
+ )
+"
+
+src_prepare() {
+ # use system ssl certificates
+ mkdir "${S}"/curl
+ cp /etc/ssl/certs/ca-certificates.crt "${S}"/curl/ca-bundle.crt
+
+ epatch \
+ "${FILESDIR}"/6.4.5-glibc210.patch \
+ "${FILESDIR}"/${PV}-*
+
+ eautoreconf
+}
+
+src_configure() {
+ local wxconf=""
+ local conf=""
+
+ # define preferable CFLAGS (recommended by upstream)
+ append-flags -O3 -funroll-loops -fforce-addr -ffast-math
+
+ # look for wxGTK
+ if use X; then
+ WX_GTK_VER="2.8"
+ need-wxwidgets unicode
+ wxconf+=" --with-wx-config=${WX_CONFIG}"
+ else
+ wxconf+=" --without-wxdir"
+ fi
+
+ # Bug #248769: don't use strlcat and friends from kerberos or similar
+ #local func
+ #for func in strlcat strlcpy; do
+ # eval "export ac_cv_func_${func}=no"
+ # append-cppflags -D${func}=boinc_${func}
+ #done
+ use server || conf+=" --disable-server"
+ use X || conf+=" --disable-manager"
+ use client || conf+=" --disable-client"
+
+ # configure
+ econf \
+ --disable-dependency-tracking \
+ --enable-unicode \
+ --with-ssl \
+ $(use_with X x) \
+ ${wxconf} \
+ ${conf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodir /var/lib/${PN}/
+ keepdir /var/lib/${PN}/
+
+ if use X; then
+ newicon "${S}"/packages/generic/sea/${PN}mgr.48x48.png ${PN}.png || die
+ make_desktop_entry boincmgr "${PN}" "${PN}" "Math;Science" /var/lib/${PN}
+ fi
+
+ # cleanup cruft
+ rm -rf "${D}"/etc/
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf ${PN}
+}
+
+pkg_setup() {
+ enewgroup ${PN}
+ # note this works only for first install so we have to
+ # elog user about the need of being in video group
+ if use cuda; then
+ enewuser ${PN} -1 -1 /var/lib/${PN} "${PN},video"
+ else
+ enewuser ${PN} -1 -1 /var/lib/${PN} "${PN}"
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "You are using the source compiled version."
+ elog "The manager can be found at /usr/bin/${PN}_gui"
+ elog
+ elog "You need to attach to a project to do anything useful with ${PN}."
+ elog "You can do this by running /etc/init.d/${PN} attach"
+ elog "The howto for configuration is located at:"
+ elog "http://boinc.berkeley.edu/wiki/Anonymous_platform"
+ elog
+ # Add warning about the new password for the client, bug 121896.
+ elog "If you need to use the graphical client the password is in:"
+ elog "/var/lib/${PN}/gui_rpc_auth.cfg"
+ elog "Where /var/lib/ is default RUNTIMEDIR, that can be changed in:"
+ elog "/etc/conf.d/${PN}"
+ elog "You should change this to something more memorable (can be even blank)."
+ elog
+ elog "Remember to launch init script before using manager. Or changing the password."
+ if use cuda; then
+ elog "To be able to use CUDA you should add boinc user to video group."
+ elog "To do so run as root:"
+ elog "gpasswd -a boinc video"
+ fi
+}
diff --git a/sci-misc/boinc/files/6.6.40-gui01.patch b/sci-misc/boinc/files/6.6.40-gui01.patch
new file mode 100644
index 000000000000..1396851e9960
--- /dev/null
+++ b/sci-misc/boinc/files/6.6.40-gui01.patch
@@ -0,0 +1,11 @@
+--- ../boinc-6.6.40/clientgui/BOINCGUIApp.h 2009-09-21 21:41:28.000000000 +0200
++++ clientgui/BOINCGUIApp.h 2009-09-24 01:28:44.510420617 +0200
+@@ -88,6 +88,8 @@
+ wxString m_strBOINCMGRDataDirectory;
+ wxString m_strBOINCArguments;
+
++ bool m_bAccessibilityEnabled;
++
+ bool m_bBOINCMGRAutoStarted;
+ int m_iBOINCMGRDisableAutoStart;
+ int m_iShutdownCoreClient;
diff --git a/sci-misc/boinc/files/6.6.40-locale.patch b/sci-misc/boinc/files/6.6.40-locale.patch
new file mode 100644
index 000000000000..f7fa7970162d
--- /dev/null
+++ b/sci-misc/boinc/files/6.6.40-locale.patch
@@ -0,0 +1,14 @@
+diff -urN boinc-6.6.40.old/locale/Makefile.am boinc-6.6.40/locale/Makefile.am
+--- boinc-6.6.40.old/locale/Makefile.am 2009-01-01 02:07:26.000000000 +0100
++++ boinc-6.6.40/locale/Makefile.am 2009-09-26 14:30:36.000000000 +0200
+@@ -46,8 +46,8 @@
+ mydir=$(DESTDIR)$(datadir) ;\
+ for ldir in $(locale_dirs) ; do \
+ $(INSTALL) -d $$mydir/$$ldir ; \
+- if [ -f $$ldir/BOINC-Manager.po ] ; then \
+- $(INSTALL) $$ldir/BOINC-Manager.po $$mydir/$$ldir/BOINC-Manager.po ; \
++ if [ -f $$ldir/BOINC-Manager.mo ] ; then \
++ $(INSTALL) $$ldir/BOINC-Manager.mo $$mydir/$$ldir/BOINC-Manager.mo ; \
+ fi ;\
+ done
+
diff --git a/sci-misc/boinc/metadata.xml b/sci-misc/boinc/metadata.xml
index 1fc5c3ddbe65..8f966ffa3944 100644
--- a/sci-misc/boinc/metadata.xml
+++ b/sci-misc/boinc/metadata.xml
@@ -10,11 +10,16 @@
platform for distributed computing using volunteered computer resources.
</longdescription>
<use>
- <flag name='server'>Enable compilation of server</flag>
+ <flag name="server">Enable compilation of server</flag>
<flag name="cuda">
Use nvidia cuda toolkit for speeding up computations.
NOTE: works only for subset of nvidia graphic cards so make sure your card
is supported before opening bug about it.
</flag>
+ <flag name="client">
+ Build client part of the boinc. Not only the manager but also the computation
+ unit. With +X only you will have only manager which can connect to remote
+ clients.
+ </flag>
</use>
</pkgmetadata>