summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-03 08:58:55 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-03 08:58:55 +0000
commitf45fe03bfb9bb18e5af411479c65e067bc26b880 (patch)
treef21daa19ccc59a538aebbeb91f1ddb03d09ef547 /sci-mathematics
parentVersion bump. (diff)
downloadgentoo-2-f45fe03bfb9bb18e5af411479c65e067bc26b880.tar.gz
gentoo-2-f45fe03bfb9bb18e5af411479c65e067bc26b880.tar.bz2
gentoo-2-f45fe03bfb9bb18e5af411479c65e067bc26b880.zip
Make it gold resistant, #369455
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/otter/ChangeLog8
-rw-r--r--sci-mathematics/otter/files/otter-3.3-gold.patch16
-rw-r--r--sci-mathematics/otter/otter-3.3-r1.ebuild15
-rw-r--r--sci-mathematics/otter/otter-3.3-r2.ebuild38
4 files changed, 53 insertions, 24 deletions
diff --git a/sci-mathematics/otter/ChangeLog b/sci-mathematics/otter/ChangeLog
index f5b97429901b..a606a0d36e7b 100644
--- a/sci-mathematics/otter/ChangeLog
+++ b/sci-mathematics/otter/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/otter
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/otter/ChangeLog,v 1.13 2010/01/13 02:29:46 markusle Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/otter/ChangeLog,v 1.14 2011/06/03 08:58:54 jlec Exp $
+
+ 03 Jun 2011; Justin Lecher <jlec@gentoo.org> otter-3.3-r1.ebuild,
+ otter-3.3-r2.ebuild, +files/otter-3.3-gold.patch:
+ Make it gold resistant, #369455
*otter-3.3-r2 (13 Jan 2010)
diff --git a/sci-mathematics/otter/files/otter-3.3-gold.patch b/sci-mathematics/otter/files/otter-3.3-gold.patch
new file mode 100644
index 000000000000..a3765b47a958
--- /dev/null
+++ b/sci-mathematics/otter/files/otter-3.3-gold.patch
@@ -0,0 +1,16 @@
+ source/formed/Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/source/formed/Makefile b/source/formed/Makefile
+index 39eaae5..7526c03 100644
+--- a/source/formed/Makefile
++++ b/source/formed/Makefile
+@@ -37,7 +37,7 @@ CFLAGS += $(DFLAGS)
+ #
+ # The following works on a RedHat 7.3 computer
+
+-XLIBS = -L/usr/X11R6/lib -lXaw
++XLIBS = -L/usr/X11R6/lib -lXaw -lXm -lXt -lX11
+
+ formed: formed.o display.o callback.o
+ $(CC) $(CFLAGS) $(LDFLAGS) formed.o display.o callback.o \
diff --git a/sci-mathematics/otter/otter-3.3-r1.ebuild b/sci-mathematics/otter/otter-3.3-r1.ebuild
index f000c1781d03..0058365dfeac 100644
--- a/sci-mathematics/otter/otter-3.3-r1.ebuild
+++ b/sci-mathematics/otter/otter-3.3-r1.ebuild
@@ -1,16 +1,21 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/otter/otter-3.3-r1.ebuild,v 1.7 2010/01/02 18:20:20 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/otter/otter-3.3-r1.ebuild,v 1.8 2011/06/03 08:58:55 jlec Exp $
DESCRIPTION="An Automated Deduction System."
-SRC_URI="http://www-unix.mcs.anl.gov/AR/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www-unix.mcs.anl.gov/AR/otter/"
+HOMEPAGE="http://www.cs.unm.edu/~mccune/otter/"
+SRC_URI="http://www.cs.unm.edu/~mccune/otter/${P}.tar.gz"
KEYWORDS="~amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
LICENSE="otter"
SLOT="0"
IUSE=""
-DEPEND="virtual/libc"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXt"
+DEPEND="${RDEPEND}"
src_compile() {
cd source
diff --git a/sci-mathematics/otter/otter-3.3-r2.ebuild b/sci-mathematics/otter/otter-3.3-r2.ebuild
index bc683123880c..9ac06bcb31b0 100644
--- a/sci-mathematics/otter/otter-3.3-r2.ebuild
+++ b/sci-mathematics/otter/otter-3.3-r2.ebuild
@@ -1,40 +1,44 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/otter/otter-3.3-r2.ebuild,v 1.1 2010/01/13 02:29:46 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/otter/otter-3.3-r2.ebuild,v 1.2 2011/06/03 08:58:54 jlec Exp $
+
+EAPI=4
-EAPI="2"
inherit eutils
DESCRIPTION="An Automated Deduction System."
-SRC_URI="http://www-unix.mcs.anl.gov/AR/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www-unix.mcs.anl.gov/AR/otter/"
+HOMEPAGE="http://www.cs.unm.edu/~mccune/otter/"
+SRC_URI="http://www.cs.unm.edu/~mccune/otter/${P}.tar.gz"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
LICENSE="otter"
SLOT="0"
IUSE=""
-DEPEND="virtual/libc"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXt"
+DEPEND="${RDEPEND}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-gold.patch
}
src_compile() {
cd source
- CC=$(tc-getCC) emake || die "emake failed"
+ CC=$(tc-getCC) emake
cd "${S}"/mace2
- CC=$(tc-getCC) emake || die "emake in mace2 failed"
+ CC=$(tc-getCC) emake
}
src_install() {
- dobin bin/* source/formed/formed \
- || die "failed to install binaries"
- dodoc README* Legal Changelog Contents \
- || die "failed to install regular docs"
+ dobin bin/* source/formed/formed
+ dodoc README* Legal Changelog Contents
insinto /usr/share/doc/${PF}
- doins documents/*.pdf \
- || die "failed to install pdf docs"
+ doins documents/*.pdf
insinto /usr/share/${PN}/
- doins -r examples examples-mace2 \
- || die "failed to install examples"
+ doins -r examples examples-mace2
}