summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda XU <heroxbd@gentoo.org>2012-09-26 17:16:53 +0000
committerBenda XU <heroxbd@gentoo.org>2012-09-26 17:16:53 +0000
commitef8ca6c6e6ee0dba855aa92e9774ef01d97d4782 (patch)
tree11d7a4ebe29cf244b3caf2a532f8fef00a8ce6e0 /sci-mathematics
parentRemove old. (diff)
downloadgentoo-2-ef8ca6c6e6ee0dba855aa92e9774ef01d97d4782.tar.gz
gentoo-2-ef8ca6c6e6ee0dba855aa92e9774ef01d97d4782.tar.bz2
gentoo-2-ef8ca6c6e6ee0dba855aa92e9774ef01d97d4782.zip
new ebuild
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pymc/ChangeLog11
-rw-r--r--sci-mathematics/pymc/Manifest4
-rw-r--r--sci-mathematics/pymc/metadata.xml12
-rw-r--r--sci-mathematics/pymc/pymc-2.2.ebuild24
-rw-r--r--sci-mathematics/pymc/pymc-9999.ebuild24
5 files changed, 75 insertions, 0 deletions
diff --git a/sci-mathematics/pymc/ChangeLog b/sci-mathematics/pymc/ChangeLog
new file mode 100644
index 000000000000..b7c1f9b27807
--- /dev/null
+++ b/sci-mathematics/pymc/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-mathematics/pymc
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pymc/ChangeLog,v 1.1 2012/09/26 17:16:53 heroxbd Exp $
+
+*pymc-2.2 (27 Sep 2012)
+*pymc-9999 (27 Sep 2012)
+
+ 27 Sep 2012; Benda Xu <heroxbd@gentoo.org> +metadata.xml, +pymc-2.2.ebuild,
+ +pymc-9999.ebuild:
+ new ebuild
+
diff --git a/sci-mathematics/pymc/Manifest b/sci-mathematics/pymc/Manifest
new file mode 100644
index 000000000000..7cc360ceb12b
--- /dev/null
+++ b/sci-mathematics/pymc/Manifest
@@ -0,0 +1,4 @@
+DIST pymc-2.2.tar.gz 351767 RMD160 16dc4988a445bb7a2b2477c0846d979e8822854d SHA1 1deda0f15e097cae492a73f3260d57e2fd499311 SHA256 a2b5ff9c4a17dbdf93fafc3822d077956fcfa638cce6e594466f0d8523982ec1
+EBUILD pymc-2.2.ebuild 568 RMD160 7a6a68f96f7316a5e82d8d8cf832551babd6a96e SHA1 2c84e36776ceeddaaf3b6ca58a8f82de0362fa26 SHA256 06547bd48fb1c582ffd0b45c6955996db72ba247c8a1e0875262823d3b764125
+EBUILD pymc-9999.ebuild 515 RMD160 d974236a720ac49537377d530fe093a29b148848 SHA1 02bd48317b27a4873a23704686fcccd157b2010b SHA256 a8b23921b6e40d90facc4d7c35f12508095bd138e3c181af67ff52b3ac74fffd
+MISC metadata.xml 409 RMD160 c33297a6a5299af13628768804b240b6358824cf SHA1 020b2edb067fe0ee5a91e78fe8135de1aae82c26 SHA256 f3717579cda034f9ff6741dc2274da937c5a3bd20f9b29678a1e98c03e77d71d
diff --git a/sci-mathematics/pymc/metadata.xml b/sci-mathematics/pymc/metadata.xml
new file mode 100644
index 000000000000..dfb8ad2183b2
--- /dev/null
+++ b/sci-mathematics/pymc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>heroxbd@gentoo.org</email>
+ <name>Benda Xu</name>
+ </maintainer>
+<longdescription lang="en">
+PyMC is a python module that implements Bayesian statistical models
+and fitting algorithms, including Markov chain Monte Carlo.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/pymc/pymc-2.2.ebuild b/sci-mathematics/pymc/pymc-2.2.ebuild
new file mode 100644
index 000000000000..e06e14cda067
--- /dev/null
+++ b/sci-mathematics/pymc/pymc-2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pymc/pymc-2.2.ebuild,v 1.1 2012/09/26 17:16:53 heroxbd Exp $
+
+EAPI=4
+
+inherit distutils vcs-snapshot
+
+DESCRIPTION="Markov Chain Monte Carlo sampling toolkit."
+HOMEPAGE="http://github.com/${PN}-devs/${PN} http://pypi.python.org/pypi/${PN}"
+SRC_URI="http://github.com/example/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+SLOT=0
+KEYWORDS="~amd64-linux ~x86-linux"
+LICENSE=AFL-3.0
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ dev-python/pytables
+ dev-python/numpy"
+
+src_compile() {
+ distutils_src_compile --fcompiler=gnu95
+}
diff --git a/sci-mathematics/pymc/pymc-9999.ebuild b/sci-mathematics/pymc/pymc-9999.ebuild
new file mode 100644
index 000000000000..4e1b9cc28402
--- /dev/null
+++ b/sci-mathematics/pymc/pymc-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pymc/pymc-9999.ebuild,v 1.1 2012/09/26 17:16:53 heroxbd Exp $
+
+EAPI=4
+
+inherit distutils git-2
+
+EGIT_REPO_URI="http://github.com/${PN}-devs/${PN}.git"
+DESCRIPTION="Markov chain Monte Carlo for Python."
+HOMEPAGE="http://github.com/${PN}-devs/${PN} http://pypi.python.org/pypi/${PN}"
+
+SLOT=0
+KEYWORDS=""
+LICENSE=AFL-3.0
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ dev-python/pytables
+ dev-python/numpy"
+
+src_compile() {
+ distutils_src_compile --fcompiler=gnu95
+}