summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-21 14:12:55 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-21 14:12:55 +0000
commitec5f4e3258fd84d923d20e06cc4daea81d41ca72 (patch)
tree85be08f82ac43f9faa3f6b9dd2e4938eb3ed4a01 /sci-mathematics
parentSecurity bump (bug #458390) (diff)
downloadgentoo-2-ec5f4e3258fd84d923d20e06cc4daea81d41ca72.tar.gz
gentoo-2-ec5f4e3258fd84d923d20e06cc4daea81d41ca72.tar.bz2
gentoo-2-ec5f4e3258fd84d923d20e06cc4daea81d41ca72.zip
sci-mathematics/gsl-shell: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gsl-shell/ChangeLog6
-rw-r--r--sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild13
-rw-r--r--sci-mathematics/gsl-shell/metadata.xml16
3 files changed, 21 insertions, 14 deletions
diff --git a/sci-mathematics/gsl-shell/ChangeLog b/sci-mathematics/gsl-shell/ChangeLog
index d52e8b02242d..33ea3f2de715 100644
--- a/sci-mathematics/gsl-shell/ChangeLog
+++ b/sci-mathematics/gsl-shell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/gsl-shell
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/ChangeLog,v 1.7 2013/02/01 12:09:55 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/ChangeLog,v 1.8 2013/02/21 14:12:55 jlec Exp $
+
+ 21 Feb 2013; Justin Lecher <jlec@gentoo.org> gsl-shell-2.2.0.ebuild,
+ metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
01 Feb 2013; Agostino Sarubbo <ago@gentoo.org> gsl-shell-2.2.0.ebuild:
move media-fonts/freefont-ttf into media-fonts/freefont
diff --git a/sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild b/sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild
index c114d18a1093..632f6b3f12e5 100644
--- a/sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild
+++ b/sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild
@@ -1,19 +1,22 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild,v 1.2 2013/02/01 12:09:55 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild,v 1.3 2013/02/21 14:12:55 jlec Exp $
EAPI=4
-inherit eutils
+
+inherit eutils toolchain-funcs
DESCRIPTION="Lua interactive shell for sci-libs/gsl"
HOMEPAGE="http://www.nongnu.org/gsl-shell/"
SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
-LICENSE="GPL-3"
+
SLOT="0"
+LICENSE="GPL-3"
KEYWORDS="~amd64 ~x86"
IUSE="doc fox"
-DEPEND=">=sci-libs/gsl-1.14
+DEPEND="
+ >=sci-libs/gsl-1.14
virtual/blas
>=x11-libs/agg-2.5
>=media-libs/freetype-2.4.10
@@ -31,7 +34,7 @@ src_prepare() {
}
src_compile() {
- local BLAS=`pkg-config --libs blas`
+ local BLAS=$($(tc-getPKG_CONFIG) --libs blas)
if use fox; then
local FOX_INCLUDES=`WANT_FOX=1.6 fox-config --cflags`
diff --git a/sci-mathematics/gsl-shell/metadata.xml b/sci-mathematics/gsl-shell/metadata.xml
index 0c1147a33683..d56d122c63c6 100644
--- a/sci-mathematics/gsl-shell/metadata.xml
+++ b/sci-mathematics/gsl-shell/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>grozin@gentoo.org</email>
- <name>Andrey Grozin</name>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
</maintainer>
-<herd>sci-mathematics</herd>
-<longdescription lang="en">
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
GSL shell offers an interactive command-line interface
that gives access to GSL collection of mathematical functions.
GSL shell is based on the powerful and elegant scripting language Lua.
@@ -15,7 +15,7 @@ but does offer much more simple and expressive way to use GSL.
The objective of GSL shell is to give the user the power
of easily access GSL functions without having to write a complete C application.
</longdescription>
-<use>
- <flag name='fox'>Build a <pkg>x11-libs/fox</pkg> GUI</flag>
-</use>
+ <use>
+ <flag name="fox">Build a <pkg>x11-libs/fox</pkg> GUI</flag>
+ </use>
</pkgmetadata>