summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-08-08 10:57:06 +0000
committerMichael Weber <xmw@gentoo.org>2015-08-08 10:57:06 +0000
commita9807be961b6608d830a60d85983ecdef3f93e26 (patch)
tree0d6b6131051f4931b4d20d3304d79fbfabdc0044 /sci-mathematics
parentfix typo (diff)
downloadgentoo-2-a9807be961b6608d830a60d85983ecdef3f93e26.tar.gz
gentoo-2-a9807be961b6608d830a60d85983ecdef3f93e26.tar.bz2
gentoo-2-a9807be961b6608d830a60d85983ecdef3f93e26.zip
Version bump (thanks Helmut Jarausch, bug 555732).
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cgal/ChangeLog7
-rw-r--r--sci-mathematics/cgal/cgal-4.6.1.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/sci-mathematics/cgal/ChangeLog b/sci-mathematics/cgal/ChangeLog
index cfc2b5d793c0..5c18313a446a 100644
--- a/sci-mathematics/cgal/ChangeLog
+++ b/sci-mathematics/cgal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/cgal
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/ChangeLog,v 1.27 2015/08/08 10:42:39 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/ChangeLog,v 1.28 2015/08/08 10:57:06 xmw Exp $
+
+*cgal-4.6.1 (08 Aug 2015)
+
+ 08 Aug 2015; Michael Weber <xmw@gentoo.org> +cgal-4.6.1.ebuild:
+ Version bump (thanks Helmut Jarausch, bug 555732).
*cgal-4.3-r1 (08 Aug 2015)
diff --git a/sci-mathematics/cgal/cgal-4.6.1.ebuild b/sci-mathematics/cgal/cgal-4.6.1.ebuild
new file mode 100644
index 000000000000..eb9ca6f1d367
--- /dev/null
+++ b/sci-mathematics/cgal/cgal-4.6.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cgal/cgal-4.6.1.ebuild,v 1.1 2015/08/08 10:57:06 xmw Exp $
+
+EAPI=5
+
+CMAKE_BUILD_TYPE=Release
+
+inherit multilib cmake-utils
+
+MY_P=CGAL-${PV}
+PID=34900
+DPID=34902
+
+DESCRIPTION="C++ library for geometric algorithms and data structures"
+HOMEPAGE="http://www.cgal.org/ https://gforge.inria.fr/projects/cgal/"
+SRC_URI="
+ http://gforge.inria.fr/frs/download.php/${PID}/${MY_P}.tar.xz
+ doc? ( http://gforge.inria.fr/frs/download.php/${DPID}/${MY_P}-doc_html.tar.xz )"
+
+LICENSE="LGPL-3 GPL-3 Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples +gmp mpfi qt4"
+
+RDEPEND="
+ dev-libs/boost
+ dev-libs/mpfr:0
+ sys-libs/zlib
+ x11-libs/libX11
+ virtual/glu
+ virtual/opengl
+ gmp? ( dev-libs/gmp[cxx] )
+ qt4? (
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ )
+ mpfi? ( sci-libs/mpfi )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS CHANGES* README"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ sed \
+ -e '/install(FILES AUTHORS/d' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCGAL_INSTALL_LIB_DIR=$(get_libdir)
+ -DWITH_CGAL_Qt3=OFF
+ -DWITH_LEDA=OFF
+ $(cmake-utils_use_with gmp)
+ $(cmake-utils_use_with gmp GMPXX)
+ $(cmake-utils_use_with qt4 CGAL_Qt4)
+ $(cmake-utils_use_with mpfi)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${WORKDIR}"/doc_html/. )
+ cmake-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples demo
+ fi
+}