summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-07-02 15:25:38 +0000
committerMark Wright <gienah@gentoo.org>2014-07-02 15:25:38 +0000
commita65eba3ed11ac5e8b9c3263426c96b976a64b1e8 (patch)
tree73a570be8c19f69f959c0bb80012a830d89d5af5 /sci-mathematics
parentBump agda-stdlib to 0.8 (diff)
downloadgentoo-2-a65eba3ed11ac5e8b9c3263426c96b976a64b1e8.tar.gz
gentoo-2-a65eba3ed11ac5e8b9c3263426c96b976a64b1e8.tar.bz2
gentoo-2-a65eba3ed11ac5e8b9c3263426c96b976a64b1e8.zip
Bump agda to 2.4.0.1
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/agda/ChangeLog7
-rw-r--r--sci-mathematics/agda/agda-2.4.0.1.ebuild124
2 files changed, 130 insertions, 1 deletions
diff --git a/sci-mathematics/agda/ChangeLog b/sci-mathematics/agda/ChangeLog
index 6fd841ef0907..369a719d8727 100644
--- a/sci-mathematics/agda/ChangeLog
+++ b/sci-mathematics/agda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/agda
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.26 2014/02/25 15:40:58 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.27 2014/07/02 15:25:38 gienah Exp $
+
+*agda-2.4.0.1 (02 Jul 2014)
+
+ 02 Jul 2014; Mark Wright <gienah@gentoo.org> +agda-2.4.0.1.ebuild:
+ Bump agda to 2.4.0.1
25 Feb 2014; Sergei Trofimovich <slyfox@gentoo.org> -agda-1.0.2-r2.ebuild,
-agda-2.2.6-r1.ebuild, -files/50agda-gentoo.el,
diff --git a/sci-mathematics/agda/agda-2.4.0.1.ebuild b/sci-mathematics/agda/agda-2.4.0.1.ebuild
new file mode 100644
index 000000000000..8d42084b446f
--- /dev/null
+++ b/sci-mathematics/agda/agda-2.4.0.1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.4.0.1.ebuild,v 1.1 2014/07/02 15:25:38 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal elisp-common
+
+MY_PN="Agda"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A dependently typed functional programming language and proof assistant"
+HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="epic +stdlib"
+
+RDEPEND=">=dev-haskell/binary-0.6:=[profile?] <dev-haskell/binary-0.8:=[profile?]
+ >=dev-haskell/boxes-0.1.3:=[profile?] <dev-haskell/boxes-0.2:=[profile?]
+ ~dev-haskell/data-hash-0.2.0.0:=[profile?]
+ >=dev-haskell/equivalence-0.2.3:=[profile?] <dev-haskell/equivalence-0.3:=[profile?]
+ >=dev-haskell/geniplate-0.6.0.3:=[profile?] <dev-haskell/geniplate-0.7:=[profile?]
+ >=dev-haskell/hashtables-1.0:=[profile?] <dev-haskell/hashtables-1.2:=[profile?]
+ >=dev-haskell/haskeline-0.7:=[profile?] <dev-haskell/haskeline-0.8:=[profile?]
+ >=dev-haskell/haskell-src-exts-1.9.6:=[profile?] <dev-haskell/haskell-src-exts-1.16:=[profile?]
+ >=dev-haskell/mtl-2.1.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ <dev-haskell/parallel-3.3:=[profile?]
+ >=dev-haskell/quickcheck-2.7.5:2=[profile?] <dev-haskell/quickcheck-2.8:2=[profile?]
+ >=dev-haskell/stmonadtrans-0.3.2:=[profile?] <dev-haskell/stmonadtrans-0.4:=[profile?]
+ >=dev-haskell/strict-0.3.2:=[profile?] <dev-haskell/strict-0.4:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.2:=[profile?]
+ >=dev-haskell/transformers-0.3:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/xhtml-3000.2:=[profile?] <dev-haskell/xhtml-3000.3:=[profile?]
+ >=dev-haskell/zlib-0.4.0.1:=[profile?] <dev-haskell/zlib-0.6:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ || ( ( >=dev-haskell/hashable-1.1.2.3:=[profile?] <dev-haskell/hashable-1.2:=[profile?] )
+ ( >=dev-haskell/hashable-1.2.1.0:=[profile?] <dev-haskell/hashable-1.3:=[profile?] ) )
+ epic? ( >=dev-lang/epic-0.1.13:=[profile?] <dev-lang/epic-0.10:=[profile?] )
+"
+RDEPEND+="
+ app-emacs/haskell-mode
+ virtual/emacs
+"
+PDEPEND="stdlib? ( sci-mathematics/agda-stdlib )"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.8
+ dev-haskell/happy
+"
+
+SITEFILE="50${PN}2-gentoo.el"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cabal_chdeps \
+ 'mtl >= 2.1.1 && < 2.2' 'mtl >= 2.1.1 && < 2.3' \
+ 'transformers == 0.3.*' 'transformers >= 0.3 && < 0.5'
+
+ sed -e '/.*emacs-mode.*$/d' \
+ -i "${S}/${MY_PN}.cabal" \
+ || die "Could not remove agda-mode from ${MY_PN}.cabal"
+
+ if use epic && use stdlib; then
+ ewarn "Note that the agda-stdlib README:"
+ ewarn "http://www.cse.chalmers.se/~nad/listings/lib/README.html"
+ ewarn 'says: "Currently the library does not support the Epic or JavaScript compiler'
+ ewarn 'backends." Hence you may wish to remove the epic use flag if you wish to use'
+ ewarn "the Agda standard library."
+ fi
+ sed -e 's@-Werror@@g' \
+ -i "${S}/${MY_PN}.cabal" \
+ || die "sed to remove -Werror failed"
+ sed -e '/, "-Werror"/d' \
+ -i "${S}/src/full/Agda/Compiler/MAlonzo/Compiler.hs" \
+ || die "sed to remove -Werror from Compiler.hs failed"
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag epic epic)
+}
+
+src_compile() {
+ BYTECOMPFLAGS="-L ./src/data/emacs-mode"
+ elisp-compile src/data/emacs-mode/*.el \
+ || die "Failed to compile emacs mode"
+ haskell-cabal_src_compile
+}
+
+src_install() {
+ local add="${ED}"/usr/share/"${P}/ghc-$(ghc-version)"
+
+ haskell-cabal_src_install
+
+ # generate Primitive.agdai, emulate Setup.hs postinst phase
+ Agda_datadir="${add}" \
+ "${ED}"/usr/bin/agda "${add}"/lib/prim/Agda/Primitive.agda
+
+ rm "${ED}"/usr/bin/agda-mode || die
+ # lives in sci-mathematics/agda-executable
+ rm "${ED}"/usr/bin/agda || die
+
+ elisp-install ${PN} src/data/emacs-mode/*.el \
+ || die "Failed to install emacs mode"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "Failed to install elisp site file"
+}
+
+pkg_postinst() {
+ ghc-package_pkg_postinst
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ ghc-package_pkg_prerm
+ elisp-site-regen
+}