summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-05-04 19:50:48 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-05-04 19:50:48 +0000
commit9e8b3d3719d9f94146b8886c68977059257e4a16 (patch)
treef51b006270a500644f9968fd4934af97e44cddb6 /sci-mathematics
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-9e8b3d3719d9f94146b8886c68977059257e4a16.tar.gz
gentoo-2-9e8b3d3719d9f94146b8886c68977059257e4a16.tar.bz2
gentoo-2-9e8b3d3719d9f94146b8886c68977059257e4a16.zip
Version bump. Now supports OpenMP and R
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gretl/ChangeLog10
-rw-r--r--sci-mathematics/gretl/gretl-1.9.0.ebuild (renamed from sci-mathematics/gretl/gretl-1.8.5.ebuild)26
-rw-r--r--sci-mathematics/gretl/metadata.xml1
3 files changed, 31 insertions, 6 deletions
diff --git a/sci-mathematics/gretl/ChangeLog b/sci-mathematics/gretl/ChangeLog
index 6b529b3dff28..5431a8cbbf7a 100644
--- a/sci-mathematics/gretl/ChangeLog
+++ b/sci-mathematics/gretl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/gretl
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.22 2009/12/14 22:33:36 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.23 2010/05/04 19:50:48 bicatali Exp $
+
+*gretl-1.9.0 (04 May 2010)
+
+ 04 May 2010; Sébastien Fabbro <bicatali@gentoo.org> -gretl-1.8.5.ebuild,
+ +gretl-1.9.0.ebuild, metadata.xml:
+ Version bump. Now supports OpenMP and R
*gretl-1.8.6 (14 Dec 2009)
diff --git a/sci-mathematics/gretl/gretl-1.8.5.ebuild b/sci-mathematics/gretl/gretl-1.9.0.ebuild
index dc9f6f42ed2a..0bc876d42a1f 100644
--- a/sci-mathematics/gretl/gretl-1.8.5.ebuild
+++ b/sci-mathematics/gretl/gretl-1.9.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.8.5.ebuild,v 1.1 2009/11/21 08:30:53 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.9.0.ebuild,v 1.1 2010/05/04 19:50:48 bicatali Exp $
USE_EINSTALL=true
EAPI=2
@@ -14,11 +14,11 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="accessibility emacs gmp gnome gtk nls odbc readline sourceview"
+IUSE="accessibility emacs gmp gnome gtk nls odbc openmp readline R sourceview"
RDEPEND="dev-libs/libxml2
dev-libs/glib:2
- sci-visualization/gnuplot
+ >=sci-visualization/gnuplot-4.2
virtual/lapack
virtual/latex-base
sci-libs/fftw:3.0
@@ -35,6 +35,7 @@ RDEPEND="dev-libs/libxml2
gnome-base/libgnomeprint:2.2
gnome-base/libgnomeprintui:2.2
gnome-base/gconf:2 )
+ R? ( dev-lang/R )
sourceview? ( x11-libs/gtksourceview )
odbc? ( dev-db/unixODBC )
emacs? ( virtual/emacs )"
@@ -44,8 +45,23 @@ DEPEND="${RDEPEND}
SITEFILE=50${PN}-gentoo.el
+pkg_setup() {
+ if use openmp &&
+ [[ $(tc-getCC)$ == *gcc* ]] &&
+ ( [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] ||
+ ! has_version sys-devel/gcc[openmp] )
+ then
+ ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.7.5-locale.patch
+ # fix parallel make
+ sed -i \
+ -e 's/make/$(MAKE)/g' \
+ $(find . -name Makefile.in) || die
}
src_configure() {
@@ -61,10 +77,12 @@ src_configure() {
econf \
--with-mpfr \
$(use_enable nls) \
+ $(use_enable openmp) \
$(use_with readline) \
$(use_with gmp) \
$(use_with odbc) \
$(use_with accessibility audio) \
+ $(use_with R libR) \
${myconf} \
LAPACK_LIBS="$(pkg-config --libs lapack)"
}
diff --git a/sci-mathematics/gretl/metadata.xml b/sci-mathematics/gretl/metadata.xml
index 1b1635d68c7f..3fbb332b2d8a 100644
--- a/sci-mathematics/gretl/metadata.xml
+++ b/sci-mathematics/gretl/metadata.xml
@@ -17,5 +17,6 @@
<use>
<flag name='sourceview'>Enable support for <pkg>x11-libs/gtksourceview</pkg>
</flag>
+ <flag name='R'>Enable support for <pkg>dev-lang/R</pkg></flag>
</use>
</pkgmetadata>