summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-08-27 13:11:43 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-08-27 13:11:43 +0000
commit98917fcff5bf1952f18ffa6814e7071766045d3a (patch)
treec075f1f6c89bd879bc53512e94a8d9dc72fa6fdf /sci-mathematics
parentUsing mirror:// for berlios, adding a few missing quotes and removing sed fro... (diff)
downloadgentoo-2-98917fcff5bf1952f18ffa6814e7071766045d3a.tar.gz
gentoo-2-98917fcff5bf1952f18ffa6814e7071766045d3a.tar.bz2
gentoo-2-98917fcff5bf1952f18ffa6814e7071766045d3a.zip
version bump
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/ChangeLog7
-rw-r--r--sci-mathematics/coq/coq-8.2_p1.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index fdaaa8fd68ef..1184513dcdca 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/coq
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.41 2009/05/18 06:38:23 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.42 2009/08/27 13:11:43 aballier Exp $
+
+*coq-8.2_p1 (27 Aug 2009)
+
+ 27 Aug 2009; Alexis Ballier <aballier@gentoo.org> +coq-8.2_p1.ebuild:
+ version bump
18 May 2009; Alexis Ballier <aballier@gentoo.org> -coq-8.1_p3.ebuild,
-coq-8.1_p3-r1.ebuild, metadata.xml:
diff --git a/sci-mathematics/coq/coq-8.2_p1.ebuild b/sci-mathematics/coq/coq-8.2_p1.ebuild
new file mode 100644
index 000000000000..92ef4f5aea29
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.2_p1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.2_p1.ebuild,v 1.1 2009/08/27 13:11:43 aballier Exp $
+
+EAPI="2"
+
+inherit eutils multilib
+
+MY_PV="${PV/_p/pl}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Coq is a proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="http://coq.inria.fr/distrib/V${MY_PV}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="norealanalysis gtk debug +ocamlopt doc"
+
+RDEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]
+ >=dev-ml/camlp5-5.09[ocamlopt?]
+ gtk? ( >=dev-ml/lablgtk-2.10.1[ocamlopt?] )"
+DEPEND="${RDPEND}
+ doc? ( dev-tex/hevea virtual/latex-base )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ ocaml_lib=`ocamlc -where`
+ local myconf="--prefix /usr
+ --bindir /usr/bin
+ --libdir /usr/$(get_libdir)/coq
+ --mandir /usr/share/man
+ --emacslib /usr/share/emacs/site-lisp
+ --coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ --docdir /usr/share/doc/${PF}
+ --camlp5dir ${ocaml_lib}/camlp5
+ --lablgtkdir ${ocaml_lib}/lablgtk2"
+
+ use debug && myconf="--debug $myconf"
+ use norealanalysis && myconf="$myconf --reals no"
+ use norealanalysis || myconf="$myconf --reals all"
+ use doc || myconf="$myconf --with-doc no"
+
+ if use gtk; then
+ use ocamlopt && myconf="$myconf --coqide opt"
+ use ocamlopt || myconf="$myconf --coqide byte"
+ else
+ myconf="$myconf --coqide no"
+ fi
+ use ocamlopt || myconf="$myconf -byte-only"
+ use ocamlopt && myconf="$myconf --opt"
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure $myconf || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ emake COQINSTALLPREFIX="${D}" install || die
+ dodoc README CREDITS CHANGES
+
+ use gtk && domenu "${FILESDIR}/coqide.desktop"
+}