summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-06-13 21:54:19 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-06-13 21:54:19 +0000
commit970cac6ea6bf22eb6fcac4ab72b950eba8d01ee1 (patch)
treeed67f773ed2cc98b56ed54c1e1d457f24076315c /sci-mathematics
parentNew package, bug 185523. Thanks to Harry.TX, Julien Cynober, and all the othe... (diff)
downloadgentoo-2-970cac6ea6bf22eb6fcac4ab72b950eba8d01ee1.tar.gz
gentoo-2-970cac6ea6bf22eb6fcac4ab72b950eba8d01ee1.tar.bz2
gentoo-2-970cac6ea6bf22eb6fcac4ab72b950eba8d01ee1.zip
Version bump. Switched to EAPI4. Added static-libs flag
(Portage version: 2.1.10.2/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/ginac/ChangeLog8
-rw-r--r--sci-mathematics/ginac/files/ginac-1.5.7-gcc45.patch16
-rw-r--r--sci-mathematics/ginac/ginac-1.6.0.ebuild (renamed from sci-mathematics/ginac/ginac-1.5.7.ebuild)28
3 files changed, 22 insertions, 30 deletions
diff --git a/sci-mathematics/ginac/ChangeLog b/sci-mathematics/ginac/ChangeLog
index 229394d05a52..e643bcbb6ea5 100644
--- a/sci-mathematics/ginac/ChangeLog
+++ b/sci-mathematics/ginac/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/ginac
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ChangeLog,v 1.50 2011/04/26 08:46:53 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ChangeLog,v 1.51 2011/06/13 21:54:19 bicatali Exp $
+
+*ginac-1.6.0 (13 Jun 2011)
+
+ 13 Jun 2011; Sébastien Fabbro <bicatali@gentoo.org> -ginac-1.5.7.ebuild,
+ -files/ginac-1.5.7-gcc45.patch, +ginac-1.6.0.ebuild:
+ Version bump. Switched to EAPI4. Added static-libs flag
26 Apr 2011; Markos Chandras <hwoarang@gentoo.org> ginac-1.5.8.ebuild:
Stable on amd64 wrt bug #360605
diff --git a/sci-mathematics/ginac/files/ginac-1.5.7-gcc45.patch b/sci-mathematics/ginac/files/ginac-1.5.7-gcc45.patch
deleted file mode 100644
index df0a61d79f3c..000000000000
--- a/sci-mathematics/ginac/files/ginac-1.5.7-gcc45.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Fixing build with gcc 4.5.
-Upstream fix e22d2ed95925d870876c4fcd922ea2a9cfdbdab1
-
-http://bugs.gentoo.org/show_bug.cgi?id=321411
-
---- ginac/function.pl
-+++ ginac/function.pl
-@@ -1314,7 +1314,7 @@
-
- // No derivative defined? Then return abstract derivative object
- if (opt.power_f == NULL)
-- return (new power::power(*this, power_param))->setflag(status_flags::dynallocated |
-+ return (new GiNaC::power(*this, power_param))->setflag(status_flags::dynallocated |
- status_flags::evaluated);
-
- current_serial = serial;
diff --git a/sci-mathematics/ginac/ginac-1.5.7.ebuild b/sci-mathematics/ginac/ginac-1.6.0.ebuild
index ca1753c17972..8c75df3b261d 100644
--- a/sci-mathematics/ginac/ginac-1.5.7.ebuild
+++ b/sci-mathematics/ginac/ginac-1.6.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ginac-1.5.7.ebuild,v 1.3 2011/04/25 15:05:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ginac-1.6.0.ebuild,v 1.1 2011/06/13 21:54:19 bicatali Exp $
-EAPI=2
+EAPI=4
inherit eutils
DESCRIPTION="C++ library and tools for symbolic calculations"
@@ -12,7 +12,7 @@ HOMEPAGE="http://www.ginac.de/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc"
+IUSE="doc static-libs"
RDEPEND=">=sci-libs/cln-1.2.2"
DEPEND="${RDEPEND}
@@ -25,33 +25,35 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.5.1-pkgconfig.patch
- epatch "${FILESDIR}"/${P}-gcc45.patch
+}
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ $(use_enable static-libs static)
}
src_compile() {
- emake || die "emake failed"
+ emake
if use doc; then
export VARTEXFONTS="${T}"/fonts
cd "${S}/doc/reference"
#pdf generation for reference failed (1.5.1), bug #264774
#emake html pdf || die "emake doc reference failed"
- emake html || die "emake ref failed"
+ emake html
cd "${S}/doc/tutorial"
- emake ginac.pdf ginac.html || die "emake doc tutorial failed"
+ emake ginac.pdf ginac.html
fi
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README NEWS AUTHORS || die
-
+ default
if use doc; then
cd doc
insinto /usr/share/doc/${PF}
- newins tutorial/ginac.pdf tutorial.pdf || die "tutorial install failed"
- #newins reference/ginac.pdf reference.pdf || die "ref install failed"
+ newins tutorial/ginac.pdf tutorial.pdf
insinto /usr/share/doc/${PF}/html/reference
- doins -r reference/html_files/* || die
+ doins -r reference/html_files/*
insinto /usr/share/doc/${PF}/html
newins tutorial/ginac.html tutorial.html
insinto /usr/share/doc/${PF}/examples