summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-07 08:05:21 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-07 08:05:21 +0000
commit93f8d50c40bff0dfb05fae91d4db2d3a0d17d0fe (patch)
treebe2d3a33f710429411b5e9101c3cb7f4a806e56f /sci-mathematics
parentBump for #460648 (diff)
downloadgentoo-2-93f8d50c40bff0dfb05fae91d4db2d3a0d17d0fe.tar.gz
gentoo-2-93f8d50c40bff0dfb05fae91d4db2d3a0d17d0fe.tar.bz2
gentoo-2-93f8d50c40bff0dfb05fae91d4db2d3a0d17d0fe.zip
sci-mathematics/gmp-ecm: Fix download location; bump to EAPI=5 and clean some die
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gmp-ecm/ChangeLog6
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-6.4.3-r5.ebuild4
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild28
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild31
-rw-r--r--sci-mathematics/gmp-ecm/metadata.xml16
5 files changed, 44 insertions, 41 deletions
diff --git a/sci-mathematics/gmp-ecm/ChangeLog b/sci-mathematics/gmp-ecm/ChangeLog
index ae9fe441d542..3da8477991ca 100644
--- a/sci-mathematics/gmp-ecm/ChangeLog
+++ b/sci-mathematics/gmp-ecm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/gmp-ecm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/ChangeLog,v 1.8 2013/03/07 07:51:19 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/ChangeLog,v 1.9 2013/03/07 08:05:21 jlec Exp $
+
+ 07 Mar 2013; Justin Lecher <jlec@gentoo.org> gmp-ecm-6.4.3-r5.ebuild,
+ gmp-ecm-6.4.4.ebuild, gmp-ecm-9999.ebuild, metadata.xml:
+ Fix download location; bump to EAPI=5 and clean some die
*gmp-ecm-6.4.4 (07 Mar 2013)
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-6.4.3-r5.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-6.4.3-r5.ebuild
index 95baa1ab69cb..b241fe52ed65 100644
--- a/sci-mathematics/gmp-ecm/gmp-ecm-6.4.3-r5.ebuild
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-6.4.3-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/gmp-ecm-6.4.3-r5.ebuild,v 1.1 2013/01/01 17:08:45 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/gmp-ecm-6.4.3-r5.ebuild,v 1.2 2013/03/07 08:05:21 jlec Exp $
EAPI=4
DESCRIPTION="Elliptic Curve Method for Integer Factorization"
@@ -29,7 +29,7 @@ S=${WORKDIR}/ecm-${PV}
src_configure() {
if use gwnum; then myconf="--with-gwnum=/usr/lib"; fi
# --enable-shellcmd is broken
- econf $(use_enable openmp) $myconf || die
+ econf $(use_enable openmp) $myconf
}
src_compile() {
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild
index 75c70616162d..45aee228deb7 100644
--- a/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild,v 1.1 2013/03/07 07:51:19 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild,v 1.2 2013/03/07 08:05:21 jlec Exp $
+
+EAPI=5
-EAPI=4
DESCRIPTION="Elliptic Curve Method for Integer Factorization"
HOMEPAGE="http://ecm.gforge.inria.fr/"
-SRC_URI="https://gforge.inria.fr/frs/download.php/30965/${P}.tar.gz"
+SRC_URI="https://gforge.inria.fr/frs/download.php/32159/${P}.tar.gz"
inherit eutils flag-o-matic
@@ -14,8 +15,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+blas +custom-tune gwnum -openmp test"
-# gmp 5.1 breaks a few things with this version
-DEPEND="dev-libs/gmp
+DEPEND="
+ dev-libs/gmp
blas? ( sci-libs/gsl )
gwnum? ( sci-mathematics/gwnum )
openmp? ( sys-devel/gcc[openmp] )"
@@ -24,13 +25,14 @@ RDEPEND="${DEPEND}"
# can't be both enabled
REQUIRED_USE="gwnum? ( !openmp )"
-# little oopsie
-S=${WORKDIR}/ecm-6.4.3
+S=${WORKDIR}/ecm-${PV}
+
+MAKEOPTS+=" -j1"
src_configure() {
if use gwnum; then myconf="--with-gwnum=/usr/lib"; fi
# --enable-shellcmd is broken
- econf $(use_enable openmp) $myconf || die
+ econf $(use_enable openmp) $myconf
}
src_compile() {
@@ -38,21 +40,17 @@ src_compile() {
if use custom-tune; then
use amd64 && cd x86_64
use x86 && cd pentium4
- emake -j1 || die # build libecm/libmulredc.la
+ emake
cd .. && make bench_mulredc || die
sed -i -e 's:#define TUNE_MULREDC_TABLE://#define TUNE_MULREDC_TABLE:g' `readlink ecm-params.h` || die
sed -i -e 's:#define TUNE_SQRREDC_TABLE://#define TUNE_SQRREDC_TABLE:g' `readlink ecm-params.h` || die
./bench_mulredc | tail -n 4 >> `readlink ecm-params.h` || die
fi
- emake -j1 || die
+ default
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
mkdir -p "${D}/usr/include/${PN}/"
cp "${S}"/*.h "${D}/usr/include/${PN}" || die "Failed to copy headers" # needed by other apps like YAFU
}
-
-src_test() {
- make check || die
-}
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild
index a1d21588fcce..aae03654a492 100644
--- a/sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild
@@ -1,21 +1,23 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild,v 1.2 2013/01/01 17:08:45 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/gmp-ecm-9999.ebuild,v 1.3 2013/03/07 08:05:21 jlec Exp $
+
+EAPI=5
-EAPI=4
DESCRIPTION="Elliptic Curve Method for Integer Factorization"
HOMEPAGE="http://ecm.gforge.inria.fr/"
#SRC_URI="https://gforge.inria.fr/frs/download.php/30965/${P}.tar.gz"
ESVN_REPO_URI="svn://scm.gforge.inria.fr/svnroot/ecm/trunk"
-inherit eutils subversion autotools
+inherit autotools eutils flag-o-matic subversion
LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS=""
IUSE="blas +custom-tune gwnum -openmp test"
-DEPEND="dev-libs/gmp
+DEPEND="
+ dev-libs/gmp
blas? ( sci-libs/gsl )
gwnum? ( sci-mathematics/gwnum )
openmp? ( sys-devel/gcc[openmp] )"
@@ -26,6 +28,8 @@ REQUIRED_USE="gwnum? ( !openmp )"
S=${WORKDIR}/ecm-${PV}
+MAKEOPTS+=" -j1"
+
src_prepare() {
eautoreconf
}
@@ -33,28 +37,25 @@ src_prepare() {
src_configure() {
if use gwnum; then myconf="--with-gwnum=/usr/lib"; fi
# --enable-shellcmd is broken
- econf $(use_enable openmp) $myconf || die
+ econf $(use_enable openmp) $myconf
}
src_compile() {
+ append-ldflags "-Wl,-z,noexecstack"
if use custom-tune; then
use amd64 && cd x86_64
use x86 && cd pentium4
- emake -j1 || die # build libecm/libmulredc.la
+ emake
cd .. && make bench_mulredc || die
- sed -i -e 's:#define TUNE_MULREDC_TABLE://#define TUNE_MULREDC_TABLE:g' ecm-params.h || die
- sed -i -e 's:#define TUNE_SQRREDC_TABLE://#define TUNE_SQRREDC_TABLE:g' ecm-params.h || die
- ./bench_mulredc | tail -n 4 >> ecm-params.h || die
+ sed -i -e 's:#define TUNE_MULREDC_TABLE://#define TUNE_MULREDC_TABLE:g' `readlink ecm-params.h` || die
+ sed -i -e 's:#define TUNE_SQRREDC_TABLE://#define TUNE_SQRREDC_TABLE:g' `readlink ecm-params.h` || die
+ ./bench_mulredc | tail -n 4 >> `readlink ecm-params.h` || die
fi
- emake -j1 || die
+ default
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
mkdir -p "${D}/usr/include/${PN}/"
cp "${S}"/*.h "${D}/usr/include/${PN}" || die "Failed to copy headers" # needed by other apps like YAFU
}
-
-src_test() {
- make check || die
-}
diff --git a/sci-mathematics/gmp-ecm/metadata.xml b/sci-mathematics/gmp-ecm/metadata.xml
index 33cbddc879e8..1723f3d6a58c 100644
--- a/sci-mathematics/gmp-ecm/metadata.xml
+++ b/sci-mathematics/gmp-ecm/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>patrick@gentoo.org</email>
- <name>Patrick Lauer</name>
- </maintainer>
- <use>
- <flag name='custom-tune'>Improve performance of some operations by selecting machine-specific defaults</flag>
- <flag name='gwnum'>Use GWNum lib where possible</flag>
- </use>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <use>
+ <flag name="custom-tune">Improve performance of some operations by selecting machine-specific defaults</flag>
+ <flag name="gwnum">Use GWNum lib where possible</flag>
+ </use>
</pkgmetadata>