summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-04-12 11:58:46 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-04-12 11:58:46 +0000
commit8dbdee93c5a5fe5f71d097270700f7d4e12590b7 (patch)
tree23f904e3fd78e4c362efc18e0bde634ccd001169 /sci-mathematics
parentCleanup old versions. (diff)
downloadgentoo-2-8dbdee93c5a5fe5f71d097270700f7d4e12590b7.tar.gz
gentoo-2-8dbdee93c5a5fe5f71d097270700f7d4e12590b7.tar.bz2
gentoo-2-8dbdee93c5a5fe5f71d097270700f7d4e12590b7.zip
Added patch for ecl-10.4.1
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/maxima/ChangeLog8
-rw-r--r--sci-mathematics/maxima/files/maxima-5.20.1-ecl-10.4.1.patch80
-rw-r--r--sci-mathematics/maxima/maxima-5.20.1-r2.ebuild (renamed from sci-mathematics/maxima/maxima-5.20.1-r1.ebuild)7
3 files changed, 92 insertions, 3 deletions
diff --git a/sci-mathematics/maxima/ChangeLog b/sci-mathematics/maxima/ChangeLog
index 8b34c4951b63..6850a2f0522c 100644
--- a/sci-mathematics/maxima/ChangeLog
+++ b/sci-mathematics/maxima/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/maxima
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.76 2010/03/06 08:49:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.77 2010/04/12 11:58:46 grozin Exp $
+
+*maxima-5.20.1-r2 (12 Apr 2010)
+
+ 12 Apr 2010; Andrey Grozin <grozin@gentoo.org> -maxima-5.20.1-r1.ebuild,
+ +maxima-5.20.1-r2.ebuild, +files/maxima-5.20.1-ecl-10.4.1.patch:
+ Added patch for ecl-10.4.1
*maxima-5.20.1-r1 (06 Mar 2010)
diff --git a/sci-mathematics/maxima/files/maxima-5.20.1-ecl-10.4.1.patch b/sci-mathematics/maxima/files/maxima-5.20.1-ecl-10.4.1.patch
new file mode 100644
index 000000000000..9f11b2614ad4
--- /dev/null
+++ b/sci-mathematics/maxima/files/maxima-5.20.1-ecl-10.4.1.patch
@@ -0,0 +1,80 @@
+diff -u -r maxima-5.20.1/lisp-utils/defsystem.lisp maxima-5.20.1-patched/lisp-utils/defsystem.lisp
+--- maxima-5.20.1/lisp-utils/defsystem.lisp 2009-05-13 10:01:40.000000000 +0200
++++ maxima-5.20.1-patched/lisp-utils/defsystem.lisp 2010-04-04 16:22:53.000000000 +0200
+@@ -871,6 +871,8 @@
+ :cormanlisp
+ :scl
+ :abcl
++ :ccl
++ :ecl
+ (and allegro-version>= (version>= 4 1)))
+ (eval-when #-(or :lucid)
+ (:compile-toplevel :load-toplevel :execute)
+@@ -993,10 +995,10 @@
+
+ #+abcl (defpackage make (:use "COMMON-LISP") (:nicknames "MK"))
+
+-#+(or clisp cormanlisp ecl (and gcl defpackage) sbcl)
++#+(or clisp cormanlisp ecl (and gcl defpackage) sbcl ccl)
+ (defpackage "MAKE" (:use "COMMON-LISP") (:nicknames "MK"))
+
+-#-(or :sbcl :cltl2 :lispworks :ecl :scl :abcl)
++#-(or :sbcl :cltl2 :lispworks :ecl :scl :abcl :ccl)
+ (in-package :make :nicknames '("MK"))
+
+ ;;; For CLtL2 compatible lisps...
+@@ -1052,7 +1054,7 @@
+ (eval-when (compile load eval)
+ (in-package :make))
+
+-#+(or ecl abcl)
++#+(or ecl abcl ccl)
+ (in-package :make)
+
+ ;;; *** Marco Antoniotti <marcoxa@icsi.berkeley.edu> 19970105
+@@ -4127,9 +4129,9 @@
+ (unless *old-require*
+ (setf *old-require*
+ (symbol-function
+- #-(or (and :excl :allegro-v4.0) :mcl :sbcl :scl :lispworks :abcl) 'lisp:require
++ #-(or (and :excl :allegro-v4.0) :ecl :mcl :sbcl :scl :lispworks :abcl :openmcl) 'lisp:require
+ #+(and :excl :allegro-v4.0) 'cltl1:require
+- #+(or :sbcl :scl) 'cl:require
++ #+(or :ecl :sbcl :scl) 'cl:require
+ #+(or :lispworks3.1 :abcl) 'common-lisp::require
+ #+(and :lispworks (not :lispworks3.1)) 'system::require
+ #+:openmcl 'cl:require
+@@ -4139,9 +4141,9 @@
+ (unless *dont-redefine-require*
+ (let (#+(or :mcl (and :CCL (not :lispworks)))
+ (ccl:*warn-if-redefine-kernel* nil))
+- #-(or (and allegro-version>= (version>= 4 1)) :lispworks)
++ #-(or :ecl (and allegro-version>= (version>= 4 1)) :lispworks)
+ (setf (symbol-function
+- #-(or (and :excl :allegro-v4.0) :mcl :sbcl :scl :lispworks :abcl) 'lisp:require
++ #-(or (and :excl :allegro-v4.0) :mcl :sbcl :scl :lispworks :abcl :openmcl) 'lisp:require
+ #+(and :excl :allegro-v4.0) 'cltl1:require
+ #+(or :lispworks3.1 :abcl) 'common-lisp::require
+ #+(or :sbcl :scl) 'cl:require
+@@ -4150,6 +4152,12 @@
+ #+(and :mcl (not :openmcl)) 'ccl:require
+ )
+ (symbol-function 'new-require))
++ #+:ecl
++ (progn
++ (ext:package-lock "CL" nil)
++ (setf (symbol-function 'lisp:require)
++ (symbol-function 'new-require))
++ (ext:package-lock "CL" t))
+ #+:lispworks
+ (let ((warn-packs system::*packages-for-warn-on-redefinition*))
+ (declare (special system::*packages-for-warn-on-redefinition*))
+diff -u -r maxima-5.20.1/src/ecl-port.lisp maxima-5.20.1-patched/src/ecl-port.lisp
+--- maxima-5.20.1/src/ecl-port.lisp 2008-08-10 21:18:07.000000000 +0200
++++ maxima-5.20.1-patched/src/ecl-port.lisp 2010-04-04 16:23:02.000000000 +0200
+@@ -21,3 +21,5 @@
+
+ (si::trap-fpe 'floating-point-underflow nil)
+
++(ext:package-lock "CL" nil)
++
diff --git a/sci-mathematics/maxima/maxima-5.20.1-r1.ebuild b/sci-mathematics/maxima/maxima-5.20.1-r2.ebuild
index 4b8f12657393..d931fbc18c57 100644
--- a/sci-mathematics/maxima/maxima-5.20.1-r1.ebuild
+++ b/sci-mathematics/maxima/maxima-5.20.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.20.1-r1.ebuild,v 1.1 2010/03/06 08:49:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.20.1-r2.ebuild,v 1.1 2010/04/12 11:58:46 grozin Exp $
EAPI=2
inherit eutils elisp-common
@@ -46,7 +46,7 @@ for LISP in ${SUPP_LISPS}; do
RDEPEND="${RDEPEND} gcl? ( >=dev-lisp/gcl-2.6.8_pre[ansi] )"
else if [ "${LISP}" = "ecl" ]
then
- RDEPEND="${RDEPEND} ecl? ( >=dev-lisp/ecls-9.8.3 )"
+ RDEPEND="${RDEPEND} ecl? ( >=dev-lisp/ecls-10.4.1 )"
else if [ "${LISP}" = "openmcl" ]
then
RDEPEND="${RDEPEND} openmcl? ( dev-lisp/clozurecl )"
@@ -105,6 +105,9 @@ src_prepare() {
# ClozureCL executable name is now ccl
epatch "${FILESDIR}"/${PN}-clozurecl.patch
+ # see http://osdir.com/ml/sage-devel/2010-04/msg00077.html
+ epatch "${FILESDIR}"/${P}-ecl-10.4.1.patch
+
epatch "${FILESDIR}"/${P}-emacs-version.patch
# remove rmaxima if not needed