summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-04-23 09:04:36 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-04-23 09:04:36 +0000
commit7f510ed8ac3790b489b46f6af1a68a606e97a2bb (patch)
tree9be13676e3632c7a591ecb250ef61c359aa0e52b /sci-mathematics
parentAdd qt-webkit dependency wrt bug #316441 (diff)
downloadgentoo-2-7f510ed8ac3790b489b46f6af1a68a606e97a2bb.tar.gz
gentoo-2-7f510ed8ac3790b489b46f6af1a68a606e97a2bb.tar.bz2
gentoo-2-7f510ed8ac3790b489b46f6af1a68a606e97a2bb.zip
Refactor ebuild to use python functions correctly. Fixes bug #316235
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/relational/ChangeLog7
-rw-r--r--sci-mathematics/relational/relational-0.10.ebuild9
2 files changed, 12 insertions, 4 deletions
diff --git a/sci-mathematics/relational/ChangeLog b/sci-mathematics/relational/ChangeLog
index c0545957820d..e23f5c3fe923 100644
--- a/sci-mathematics/relational/ChangeLog
+++ b/sci-mathematics/relational/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/relational
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/relational/ChangeLog,v 1.2 2009/12/18 16:24:47 hwoarang Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/relational/ChangeLog,v 1.3 2010/04/23 09:04:36 hwoarang Exp $
+
+ 23 Apr 2010; Markos Chandras <hwoarang@gentoo.org> relational-0.10.ebuild:
+ Refactor ebuild to use python functions correctly. Fixes bug #316235
18 Dec 2009; Markos Chandras <hwoarang@gentoo.org> relational-0.10.ebuild:
Update homepage url
diff --git a/sci-mathematics/relational/relational-0.10.ebuild b/sci-mathematics/relational/relational-0.10.ebuild
index 720540e6cf1e..723ba58d0ea4 100644
--- a/sci-mathematics/relational/relational-0.10.ebuild
+++ b/sci-mathematics/relational/relational-0.10.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/relational/relational-0.10.ebuild,v 1.2 2009/12/18 16:24:47 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/relational/relational-0.10.ebuild,v 1.3 2010/04/23 09:04:36 hwoarang Exp $
EAPI="2"
+PYTHON_DEPEND="2"
inherit python distutils eutils
@@ -22,6 +23,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}"
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_compile() {
true
}