summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-06-09 16:31:24 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-06-09 16:31:24 +0000
commit762fd6d03697e3957b5a5b2ca40f5e12d9a4e147 (patch)
treead5970cae60831f8e3a5450d9da283a082284cf3 /sci-mathematics
parentfix build which was broken by multilib madness (diff)
downloadgentoo-2-762fd6d03697e3957b5a5b2ca40f5e12d9a4e147.tar.gz
gentoo-2-762fd6d03697e3957b5a5b2ca40f5e12d9a4e147.tar.bz2
gentoo-2-762fd6d03697e3957b5a5b2ca40f5e12d9a4e147.zip
Fixed for glibc underlinking, thanks to Ted Tanberry and Kobboi, bug #512472
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/euler/ChangeLog8
-rw-r--r--sci-mathematics/euler/euler-1.61.0.ebuild40
-rw-r--r--sci-mathematics/euler/files/configure-gentoo.patch11
3 files changed, 36 insertions, 23 deletions
diff --git a/sci-mathematics/euler/ChangeLog b/sci-mathematics/euler/ChangeLog
index 7137ea19fbd8..765c4a001210 100644
--- a/sci-mathematics/euler/ChangeLog
+++ b/sci-mathematics/euler/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/euler
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/euler/ChangeLog,v 1.19 2012/05/04 07:46:51 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/euler/ChangeLog,v 1.20 2014/06/09 16:31:24 bicatali Exp $
+
+ 09 Jun 2014; Sébastien Fabbro <bicatali@gentoo.org> euler-1.61.0.ebuild,
+ files/configure-gentoo.patch:
+ Fixed for glibc underlinking, thanks to Ted Tanberry and Kobboi, bug #512472
04 May 2012; Jeff Horelick <jdhore@gentoo.org> euler-1.61.0.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/sci-mathematics/euler/euler-1.61.0.ebuild b/sci-mathematics/euler/euler-1.61.0.ebuild
index 1bec7cbbb08f..4b7a67d5cf18 100644
--- a/sci-mathematics/euler/euler-1.61.0.ebuild
+++ b/sci-mathematics/euler/euler-1.61.0.ebuild
@@ -1,17 +1,20 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/euler/euler-1.61.0.ebuild,v 1.10 2012/05/04 07:46:51 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/euler/euler-1.61.0.ebuild,v 1.11 2014/06/09 16:31:24 bicatali Exp $
-EAPI="1"
+EAPI=5
-inherit autotools eutils
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils
DESCRIPTION="Mathematical programming environment"
HOMEPAGE="http://euler.sourceforge.net/"
SRC_URI="mirror://sourceforge/euler/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc -sparc x86"
+KEYWORDS="amd64 ppc -sparc x86 ~amd64-linux ~x86-linux"
IUSE=""
DEPEND="x11-libs/gtk+:2
@@ -20,26 +23,21 @@ DEPEND="x11-libs/gtk+:2
RDEPEND="x11-libs/gtk+:2
x11-misc/xdg-utils"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+PATCHES=(
+ "${FILESDIR}"/configure-gentoo.patch
+ "${FILESDIR}"/command-gcc4-gentoo.patch
+ "${FILESDIR}"/${PN}-glibc-2.4-gentoo.patch
+ "${FILESDIR}"/${PN}-xdg.patch
+ "${FILESDIR}"/${PN}-fortify.patch
+)
- epatch "${FILESDIR}"/configure-gentoo.patch
- epatch "${FILESDIR}"/command-gcc4-gentoo.patch
- epatch "${FILESDIR}"/${PN}-glibc-2.4-gentoo.patch
- epatch "${FILESDIR}"/${PN}-xdg.patch
- epatch "${FILESDIR}"/${PN}-fortify.patch
+src_prepare() {
# gentoo specific stuff
- sed -i -e '/COPYING/d' -e '/INSTALL/d' Makefile.am
+ sed -i -e '/COPYING/d' -e '/INSTALL/d' Makefile.am || die
sed -i \
-e "s:doc/euler:doc/${PF}:g" \
Makefile.am docs/Makefile.am \
- docs/*/Makefile.am docs/*/images/Makefile.am \
- src/main.c \
+ docs/*/Makefile.am docs/*/images/Makefile.am src/main.c \
|| die "sed for docs failed"
- eautoreconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ autotools-utils_src_prepare
}
diff --git a/sci-mathematics/euler/files/configure-gentoo.patch b/sci-mathematics/euler/files/configure-gentoo.patch
index fd83d1ab8291..e1e7c6ef1e6b 100644
--- a/sci-mathematics/euler/files/configure-gentoo.patch
+++ b/sci-mathematics/euler/files/configure-gentoo.patch
@@ -10,6 +10,17 @@ diff -Naur euler-1.61.0/configure.in euler-1.61.0-new/configure.in
AC_PROG_CC
AM_PROG_CC_STDC
AC_HEADER_STDC
+@@ -21,6 +19,10 @@
+
+
+ dnl Checks for libraries.
++dnl Check for libm for fmod()
++AC_SEARCH_LIBS([fmod], [m], [], [
++ AC_MSG_ERROR([unable to find the fmod() function])
++])
+
+
+ dnl Checks for header files.
diff -Naur euler-1.61.0/src/Makefile.am euler-1.61.0-new/src/Makefile.am
--- euler-1.61.0/src/Makefile.am 2005-10-30 22:48:35.000000000 +0000
+++ euler-1.61.0-new/src/Makefile.am 2006-02-08 23:41:32.000000000 +0000